• 0

Missing Asms File In XP Installation

  • 0

I’m trying to do a clean install of XP on an ACER from a CD in an external CD drive. The boot from the drive works fine and so does the initial copying of files, but when the computer restarts, an “Files Needed” window pops up saying that it needs file ‘asms’ (at 39 minutes remaining). I’ve tried the whole running ‘regedit.exe’ thing, but CMD says that it can’t execute the specified program. Since I was doing a full install, I can’t do anything. Please help!


1 Answer

  1. Here is what worked for me. I did try what was recommended by Microsoft to no avail.

    Re: the file asms missing from SP2 CD
    Hey Guys,
    You might be surprised with another unique answer to this solution that I have discovered. I don’t know if you guys remember this but MSCDEX.EXE used to be used for DOS to recognize CD-ROM drives. What I did was load this file once I got the ‘asms file’ error. How did I do this?
    I hit SHIFT + F10.. This loaded the command prompt. At this point you should be able to type the command.. Try either MSCDEXNT.EXE or MSCDEX.EXE

    Once this file loads you will notice your CD Drive will start to awaken and read data. Windows will then recognize the data in the drives.

    If you cannot load the MSCDEXNT command from the command prompt then run regedit from the command prompt. Through regedit do a File… Import… This will bring up an open Dialogue Box… Through this dialog box you can fish through your windows/system32 directory and right-click/open the mscdexnt.exe FILE…

    Good Luck people.. I know it’s a very odd solution but it worked for me..

    • 0