XP SP2 install keeps failing!

Self build / N/A
November 1, 2012 at 18:44:19
Specs: Vista Ultimate, SP2, 3.0Ghz/2Ghz
I have several computers which are failing an install of XP SP2. The install proceeds but when the system reboots I get the following error: Windows could not start because the following file is missing: c:\windows\system32\config\system. I've read all the fixes for this error and none of them work. When I try to do a directory of C:\, I get invalid directory emumeration. Let me give you some background: the PCs are new and come with Windows 7 Pro 64 bit. We are installing Windows XP SP2 over this from a script on the network. This was working in the past but all of a sudden, all of the new computers are having this issue. The image from the network proceeds but when Windows attempts to start, that's when the error appears. Safe mode stops at the file agpcpq.sys and then presents the same error. Can't use Recovery Console or any other fix because I can not get to a command prompt. Any ideas?

See More: XP SP2 install keeps failing!

Report •

November 1, 2012 at 19:19:14
Make sure you have the SATA Hard disk drive slipstreamed into the installation source: http://www.computing.net/howtos/sho...

You've been helped by a 14 year old.

Report •

November 2, 2012 at 03:08:02
We change SATA to IDE in the BIOS because the image script is old. This workaround was working in the past. What makes this even more confusing is that laptops work fine; it's just the desktops that have the problem and the desktops were working before also. As far as we know, nothing has changed.

Report •

November 2, 2012 at 07:55:06
"This was working in the past but all of a sudden, all of the new computers are having this issue".

If the computers in question are new they may not be able to run WinXP. At the very least you may need to slipstream some critical drivers that obviously would not be included in the WinXP sp2 CD.

I recommend you slipstream SP3, SATA controller drivers and possibly chipset drivers into the WinXP sp2 files and then burn a new CD. nliteos makes the slipstream very easy to do. Get nlitos at the link below.

Do you have non-essential external hardware connected? If so, disconnect it until after the installation is complete and updated.


Report •

Related Solutions

November 12, 2012 at 16:51:18
I just had an installed XPSP3 that has been running for two years fail with the missing \system\ and the BSOD 0x0000007b (0xF78D2524...).
It has SATA enabled with AHCI - which I usually can't get XP to install with - but it worked for some reason 2 years ago so I left it (Seagate 320gb HD).
After this failure, I finally set the SATA to ATA (vs AHCI) in the BIOS - and now the install is working fine.
Why it worked initially, and for the last 2 years - I don't know.
Why it failed suddenly - I don't know (I have the BIOS access locked, so user didn't play it it, I'm certain).
I haven't pushed out any Microsoft updates, but can't swear the user didn't initiate this on his own (he's on holiday for a few more days).
Just posting here to hopefully make it easier for me to find it if it's an issue again (kept running into solutions to use F6 to add Mfr driver, before I changed the BIOS).

Report •

Ask Question