XP Hangs on pci.sys file! plz help

June 16, 2009 at 18:53:10
Specs: Windows XP
Hello everyone,

Before any of this happened, I installed Norton Ghost, and switched my DVD drive with a CD burner. I had to restart the computer for some reason, when I logged into XP, all the desktop icons showed and everything, then the computer just froze

So i pressed the "reset" switch on my computer. Then my computer started to run the "Chkdsk" on my hard drive. It found alot of errors and dealt with them successfully. Now every time I restart, my computer hangs at the following file (the splash screen doesn't even show!)


Things I have tried:

1.) edited the boot.ini file so that I can see which drivers are loaded by adding:

/fastdetect /noguiboot /sos /bootlog

at the end

2.) Can't boot into safe mode....also hangs at pci.sys

3.) Expanding the pci.sys file from an XP cd to \windows\system32\drivers\pci.sys with the following command

Expand D:\i386\pci.sy_ C:\windows\system32\drivers /y

no luck.

4.) Tried to 'Repair install' booting from the Windows XP cd, then going to "repair this installation". Completed successfully, but still hangs at pci.sys

5.) I have an XP installation on a different hard drive (also installed on this computer) and I can boot successfully into there. So i tried replacing the pci.sys file from that installation, but no go.

6.) Tried switching back to the dvd burner, no go. Tried removing both dvd drive and cd burner, still nothing.

I have no idea what else to try...It just doesn't get passed the pci.sys file :(

Any help would be appreciated.

Thanks alot.

See More: XP Hangs on pci.sys file! plz help

Report •

June 16, 2009 at 21:00:49
If you have identified that the "hang" is pci.sys because you have seen it as the last item on the list of files loading...I suspect that the "next" file loading is the culprit, not pci.sys, since the list you see is files that have successfully loaded (as a general rule).

Report •

June 17, 2009 at 16:13:29
hey IMpatient thanks for the reply!

I tried your suggestion but didn't have any luck. I checked which file was after pci.sys by adding /fastdetect /noguiboot /sos /bootlog to the XP installation on my other hard drive. The file that was after pci.sys was "isapnp.sys".

I tried to replace isapnp.sys with my XP installation on my other HD but no luck. Then I tried to replace it from my Windows XP cd, again it didn't work. It still hangs at pci.sys.

Just a note: My XP that is having problems was running SP3. But the Windows XP cd, and the XP on my other HD dont have any service packs. Do the files i copy into my XP SP3 have to be from a SP3 source?

Report •

June 17, 2009 at 18:33:43
Update: I updated my XP installation on the other HD to a SP3, then copied pci.sys from this installation the problematic XP installation, but it is still having the same problem.

This seems to be a rare problem since I am having a hard time finding anything on google.

Does anyone else have any idea what I can try?

Report •

Related Solutions

June 17, 2009 at 23:38:41
The loading order from your other HDD/OS is not necessarily the same order as your problem OS, but that was certainly worth a try.

On another note, in my own experience, the MS "chkdsk" is not foolproof. You could try to manually re-try a chkdsk, or try a (more reliable?) 3rd-party utility. Be prepared for it to take several hours.

Report •

June 17, 2009 at 23:53:01
One more thing... re.: your 1st post: you should have renamed your problematic XP's pci.sys to pci.old or something...THEN "expand D:\i386...etc" That's how Bill Gates would have done it :)

PS Is there a reason you have not explained why you have 2 hard drives on the same computer, both of them running XP?

Report •

June 18, 2009 at 04:58:10
hi IMpatient, I will try a chkdsk using a 3rd party application. I have already ran the windows chkdsk twice already. First using "chkdsk /p" then "chkdsk /r".

I thought that "isapnp.sys" was after pci.sys because the three files that loaded before pci.sys were exactly in the same order in both XP's.

"One more thing... re.: your 1st post: you should have renamed your problematic XP's pci.sys to pci.old or something...THEN "expand D:\i386...etc" That's how Bill Gates would have done it :) "

Yep i have backed up my whole /windows/system32/drivers folder before trying anything :)

I have an XP installation on my other HD just as a backup (in case something happens to my main XP installation), and it proved useful :) But I mostly use that HD for storing data.

I will give the 3rd party chkdsk a try. Thanks again.

Report •

June 20, 2009 at 09:48:58

So I tried scanning the HD with a Gateway tool called GWSCAN 5.12. It has a "quick test" and "extended test". The extended test includes the quick test.

I ran the extended test. The quick scan completed without any errors. The extended scan started, and said it is going to take about 1hr to complete. I left it on overnight, when I checked the next morning, the computer was off. Tried to boot up XP but gave the same problem. I wasn't sure if the extended scan completed or not, so I ran it again. I sat there for like 10 minutes, everything seemed to be running ok, so I left and came back after 1hr but it was off again. It still does not boot into XP.

I think during the scan it doesn't know how to handle some kind of error or something and just shuts off. Maybe I can try another scanning tool? Do you have any suggestions?

Report •

June 20, 2009 at 13:42:58
Are you dual booting two XP installations on this computer?
If you are, are you SURE you're booting the one you ran the Repair installation on?
Windows Setup will complete successfuly even if that's wrong.

Apparently GWSCAN 5.12 runs from MsDos - you are supposed to boot from a floppy, or from a bootable CD, with that on it - did you do that?
You don't run it from the hard drive.

If you have any suspicion there is something wrong with your operating system or the data on your hard drive, you don't use a Windows based program to test the hard drive, or run a Dos based program from the hard drive.

That was made in 2007 - I have found some older hard drive diagnostic programs don't work properly with more recent hard drives - e.g. older versions of either MaxBlast or Powermax, one of the two.
How old is the hard drive? If it's newer you may need a newer program to test it with.

(thanks to Dan Penny for this link:)
Hard Drive Diagnostics Tools and Utilities

If you don't have a floppy drive, you can get a CD image diagnostic utility from most hard drive manufacturer's web sites, but obviously you would need to make a burned CD, preferably a CD-R for best compatibilty, on another computer if you need to.

It's NOT normal for the bootable version of a hard drive diagnostic utility, or for that matter for Windows, to shut off the computer automatically without without you setting some setting, or the program having some default setting, that does that.
If the hard drive diagnostic progam quits, it should merely return to MsDos - normally it will not shut off the computer.

In that case you probably have something else going on, such as
- some ACPI related setting in the bios Setup is shutting off the computer after a certain period of inactivity. I had a friend's mboard that was set that way - I didn't discover it until Windows stopped working on that computer and I tried running a floppy bootable program that took a while to run - apparently Windows over-rides that bios setting when Windows has loaded properly.
- your power supply is defective
Failing power supplies are common and can cause your symptoms.
Check your PS.
See response 4 in this:
- your cpu has overheated to the point the mboard automatically shut down the mboard - in that case the mboard probably won't start up again untill the cpu has cooled below a certain temp. Open up the case and make sure the cpu fan spins when the computer is running. If there is mung all over the cpu fan and heatsink, remove the AC to the computer and clean them off.
- your mboard has bad capacitors.
Open up your case and examine the mboard to see if you have bad capacitors, and/or other findable signs of mboard damage .

This was the original bad capacitor problem - has some example pictures.
History of why the exploding capacitors and which mboard makers were affected:

What to look for, mboard symptoms, example pictures:
Home page that site
- what the problem is caused by
- he says there are STILL bad capacitors on more recent mboards.

Pictures of blown capacitors, other components, power supplies, Athlon cpu's, etc.:

Report •

June 20, 2009 at 21:39:08
Hey Tubesandwires,

First I want to say thanks for writing such an informative post! :)

Yes I dual boot XP installations on this computer. (I also have an option for booting into my removable HD which has an XP installation as well)

This is what my boot screen looks like:

Windows XP Main - (The one having problems, Western Digital HD)
Windows XP New - (I can boot into this just fine, Seagate HD)
Windows XP Removable - (Can boot into this as well, Samsung HD)
Recovery Console

"are you SURE you're booting the one you ran the Repair installation on? "

I am pretty sure I ran the windows repair on the correct XP installation (the Western Digital HD). I think I will unplug the other two HD's and try the repair installation again, then try booting into it...just to make sure.


About my computer shutting off. It is because of the 3rd reason in your post. My case lid has a fan, and if it is not attached to the case, the computer will shut off when it is under load and gets too hot (I figured this out a few months ago when it kept shutting off while playing L4D). So that's why GSCAN did not complete, the case lid wasn't on.

I have to wait about 5 - 10 minutes before I am able to turn the computer back on.


So GSCAN completed successfully after I put the case lid back on. Yes I ran it from a bootable cd since I dont have a floppy drive. It did not find any errors on the hard drive. I still cannot boot into the main XP installation (same pci.sys problem).

I tried installing 3 floppy drives on this computer with no luck. It cant read the floppy properly, and gives the " Windows was unable to complete the format" when I try to format. But anyway that is a different problem.

My hard drive is Western Digital Caviar SE WD2500JS 250GB 7200 RPM 8MB. I'm not excatly sure when I bought it. I think it has been over 2 years.

I will try searching for a diagnostic utility by Western Digital, and I will try the utilities that are on the link that you posted.

Thanks again for your help :) I will let you know how it goes.

Report •

June 20, 2009 at 22:06:16
"I had to restart the computer for some reason"

Does the above mean that you swapped the optical drives while the computer was running?

Report •

June 21, 2009 at 08:30:59
No...I think it was because I just installed norton ghost and it told me I had to restart. Then I logged into windows XP, Adobe gave me a message that an update was available, i pressed install. Soon after that the computer had froze. So i had to reset the computer manually. then the Chkdsk screen showed... which is where the problem started...

I scanned my hard drive using "Data LifeGuard Diagnostics for Windows" on my WD HD. Both the "quick" and "extended" tests passed. However, the SMART status indicated a "fail" for the WD HD. Here is a screenshot of the Diagnostic:


It indicates that the other two HD's are IDE, but they are actually SATA.

I tried rebooting into XP with no luck. :(

Report •

June 21, 2009 at 08:34:01
So the WD drive tests OK. You don't need to test it with something else then.
Gscan is probably a slightly modified drive manufacturer's diagnostic program - e.g. Seagate's SeaTools has tested any brand of hard drive for me even when none of theirs is connected, though I've found it may generate an incorrect (sometimes it's impossible) message about SMART or similar when you first start it if it isn't a Seagate or Maxtor drive - you merely ignore the message and continue (that doesn't affect the tests).

I have noted that when you have more than one XP (or 2000) installation on a computer and you run the second Repair choice when you boot from the CD - Repair your existing Windows installation or similar (many call that a Repair Install - I prefer to call it a Repair Setup - Microsoft has never used Install for their operating systems - they use Setup), or when you use the Recovery Console, the drive letters are NOT necessarily the same as they are in Windows.
To avoid choosing the wrong one....
If the two hard drive XP installations are on different hard drives, disconnect the one that's okay before you run the Repair installation (I prefer to call it a Repair Setup).
- or - the drive letters Setup shows before the Repair installation are probably the same as the Recovery Console shows -
make note of some file or folder that's in the \Windows folder on the working XP that's probably not on the other non working one, and use the Dir command in the Recovery Console to make sure you're choosing the right XP installation
- or - if you know the volume label is different for the two XP Windows partitions, use the volume (or dir? - the volume label shown at the end of the list?) command in Recovery Console to confirm you're choosing the right one.

Another thing is if you want XP to see itself as assigned to the C partition on each XP installation, XP won't assign itself C if Setup finds that hard drive partitions already set up on the computer it recognizes have been assigned drive letters and XP recognizes that - Setup will then use the next available drive letter for the partition Windows itself is installed on . You can find which drive letter Windows sees itself as assigned to in System Information.

If you want XP to see itself as assigned to the C partition on each XP installation, disconnect all other hard drives while running Setup, or disable all other hard drives from being detected in the bios Setup (you may need to change jumpers on IDE drives when you do that). If there is more than one partition that has already been partitioned and formatted using something XP recognizes on the only hard drive connected, use something such as Partition Magic (or the freeware Partition Logic?) to HIDE the other partition(s) before you run Setup. (NOTE that PM uses different rules to determine which drive partition is assigned which letter than XP and 2000 do - make sure you HIDE the right partitions)
That works for sure for a XP or 2000 Setup from scratch, however, I'm not not sure if running a Repair installation (Repair Setup) will change that drive letter to C if it was something other than C previously, because running it retains most existing settings.
If doing that messes up your dual boot after you have re-connected your drives after Setup has finished , you can easily fix that in the Recovery Console by using bootcfg /rebuild ( I can supply additional info about that) .
If doing that messes up the drive letters assigned to partitions or other drives after you have re-connected your drives after Setup has finished, you can change the drive letter assigned to any drive except the one Window has booted from in Disk Management (in Control Panel - Administrative Tools - Computer Management; I can supply additional info about that).

"I tried installing 3 floppy drives on this computer with no luck. It cant read the floppy properly, and gives the " Windows was unable to complete the format" when I try to format. But anyway that is a different problem."

Did you try more than one floppy disk?
If you didn't, I have found floppies made since about 2000 are a lot more likely to have undetected bad sectors on them or they are a lot more likely to develop bad sectors on them in a relatively short time even if they initially test as being free of them, because quailty control is not as good as it used to be. I have about 50 such floppies (the idea being when I have ten of a brand I can usually exchange them for a new box of ten for free), and have thrown away many others - they either were found to have some bad sectors on them, or they became so defective they could not be formatted when I attempted to format them. Sometimes as many as 2 or 3 in ten floppies of a brand have such defects.
If a floppy cannot be formatted, try it in another floppy drive you know works fine - if it still can't be formatted, the disk is one of those defective disks.
I always check a floppy disk for undetected bad sectors whenever I want to place data on it, whether it is new or being re-used, by performing a FULL Format on it - a FULL Format is very good at detecting un-detected bad sectors. If bad sectors are found, I DO NOT use that floppy for any important data I can't afford to loose, because it's likely a floppy made since 2000 will develop more bad sectors over time.
E.g. in XP, RIGHT click on the A drive letter with a floppy disk in the drive, choose Format, DO NOT select the Quick format box. When the format is finished. RIGHT click on the floppy and choose Properties - there should be NO bad sectors, 1,457,664 bytes usable.

Another thing is the quality control for newer floppy drives isn't as good as it used to be. It's very important that the floppy drive's heads are aligned properly, within a specific standard tolerance. If the alignment of a drive is out of whack, floppies made in a drive will work fine in that drive, but they don't work fine in other floppy drives. However, you're unlikely to encounter more than one mis-aligned drive at any one time.

If you did use more than one floppy disk......

It's extremely unlikely more than one floppy drive would be defective at any one time. If you used the same floppy cable for all three drives.....

I composed this about IDE data cables, but it applies to floppy data cables and other ribbon cables too....

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittant, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.
80 wire data cables are also easily damaged at either edge if the cable is sharply creased at a fold in the cable.

Try another data cable if in doubt.

Report •

June 21, 2009 at 09:31:27

I don't see where the WD diagnostics passed the drive. It states the 250 failed.


The SATA drives were identified as IDE drives because they are configured to run in an IDE mode. That is nothing to be concerned about.

I am still not clear on how you swapped out your CD drive. If you were shut down and unplugged or not?

If your CD rive is connected to the SAME cable as the boot IDE drive then you may simply have the jumpers on the CD drive set wrong. That can stop both of the drives on that cable to function wrong.

You need to look at the jumper setting on the CD drive you removed and set the jumper on the replacement the same way. Don't just go by the positions but by the labels. For example if the old drive was set for Slave then set the new one for slave. CS (cable select) then set the new to CS.

Watch the POST screens at start up to make sure ALL your drives are identified by the BIOS.

Tap the pause key to freeze the screen temporarily if necessary. Hit the space bar to continue.

Report •

June 21, 2009 at 09:40:10
"I scanned my hard drive using "Data LifeGuard Diagnostics for Windows" on my WD HD. Both the "quick" and "extended" tests passed. However, the SMART status indicated a "fail" for the WD HD"

Did you use the latest version of Data LifeGuard Diagnostics for Windows?
I never use the Windows versions of drive diagnostics because if there's anything a little off about the Windows installation you're running it on/in the tests can produce false results.

What did the SMART related message say?
SMART is deliberately "dummied down" - it does NOT normally generate a error message unless the problem is SERIOUS, because doing so would un-necessarily tarnish the drive manufacturer's reputation.

Report •

June 21, 2009 at 09:47:43

The OP said one thing but the screen shots say different. Both WD and SMART failed the 250GB. Look at the OPs link.


Report •

June 21, 2009 at 09:50:10


I don't see where the WD diagnostics passed the drive. It states the 250 failed."

You should have guessed this from what I've sometimes mentioned in previous topics both you and I have responded to....
As usual, it took me a long time to compose what became Response 12 because of my crummy typing skills.
Response 11 wasn't there when I started to compose it.

He said he completed the Repair installation successfuly, it appears, after he swapped optical drives, so if that's the case there's no indication in his posts there's anything wrong with the optical drive's connection or jumpering after he swapped optical drives.

"The OP said one thing but the screen shots say different. Both WD and SMART failed the 250GB. "

I noticed that when I looked at his link. However, I've seen where a diagnostic fails a drive only because of the SMART error(s) - he didn't show us the full summary - that would be apparent in that.


As OtheHill has mentioned sometimes diagnostics see a SATA drive as an IDE drive, if the SATA controller mode in the bios Setup for the mboard is set to IDE compatible mode or similar and the drive is connected to the mboard SATA headers (for the main chipset SATA controller(s) - on some mboards there's an additional SATA controller chipset) . Since the WD drive is seen as SATA, it must be either connected to a different SATA drive controller - that's on a card, or connected to a SATA header for a second separate chipset SATA controller on the mboard (e.g. I've seen a few that have a JMB36x as well) , or there is more than one SATA controller in the bios Setup, one is set to IDE compatible mode, the other to SATA mode (though I've never seen that).

I would run the Dos bootable version of the Data Lifguard diagnostics to make sure, possibly also something else such as the Dos bootable Seatools which has been accurate for me for any brand of drive, but so far it sure looks like the WD drive is failing, and if so I wouldn't use it anymore myself - I would try to get what personal or other data than can't be reloaded off if it while it was still possible to do that, e.g. by accessing the WD drive from the other XP installation.

Report •

June 21, 2009 at 10:35:36
I haven't read through the whole post yet, but I just want to clear the confusion about the tests for now........

The Extended and Quick scans DID pass successfully. The "Failed" message in the screenshot is not from the extended/quick scans, it is from the SMART status, which is separate from the extended/quick scans. It generated a "FAIL" because of the "Multi Zone Error Rate" shown in the window on the right.

The window on the right was telling details about the SMART status, not the extended/quick scans.

Here is the screenshot showing results from the extended/quick scans:


Sorry about the confusion.

I will reply to the rest of the messages posted in a while.

Report •

June 21, 2009 at 10:36:01
I wasn't inferring the points I brought up were the current cause of the OPs problems. Simply pointing out discrepancies.

Report •

June 21, 2009 at 20:31:11
Hello guys,

I disconnected my Seagate & Samsung HD's and I ran the repair setup/installation again with only the WD HD installed. As expected, windows setup only found one XP installation on the hard drive, so I chose it to repair. It went well, but still did not fix the problem.


As for making all my XP's see the Main XP as "C"...
I dont really mind if all my XP installations dont see the main XP as drive "C". I only boot into them if something happens to my main XP installation. As long as the Main XP sees it as C, its all good.


Yep I tried more than 1 floppy, didn't work on any. They work fine on my work computers, but not at home...so the floppies are ok.

But I did not try a differnt Floppy data cable, I will give that a shot. I'll try to fix the floppy problem after I fix my XP problem though.



My computer was off when I swapped the optical drives. I tried booting into XP with only my Vid card/CPU/RAM/WD HD, but still did not fix the problem.

Right now I have the CD-RW and DVD-RW installed, they are both working fine. They show up during the POST screen.



Yes I think it was the latest version of Data LifeGuard Diagnostics. I got it from here, I'm pretty sure they put the latest version of the diagnostic:

I also burned the Data LifeGuard Diagnostics ISO to a CD, and tried booting up from it and running the extended test. It passed without any errors.

The SMART status failed due to the "Multi Zone Error Rate" as indicated in the screenshot:



I have already backed up important data from the WD HD. I still have not tried Seatools, but I will give it a shot. I have ran the Dos bootable version of Data LifeGurad diag and it passed both tests. Still cannot boot into XP.

I'll try looking into the BIOS and disable the "IDE compatible mode" if it is enabled. All the SATA cables are connected really close together on the mboard, and I think they should be part of the same controller...i dont really know, i am just guessing.

So, I'll give Seatoolsa a shot, and try to make the other two drives be recogized as SATA.

Thanks again for all the help! :)

Report •

June 21, 2009 at 22:20:37
Although SATA drives are considered to all run independently there are TWO SATA ports per SATA controller and are usually identified as SATA 1 master, SATA 1 slave. SATA 2 master, SATA 2 slave. You get the idea.

In addition to that information some SATA ports on some motherboards have certain SATA ports that do not support a bootable device, only storage devices.

You need to consult with your manual to see if that applies in your case.

Report •

June 29, 2009 at 07:35:33
Hey guys, sorry for the late reply, I was away for a few days.

I tried Seatools using the windows version. Scanned using the "Long Drive Self Test" and the "Long Generic" test. Both passed but didn't fix the problem.

I also tried the Dos Version of Seatools, but it wouldn't run properly for some reason. I think it was because of the GUI, I couldn't move the mouse, and had to operate with the keyboard only. It still ran the tests, but when it completed, I couldn't figure out how to check if the test completed successfully or not.

Also, I couldn't find an option in my BIOS to disable the "IDE compatible mode" for the SATA HD's.

Do you have any other ideas? I think I might just format the partition...nothing seems to be working...

Thanks again.

Report •

June 29, 2009 at 07:55:39
One other question for you. Somewhere up there you state that one of your WinXP installations has no service packs.

Are you aware that WinXP original is NOT 48 bit LBA compliant. That means it does not support hard drives larger than 127GB. Using Original on a drive larger than 127GB WILL eventually result in data corruption or loss.

Also, I am assuming your BIOS is 48 bit LBA compliant. To verify that, watch the POST screens at start up. All your drives should be identified in those screens by BOTH the model and the FULL drive capacity.

Report •

June 29, 2009 at 09:12:07
Hi OtheHill,

When I was first trying to fix the problem, I copied the pci.sys file from an XP installation that worked and had no service pack (copied from the Seagate XP to the Western Digital XP). It didn't fix the problem. So I upgraded the XP on Seagate to SP3 and tried to copy the pci.sys to my XP installation that is having problems. Still did not work. All my XP Installations now have SP3.

I wasn't aware that XP with no SP does not support HD's above 127 GB. But I didn't notice anything unusual using that XP when it had no SP. (although recently I am having problems with that XP (on Seagate).... might have started happening after I upgraded it to SP3. I thought it might be some virus on the HD. Firefox and IE both do not display pages correctly, I see funny characters all over the place. I cannot install certain programs. everything seems to be acting strangely.) But I dont think that has something to do with my XP on my WD partition. Since I dont ever use the XP on Seagate, I don't mind formatting it and installing a fresh XP with SP3.

Also, my POST screen shows all the HD's as SATA and indicates the correct model and drive capacity.

Report •

June 29, 2009 at 10:30:02
The issue develops after writing to the disk for some time. Also, accessing a second disk of more than 127GB when you don't have a SP installed can cause some issues.

Report •

June 29, 2009 at 13:40:46
"I also tried the Dos Version of Seatools, but it wouldn't run properly for some reason. I think it was because of the GUI, I couldn't move the mouse, and had to operate with the keyboard only."

Nothing you said indicates there's anything wrong with SeaTools.
That program,and many, if not all, other Dos bootable ones, cannot recognize a USB mouse. It will recognize a PS/2 mouse or, probably, a Serial mouse, (or a "combo" mouse that is designed to be, and has the circuits so it can be, used with either a USB or PS/2 connection, with a simple USB to PS/2 adapter).
However, Seatools is so simple to use, using a keyboard with it is no problem.
Type H (or click on H if the mouse works) for more info.

"It still ran the tests, but when it completed, I couldn't figure out how to check if the test completed successfully or not. "

If it is successful, a line indicating it was is added right after the LBA line - e.g. for the long test
"Read Scan Passed on (date) @ (time)"
However, if the drive has one or more SMART errors, I don't know if that will appear.

"Also, I couldn't find an option in my BIOS to disable the "IDE compatible mode" for the SATA HD's. "

The mode the SATA controller(s) is(are) set to in the bios Setup has NOTHING to do with your problem!

I gather from the info in your posts this computer is a desktop computer and it may be a Gateway model, but it may be very helpful if you supplied which MODEL it is. That's often on a label on the outside of a brand name system's case, or may be determined on the brand name's web site.
- if it is a brand name system in most cases the brand did not make the mboard - it was made by a major mboard manufacturer and supplied to the brand name builder and is either identical to amodel made by the mboard manufacturer, or an OEM only model supplied only to brand name builders, with a bios version on it made by, or for, the brand name builder.
- or - if it is a generic system
In either case, the mboard model and possibly it's brand is often printed in obvious larger characters on the surface of the mboard, often between slots or in the middle of the mboard - if you see such a model number and/or brand on the mboard, tell us what you see.

If it's a brand name system, what you see in the brand name's bios version may be very similar or quite different from what is seen in the mboard manufacturer's bios version for a mboard that is identical to a mboard manufacturer's model .
If it is a generic system, or if the mboard is identical to a mboard manufacturer's model, the bios Setup settings info is often in the mboard manufacturer's manual for the model, and if so we can look at that and (may) see what you see.

The settings in the mboard's bios regarding the mode only apply if the WD drive is connected to a header for the main chipset's SATA chipset - some mboards have an additonal SATA controller chipset e.g. JMBxxxx - the settings in the bios often don't apply to that, and don't apply if the WD drive is connected to a controller card in a slot.

It isn't necessarily called IDE compatibilty mode in the bios. It may be called Compatibilty mode, or IDE mode, or EIDE mode, or ATA mode, or similar.
SATA mode is a.k.a. AHCI mode.
You usually find the setting for IDE compatibilty mode, or whatever it's called, in the same place where you can set SATA (or AHCI) mode.
If the the SATA chipset is capable of RAID, you usually find the setting for IDE compatibilty mode, or whatever it's called, in the same place where you can set SATA (or AHCI) or RAID (or AHCI RAID) mode.

"Do you have any other ideas? "

If pci.sys is corrupted, you should be able to delete the existing pci.sys on the WD when you boot from the other XP installation, and then copy pci.sys to it, and that should make the WD XP installtion work.
However, it may not actually be pci.sys that is the problem, because sometimes Windows can't tell you directly what the problem is.

Did you you use the correct version of pci.sys??
Apparently you must use the one appropriate for whether or which SP version is supposed to be on the existing XP installation.

I don't have anything other than an existing XP Home installation with SP3 updates installed, so I can't compare pci.sys for the different situations at my place, but I do have a copy of a CD with no SP updates, original CDs with SP2 updates, etc., so I can compare pci.sy_ for the different situations.

The compressed pci.sys is pci.sy_ .

pci.sy_ on an XP Home CD with no SP updates included in it's Properties is 34.7kb, 35,550 bytes (it's in \i386).

pci.sy_ on an XP Home CD with SP2 updates included in it's Properties is 36.3kb, 37,184bytes (it's in \i386).

pci.sy_ on an official Microsoft SP2 upgrade CD in it's Properties is 36.3kb, 37,184bytes - there is only one, so SP2's pci.sys is therefore identical for XP Home, Pro, and MCE.
(I used Winzip to examine the contents of Xpsp2.exe to find that).

pci.sy_ in the official Microsoft SP3 updates download in it's Properties is 37,180 bytes - there is only one, so it's therefore identical for XP Home, Pro, and MCE.
(I used Winzip to examine the contents of WindowsXP-KB936929-SP3.exe to find that).

pci.sys in an XP Home installation with SP3 updates installed in it's Properties is 66.6kb, 68,224bytes

SO - the versions of pci.sys are different depending on whether or which SP updates are on the XP installation.

e.g. if you have updated the XP no SP updates installation by installing SP3 updates, you must use the pci.sy_ from the SP3 updates download, or a copy of pci.sys from another XP installation that has the SP3 updates installed. .

"The SMART status failed due to the "Multi Zone Error Rate" "

ID Hex
200 C8
Write Error Rate / (a.k.a.)
Multi-Zone Error Rate
The total number of errors when writing a sector.
Not flagged as Critical (orange)

However, when I searched for: Multi Zone Error Rate
some "hits" listed the Multi Zone Error Rate for a particular drive and it's usually 0 (zero).

It could be the WD drive is starting to fail, but it hasn't reached the point yet where other things have been exceeded.

The SMART info has other info in it.
If you're getting high numbers for: reallocated sectors
or any more than only a few :uncorrectable sectors, the WD drive is probably going to fail in a short time.

Sometimes the SMART info shows you the threshold for each value as well as it's present value - the value that should not be exceeded - sometimes it doesn't.
A some of the present values are high, even if they haven't yet exceeded the threshold, that often indicates the drive is starting to fail.
If the WD diagnostics don't show the threshold values........
- I have a freeware utility called dtemp.exe (Drive Temp) that also shows SMART info and it shows the threshold values - however the author is no longer providing it and most links for it on the web are now dead.
- the freeware SpeedFan also has SMART info but I don't know if it shows the threshold values:
- there is often a hardware monitoring software program on the CD that comes with a mboard, or available from the web site in the downloads for the model, you can load in Windows - that often has SMART info in it - it may or may not have the threshold values in it. If you have a brand name system and if you can find which manufacturer made the mboard, the hardware monitoring software program for the same model or a similar OEM only model will work for your mboard.

Another thing that might indicate failure or failure in the near future is the temperature of the drive, and/or of chips on it's logic board. The Dos bootable SeaTools displays the current temp of the drive, if the drive is more recent and has the sensor, and so do the freeware Dtemp.exe and SpeedFan. I have found drives that are failing often have one or more chips that get way too hot - too hot to keep a fingertip on - . whether or not the drive has a temp sensor.

"I think I might just format the partition...nothing seems to be working..

I don't think re-formatting the drive, or deleting the partition(s) then making them again, which partitions and formats in one step, will solve your problem, but Zero filling the drive MIGHT.
However, it could be whatever makes SMART work properly on the drive cannot work properly anymore because something is damaged - firmware or circuitry.

You could try copying all the existing data on the WD drive elsewhere - e.g. in this case it would be preferable to copy just the data including hidden and system files, such as by using XXCOPY /CLONE - then try "Zero filling" or "Low Level Formatting" the drive (which actually Zero fills it), then copy the data back onto the drive.
e.g. To Zero fill the drive with the Dos bootable SeaTools, you press Z, but MAKE SURE you have selected the correct drive (you press D to toggle which physical drive is selected when there is more than one).

"I wasn't aware that XP with no SP does not support HD's above 127 GB. But I didn't notice anything unusual using that XP when it had no SP. "

Actually it's 128gb ( binary) in the bios and in Setup, = 137gb (decimal) manufacturer's size, before the drive has been partitioned and formatted.
If you run Setup from scratch from the XP no updates CD, the max physical drive or partition size XP can recognize is 128gb.

By the way, an XP CD not having SP1 printed on the original CD doesn't necessarily indicate it doesn't have SP1 updates.
An XP CD with SP2 or SP3 updates included has SP2 or SP3 printed on the CD, BUT an XP CD with SP1 updates DOES NOT have SP1 printed on it, at least it doesn't on all the SP1 CDs I've seen. You only know it has SP1 updates included after Setup has finished and you look in System Information.
If your supposedly no SP updates CD actually has SP1 updates, drives> 128gb are recognized properly initially, and XP supports recognizing USB 2.0 controllers. (You may also be able to tell whether it has SP1 updates by looking up the CD's specific volume label.)

If you run the second Repair option from the XP no updates CD, what many call a Repair Install, and I call a Repair Setup, if SP1 or later updates have already been installed on the XP installation, the Repair Setup doesn't touch most of the existing XP installation settings or the files it was updated with, unless they're corrupted or missing, ONLY IF they're on the original CD, so if the > 128gb drive or partition was seen as it's full size previously that doesn't change.

If you installed XP with the no updates CD when there was no drive > 128gb connected, you wouldn't notice anything wrong with the size of drives or partitions detected. If you then upated it with SP1 or later updates, after that when you connect a >128gb drive it's size is recognized properly, if the mboard's bios supports that and the drive (size) detection in the bios is set to Auto or LBA.

You can make yourself a slipstreamed CD, preferably a CD-R for the best possible compatibility with any optical drive, that has the contents of the XP no updates CD with SP2 or SP3 updates integtrated into it, and then you don't need to be concerned about the sizes of drives > 128gb. Also, XP's USB 2.0 support requires SP1 or later updates, and you can integrate SATA controller drivers or other drivers into the slipstreamed CD as well. You use your original Product Key.

Report •

Ask Question