XP Doesn't See All 1.5Gb RAM

March 2, 2010 at 07:04:02
Specs: Windows XP
Hi everyone.

I've recently fresh installed WinXP on my PC, but when I go to System Properties it says I've only got 256Mb of RAM instead of 1.5Gb.

Everything worked fine on the previous installation so I don't think its an hardware problem.

I've also noticed that my boot.ini file is completely empty. No text at all. Is it normal?

Sorry for my English and thanks

See More: XP Doesnt See All 1.5Gb RAM

March 2, 2010 at 07:08:03
"I've also noticed that my boot.ini file is completely empty. No text at all. Is it normal?"

That is fine. You only need to add items to this file if you need to boot multiple OSs.

As for your RAM, what does your BIOS report? Turn on the memory test on POST option in your BIOS. You may have a lose RAM module or you have mismatched RAM. Some systems will not work with error correction RAM. Is this RAM new or has it worked in the system before?

Report •

March 2, 2010 at 07:53:35
No it is not normal that your boot.ini is empty. You must be looking at the wrong file because you would not boot if it was empty.

Are you looking at the file at c:\ ?

Go to a cmd prompt and type "mem" without the quotes. Post the results for review.

Report •

March 2, 2010 at 11:09:23
Oh, ya Wonderer is right. If it is blank Windows will boot but you will get an error. Check this out for fixing it...


Report •

Related Solutions

March 2, 2010 at 12:04:48
Since it is booting I would suggest we don't sagway into boot.ini issues when we still have a memory amount issue to address.

Waiting on the results of the mem. Thx

Report •

March 3, 2010 at 08:46:51
I have no error message at boot. This RAM has worked before.
BIOS reports 1.5Gb, but I'm sure the system is performing like it has got only 256.

Mem log is in Portuguese, I'll translate it soon.

Report •

March 3, 2010 at 08:50:55
You don't have more than one OS on this computer do you. Are you running a Linux bootloader to mange both Windows and Linux?

If I did not know better it almost sounds like you are running a Virtual Machine for your Windows and did not configure it to give enough memory to the instance.

Report •

March 3, 2010 at 10:26:01
WinXp Pro is the only OS I have installed but recently I've ran a a USBPersistent Linux (Ubuntu) but I haven't installed it on the harddrive...

May it cause any problem?

Report •

March 3, 2010 at 10:37:31
I don't need a translation just a post of the mem results. Format is universal so I can figure out from the numbers what you have.

Another OS install has nothing to do with reported memory [RAM].

It would affect disk space on the drive.

Report •

March 3, 2010 at 13:01:00
Here it is:

655360 bytes total memória convencional
655360 bytes disponível ao MS-DOS
627696 dimensão do maior programa executável

1048576 bytes total memória de extensão contígua
0 bytes disponíveis de memória de extensão contígua
941056 bytes disponíveis de memória XMS
MS-DOS residente na área de memória elevada


Report •

March 3, 2010 at 13:52:00
Sorry. My mistake. Mem doesn't give you the correct stats anymore.

Instead bring up task manager and go to the Performance tab.

What is listed for Physical Memory total?

Report •

March 3, 2010 at 14:06:09
It gives 261676k.

Report •

March 3, 2010 at 14:33:36
That's a problem :-)

Go to Run and type in msconfig
Go to the boot.ini tab
Click on the Advanced Options... button
Are any of the boxes here checked?

Report •

March 4, 2010 at 04:12:10
When I click on Advanced Options msconfig crashes!

I heard it might be a virus... what do you think?

Report •

March 4, 2010 at 08:30:03
This was a fresh install. Unless you are direct to the internet and have no router, or did downloads from other than Microsoft sites, then possibly.

Are you up on all the service packs?

I would be more inclined to think this was a bad install. I would reinstall making sure to wipe and recreate the disk partitions.

Report •

March 4, 2010 at 11:41:23
My WinXP is the latest build and SP3.

Do you think another clean install is the only solution?

Although I've done some clean installs, I really hate working with partitions and such...


Report •

March 4, 2010 at 13:15:57
virus question: do you have a router? if not you maybe infected with a port trojan though I have never ever heard of the advanced msconfig tab being a target.

ignoring the advanced tab, can you view the boot.ini in msconfig? is there a /maxmem switch?

Report •

March 5, 2010 at 06:09:29
I've clean installed it again, but it still says I've only got 256Mb...

But now I can go to msconfig, and no, MAXMEM isn't checked...


Report •

March 5, 2010 at 09:04:22
A new clean install says the same thing?

That points to hardware. Did you do a ram upgrade?

Might want to open the case and reseat the ram.

I would suggest downloading memtest and running it. Curious as to how much ram it sees.

Report •

March 5, 2010 at 13:34:16
Yes, I've upgraded from 512Mb+512Mb to 1Gb+512Mb but everything has worked well on the previous Windows XP and on Windows 7 that had installed, on live USB Linux and the BIOS reports it correctly so its hard to believe that is hardware problem.

It may also be interesting for you to see this:


(That topic is mine too)

I'll download memtest.

Report •

March 5, 2010 at 15:50:57
Only way I know to limit ram in a ntldr based OS is to use the maxmem switch in the boot.ini. No maxmem no limit.

The question then becomes why is install only seeing 256meg.

BTW I have worked with hardware for years and I have seen the bios see the ram but the OS wouldn't even load until I set some jumpers correctly.

A simple test is pull the gig ram chip and see if the OS then sees 512. Then visa versa it.

Report •

March 14, 2010 at 00:10:43
Thanks again.

I've ran Meemtest86+ and it finds no errors.
Do I really have to mess up with the ram... ?
I'm way not comfortable with that :).

Report •

March 14, 2010 at 20:25:00
If one memory module is faster, depending upon your board, you may need to make sure the slower one is in the 'first' slot so the faster one can be run at the slower speed.
Also, Are you using shared memory with graphics? You might have an unusual setting set in your BIOS (OR IN WINDOWS ACTUALLY) that is forcing most of your memory to be reserved for graphics use and not for system use.
When you 'clean' installed, did you format the drive, thereby truely starting fresh? Or did you skip that and call it a clean install, but unknowingly still retain some settings?

Report •

March 15, 2010 at 07:38:59
Well, I haven't change anything on the BIOS.
I formatted the old WXP partition, created a new one and installed the new WXP. That is a clean install, isn't it?


Report •

March 15, 2010 at 08:41:25
what did memtest report for total memory?

Report •

March 15, 2010 at 09:09:39
The response was in number 13. It appears that the OP did not do the fresh install right. Probably forgot to delete the partitions.

Report •

March 15, 2010 at 10:52:13
Well, I formatted the partition.
The Memtest reported all the 1.5Gb...
God, Im desperated xD.
Thanks all.

Report •

March 15, 2010 at 10:56:47
"Well, I formatted the partition."

You have to delete the partition, then recreate it then format the partition.

But this is not your problem being that the command prompt memory test is reporting the memory right.

Report •

March 15, 2010 at 11:54:02
I still say check the BIOS settings carefully, there may be a setting there to reserve % memory for graphics or something else. Are you using onboard graphics or do you have a video card?
Also, by not deleting the partition, are you possibly preserving a boot sector virus/infection? Or could this be a BIOS error or infection? Is flashing the BIOS a real option?
** just throwing these out for others to think about/comment on **

Report •

March 15, 2010 at 12:34:39
True you could have your BIOS set to share your RAM to other perifials such as a video card but then when you do a MEMTEST then it would have only reported what the BIOS has allocated to applications. This means the BIOS being a problem is ruled out. Kinda why a request was made to do a MEMTEST.

I have some thoughts, not good ones but I will wait to see what others have to say.

Report •

March 15, 2010 at 13:11:46
"You have to delete the partition, then recreate it then format the partition. "

It was exactly what I've done.

"I still say check the BIOS settings carefully"

Believe me I have. Besides, I'm writing this on the PC with the "problem" on a Ubuntu Persistent USB and it reports 1.5Gb.

"I have some thoughts, not good ones but I will wait to see what others have to say."

Well... Nothing else to say :)


Please check this. It may have nothing to do with this, but it's some info:


The topic was mine too.

Thanks again to all.

Report •

Ask Question