XP cloned to SATA2 drive won't boot

December 31, 2008 at 05:35:09
Specs: Windows XP, AMD Athlon X2 4200+ / 2 G
Trying to clone an existing, working WinXP SP3 setup from an old SATA-1 drive to a newer SATA-2 drive.

The cloning (or even a fresh Win XP SP2 from genuine CD installation) appears to succeed. Upon booting, the BIOS appears to POST fine but I get an error when starting to load Win XP (before the WinXP loading screen appears): "Disk Read Error. Press CTRL+ALT+DEL to restart."

I have seen that there can be problems with WinXP and SATA drives, but I expected that since (i) I have been using a SATA drive all along and (ii) the cloned image therefore already has any SATA drivers needed by my BIOS (I have installed the appropriate NForce 4 driver suite, v15.23), this cloning should work.

I initially tried with an older BIOS, but have since upgraded to the latest, 1409.

I've tried (i) cloning the drive with the latest tools from Seagate (ii) cloning the drive with the latest tools from Western Digital, and even (iii) reinstalling XP from scratch using the same genuine OEM XP SP2 disc that I used on the original drive.

System Details:

RAM checks out okay; no overclocking.

Old HDD: Maxtor 250 GB SATA1 (150 MB/s) full CHKDSK run at boot-up confirms physical media is good.

New HDD: Seagate 500 GB SATA2 (300 MB/s) full CHKDSK confirms physical media is good: I can mount the drive as a non-booting drive and use it no problem.

Any suggestions on how I can get the new SATA2 drive booting WinXP will be much appreciated.

I'd prefer to use a clone of my existing installation, but if that's impossible for some reason, I would at least like to be able to boot from a fresh WinXP install!

See More: XP cloned to SATA2 drive wont boot

Report •

December 31, 2008 at 07:04:02
Did you format the new SATA?

Report •

December 31, 2008 at 08:00:24
If you updated the BIOS you may have had BIOS settings other than default before and now have default.

You have a setting in the BIOS that allows the SATA drive to run in an IDE compatibility mode. If you were using that before and not using it now you will have problems.

What was the reason for changing the boot drive?

Report •

December 31, 2008 at 09:10:19
I would suggest the following;

In recovery console run fixmbr and fixboot

Still no boot run a repair install of xp

'tis the season to be of good cheer. Wishing one and all happy times with family and friends.

Report •

Related Solutions

December 31, 2008 at 11:09:05
Thanks for the responses so far. It's reassuring to we've thought of some of the same things!

guapo, regarding formatting: yes, I have now done two full formats of the drive (i.e., not Quick formats) as NTFS with whatever the default allocation block size was. When I first set up the drive, I mounted it as a non-boot drive, partitioned it using the WinXP 'Computer Management' disk section, and then formatted it. I ran a second format the next day just to be sure that wasn't the problem.

OtheHill, regarding the BIOS update: I did the BIOS update as a part of my troubleshooting, i.e., I first got this error before doing the BIOS update. Also, my old (SATA-1) boot drive continues to be bootable, so I was guessing that the BIOS settings (both before and after the BIOS update) are not the critical issue?

wanderer, regarding WinXP recovery steps: again, good to see I I'm on the same page as you... I did 'fixmbr' and 'fixboot' tools via the recovery console, and I already tried a repair install of XP. The repair install gave the appearance of working, but when trying to boot the drive, it still gave the same error.

Thanks for the thoughts so far; any other ideas out there?

Report •

December 31, 2008 at 11:34:47
Check the cloned drive to see if the boot partition is set as active. You can check that with fdisk.

One other item to note. If you had a SATA I drive your SATA controllers may be only SATA I controllers. Not all SATA II drives are backward compatible. Some have a SATA I limiter jumper. Check the manufacturer's website to verify.

Report •

December 31, 2008 at 23:02:17
The is a program that makes cloning xp installations quite easy called xxclone. Connect the new disk format it inside windows and the set xxclone on it. I belive it sets the partition active, initialises the registry ect. You would only need the free version to do this. It has a few little niggles, 1. The boot.ini file in the cloned install will have been edited to "xxclone...." instead of "windows..." and it won't be set to hidden. 2. it doesn't seem to uninstall properly, I normally just delete the shortcut and the xxclone.exe from %systemroot%\system32.

Just be sure to look at the "cool tools" tab to make the disk bootable.

It may be that you have some other problem unrelated, but who knows....


Report •

January 19, 2009 at 22:04:59
Thanks to everyone who offered some help here. I tried all the suggestions above, with no success.

Eventually I switched from the Seagate 7200.11 500 GB SATA2 (300 MB/s) to a Western Digital 5000AAKS 500 GB SATA2 (300 MB/s), and the Western Digital drive worked fine from the get go, no need to do anything special at all (i.e., WinXP SP2 installed fine on the Western Digital drive with no need for special drivers or changes to BIOS settings or anything like that).

So overall, it appears to be a problem with the Seagate technology. It worked fine for a non-boot drive, but would not boot.

Report •

January 20, 2009 at 05:10:46
Did you end up connecting the WD drive to the same exact SATA port as the Seagate?

Some motherboards have some SATA ports that are not bootable.

Report •

January 20, 2009 at 08:46:32
I had tried the Seagate on two different SATA ports, one on each of the mainboard's controllers. One of the ports I tried was the board's lowest numbered SATA port (port 3, since 1 and 2 are reserved for legacy IDE drives, of which I have none).

I am currently booting WinXP from the WD via SATA port 6 (i.e., not the lowest SATA port number), and the drive is definitely operating in SATA2 mode (and I did not need to install any third-party drivers to get that), substantially faster than my old SATA1 boot drive (93 MB/s sustained vs. 63 MB/s).

I simply swapped out the Seagate and put the WD in the exact same physical configuration, made no change to BIOS settings, and used the same genuine WinXP SP2 install CD.

Report •

January 20, 2009 at 08:54:38
The only different in the two MIGHT be the ability to use NCQ. Although most new models do support that function.


Report •

January 20, 2009 at 20:31:25
The Seagate drive had NCQ and the WD does not, but according to Seagate, "NCQ supported hard drives will work just fine with non-NCQ supported controllers or motherboards. However you will not be able to take advantage of the NCQ features." (<http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId=193785>)

So even if my mainboard doesn't handle NCQ, Seagate says the drive should have worked.

There does seem to be a massive problem with Seagate firmware across many product lines (including the 7200.11 line), so maybe this booting problem is related to that, and might be fixable with the firmware update that Seagate has promised: <http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId=207931>.

According to the Seagate serial-number checker, my HDD should not have been affected by that problem, but I'm not sure I believe all of Seagate's documentation on the topic just now, since they are clearly still in the middle of investigating a huge problem.

Report •

January 21, 2009 at 05:16:25
Sounds like you have the best handle on the situation that can be had at the moment.

Report •

February 2, 2009 at 21:09:38
I have again experienced a similar problem as the one in this thread. I have an HP 6320 laptop that I upgraded to a 125G drive a couple of years ago. I need to send the laptop back to get some warranty repairs completed and I went to put the original 60G drive back into the machine today to send it back and it gave me the "Disk Read Error. Press CTRL+ALT+DEL to restart." I can view all contents on the drive fine it is set to be a boot partition and this is the original drive that was functioning fine before I upgraded. I used the HP Recover partition to set the primary partition back to factory defaults and it still will not boot off of that partition.

Incidently, I had also cloned a 500G over the weekend and the machine won't boot off of it either. Just sits at the prompt after the bios completes.

Report •

February 3, 2009 at 06:43:47

To my knowledge no one makes a 125GB hard drive. Your issues may be related to 48 bit LBA compliance. Look at the link below for additional info.


Report •

February 3, 2009 at 07:18:43
The current drive is a WDC WD1200BEVS-60RSTO so I think it is a 120G drive, not the 125G I was recalling from memory for my post.

Thanks for the links on the 48-bit LBA. I will research and find out if that is the issue and advise. Sounds like a likely explanation.

Report •

Ask Question