WinXP and hard disk problem

Micro-star internatonal c... / Ms-7523
February 23, 2009 at 22:37:18
Specs: Microsoft Windows XP Professional, 3.333 GHz / 3071 MB
Hi everyone,

I have a Western Digital Raptor 150 GB @ 10000 RPM that I'm experiencing trouble with. I am running Windows XP Pro with SP3 on a desktop computer. The disk is a SATA. It is not my OS disk, it is an additional disk. It shows up in Windows and looks okay during boot, but check this out

- Moving files from it to other drives doesn't work. I get no error message, but the operation never finishes.
- Copying files to/from it works.
- Creating new files on it works.
- Formatting it doesn't work. I get an error message: "Windows cannot format this drive. Quit any disk utilities or other programs that are using this drive, and make sure that no window is displaying the contents of the drive. Then try formatting again.".
- Chkdsk doesn't work. I get an error message prompting me to run chkdsk at the next startup. I did this and found no errors.
- Changing drive letter on it doesn't work. The device manager hangs forever and I have to use task manager to terminate. I also tried using Partition Magic, but got the same result.

It seems changing existing data on the drive isn't allowed, but adding data is.

I started Windows in safe mode and the disk works perfectly normal. I formatted it, changed drive letter and then started back up in normal mode and the problems returned, though the changes I made in safe mode were visible.

To root out the problem, I opened task manager and started terminating processes one by one. Nothing was different until I terminated one of the svchost.exe processes. Then all of a sudden the disk works normally.

I am puzzled as to what this is. The OS is freshly installed by myself (completely new PC). No settings in Windows have been altered. Everything else on the computer works fine.

Please assist!

All the best,

See More: WinXP and hard disk problem

Report •

February 24, 2009 at 01:03:38
You can use Process Explorer to see what services are running as a part of a svchost.exe process.

Get it here

Report •

February 24, 2009 at 08:04:53
That's a really great tool! I eventually managed to root out the problem.

In case someone else has the same problem and googles to this thread, here's the solution:

1. Click Start -> Settings -> Control Panel -> Administrative Tools -> Services.

2. Double-click "Distributed Link Tracking Client".

3. Set "Startup type" to "Disabled".

4. Reboot and problem solved!

I can't find any negative consequences by disabling the service. If anyone knows of any, please let me know.

More info on the service @

All the best,

Report •

February 24, 2009 at 11:08:21
I'm glad you sorted it out, thank you for letting us know.

Report •

Related Solutions

Ask Question