Windows XP Setup issue - File 'ASMS' is needed!

September 30, 2012 at 08:12:37
Specs: Windows XP, Pentium 4/512MB
Hello there, I'm Ryan.

One day in.. August? I tried to reinstall Windows XP CLEANLY (not a repair, whatever that is). So I format the C: drive and you know everything goes fine until I am met with that error.

I have literally tried about everything I can that I found online, nothing is working.

The registry editor or device manager will not open.
Setting the CD/DVD drive in the BIOS second and HDD first doesn't work.
I burned the contents of i586(where asms is) onto a separate disc and that doesn't work.
I tried entering every letter repeatedly, that doesn't work.
I tried to boot off of a USB, nodo.
Inserting the CD when asked doesn't work. However it does display a CD icon on the mouse and the drive light glows..

Many people say use a secondary drive, My computer only has 1.
Then there are those answers about replacing drives or opening it up and all that, I can't do that the issue is.

And that is not the only thing that has happened since this install. Even when the XP disc is inside and the CD Drive is set to boot first, it no longer displays "Enter any key to boot off CD" message. All it does now it have a little blinking line for a while, and it goes to the HDD. The light is on when it does that. I even inserted a Windows 2000 disc and it doesn't boot from that. WTH happened?!

This computer is a Compaq Evo D510 Tower I believe; Although I am not sure. It has 512 MB of memory, NVIDIA Vanta Graphics card, Intel Pentium 4, and it is refurbished with WinXP was preinstalled. It has a XP and 2000 key on the machine.

See More: Windows XP Setup issue - File ASMS is needed!

Report •

September 30, 2012 at 09:19:45
Is the CD drive detected in bios?
Was it working fine?
Have you tried selecting boot menu is there the drive detected?

Report •

September 30, 2012 at 12:50:25

Always pop back and let us know the outcome - thanks

Report •

September 30, 2012 at 14:49:53
Hi sumeshbnr, The drive is detected in the BIOS.
The drive was working fine, I installed XP onto that machine before.
I don't think there is a boot menu list.. only F10 for setup and F12 for network boot. So I just have to line up their order I suppose..

Derek, when i had said I literally looked everywhere online I even checked that post ;) It didn't help. Cannot open registry.. no Windows 98/ME discs...


Something I should have mentioned but forgot to is that the disc is in fact an official one. It came with the machine and it is labeled:

Windows XP for Refurbished PCs - With Service Pack 3

This disc has worked before and it still in fact works, when all this occurred I inserted it into an another machine and it ran fine.

Thanks again for your guys spending time to help me :)

Report •

Related Solutions

September 30, 2012 at 15:50:46
Sorry, overlooked some general points in your post.

However it does display a CD icon on the mouse
Not sure what you mean by this.

I assume it makes it to Windows. If so, with the CD in the drive can you see its contents when double clicking the CD icon?

You can get W98SE or WinME bootdisks from here (create on another computer):
These only apply if you formatted it to FAT or FAT32.

Always pop back and let us know the outcome - thanks

Report •

September 30, 2012 at 16:19:37
Hi Derek,

yes it does boot into Windows. What I mean by that is that when the disc is inserted, it would show a little CD on top of the mouse cursor. It's hard to explain but it makes me think it sees the drive at least. That would happen on any normal XP install AFAIK too :)

No I cannot. I am literally STUCK in the setup process. 39 minutes left, a slideshow of features, and the asms error. Canceling would make it reboot, bringing this back up all over again.

EDIT: Forgot to mention that I formatted with NTFS, I never would format with FAT/FAT32

Report •

September 30, 2012 at 16:36:38
If you installed XP on that computer before using the same process, about the only thing I can think of is that the disk is dirty or scratched (or the CD drive lens is dirty).

There are drive lens cleaning kits available.

Try washing the CD in warm water with a touch of washing up liquid. Use your thumb to clean it from inside to outside (rather than round and round). Rinse then dry with kitchen roll.

Only other thing I can think of is a hardware fault (edge connectors, plugs & sockets etc).

It would be worth formatting before trying again after attending to the above.

Always pop back and let us know the outcome - thanks

Report •

November 27, 2012 at 08:42:43
Had this same problem for a long time on an HP. Gave up after a while. Just got the machine out and tried again. Entered the boot menu at start up, selected my cd-rom drive as the first boot option, then my cd-rom as the boot device, cleaned the install cd, and presto. Its doing fine now. Hope this helps although Im sure youve tried this.

Report •

Ask Question