Windows installer hangs

Hewlett-packard Mini 110-3530nr 10.1" bl...
July 11, 2011 at 20:17:00
Specs: Windows XP Home, N270 (Intel Atom)/1 gig
windows installer hangs and then eventually times out. I have downloaded the latest version from the Microsoft Web site (version 4.5) and installed it. In order for it to install I had to manually stop the installer service as the program could not and it would not complete the install.

This is happening when I try to install Java, AVG virus protection, I even tried to install the old installer cleanup utility but that hung up too.

See More: Windows installer hangs

Report •

July 11, 2011 at 21:33:46
Windows Installer Service could not be accessed
Click Start > Run, Copy & Paste > net start MSIServer, press ENTER and try installing again.


How to Fix the Dreaded Windows Installer Not Accessible Error

Report •

July 12, 2011 at 10:31:54
I rebooted the machine. Made sure the installer service was not running. Made sure there were no in progress installs left in the registry. Installed the latest version (4.5) of windows installer. Manually started the service as per your instructions.

This time instead of hanging at about 5% before eventually timing out and giving the error that the installer service was not responding it made it to 95% before hanging.

Report •

July 12, 2011 at 15:48:44
Do net start MSIServer again & then run this.

Tick all the boxes before running.

Auslogics Registry Cleaner
I tick all the boxes. Windows 7/Vista/2008/XP/2003 (32-bit & 64-bit)

Report •

Related Solutions

July 12, 2011 at 17:31:51
Sorry if I wasn't clear. Yes I did also check the link you sent and followed those instructions.

I have also downloaded and run the registry cleaners you recommended.

No joy in Mudville.

Normally I would just reinstall XP but it is a netbook with no ability to boot from a USB in the BIOS.

Do you know of a flash BIOS that would allow that?

Report •

July 12, 2011 at 19:30:27
Just doing a double check in case of a typo, you are running XP?


Report •

July 13, 2011 at 12:34:07
XP home edition SP3

Report •

July 13, 2011 at 13:01:14
"XP home edition SP3"

Was WinToFlash any help?

Googling got this site, 3 pages of fixes, hopefully 1 will be your's.

Report •

July 14, 2011 at 16:48:27
Hi. This is the same person. I can't login other the other name, I forgot what password I used and when I tried the reset but it never sent me the e-mail with the temp password so I had to create a new account.

I have gone through all the options on the link you sent. Still no luck.

I haven't tried the bios yet because I can't install my external DVD drive. The hardware installer says there is another install in process. So I am off on that adventure.

Thanks for all your help. If I ever get this resolved I will let you know.

Report •

July 19, 2011 at 07:15:48
Well if anyone was or is following this, I finally resolved the issue. At some point Roxio Back on Track was on the netbook and someone either uninstalled it incorrectly or the uninstall process did not complete. It left some BOT's, registry entries, and other little things running around, including some directorys so nested you couldn't even get to them to delete them.

Spent the weekend hunting it all down and getting rid of it. Now everthing works fine.

John, thanks for your help. My parent's thank you too.

Report •

July 19, 2011 at 08:38:00
Nice work Stephanie, that's really good news.

Report •

Ask Question