WIN XP PRO firewall enabled

Microsoft Microsoft windows xp pro full...
January 20, 2010 at 18:52:18
Specs: Windows XP PRO, 2GB
Hello there
I am sharing a folder in a laptop with Win xp pro through ethernet peer to peer.

The laptop has just one Windows user created, and this user has a password.

When I try to enter into this computer through the local network peer to peer, I do not get access. To get access I have to disable Windows Firewall, then I can go in this laptop.

Once I am inside of this laptop through the peer to peer link, I can enable Findows firewall again and get out of the laptop. Then if I try to enter into the laptop again with the laptop disabled, I am able to get in even though the firewall is now enabled.

Does anybody know why does it make a difference the first test and second test?

First test: I try to enter with the firewall enabled but it does not allow me to enter into the laptop)

Second test( I disable the firewall, enter into the laptop, then enabled the firewall again, get out of the laptop and then tried to go in again and then it does let me go in even with firewall enabled?

I would appreciate any idea to solve this because it is a mess having to disable and enable the firewall every time I want to get in the laptop without having to disable the firewall during the time I am inside of the laptop.

Thanks a lot in advance
In-home technical services for computers to individuals and small companies. Arganda, Madrid, Spain

See More: WIN XP PRO firewall enabled

January 24, 2010 at 15:19:29
Did you go into Control Panel & Windows Firewall & make sure it is not blocked in > Exceptions.

This may help you.

XP Firewall Commander

Report •

January 24, 2010 at 16:19:21
Thanks John
to begin with it eventually worked but I am not sure yet about what the problem was, it might have had something to do with netbios not being enabled properly but not sure though.

Indeed, I hadn't set the specifical ip addresses for the scope of all the four ports used in file and printer sharing but just for one of them. Nonetheless, for the rest, I had just the second choice called something like "all computers in my current local network" are considered exception. As a matter of fact, at the beginning I guessed that should work as well. Anyways, I ended up having to set up all the four ports with specifical ip address used in my network.

The problem with this was that it was not enough as far as I know. I had to change the netbios default configuration to the one which forces netbios enabling.

That way seemed to fix it. Nonetheless I think the default configuration for netbios should have worked as well because there was a DHCP server in the router and according to the default configuration for netbios, if the DHCP sever does not provide with netbios, then netbios is forced through TCP/IP.

Other changes I was doing was going from dynamic ip address to static ip address. Now it is working as a dynamic ip address and works fine. I do not remember whether I eventually set netbios as default or not.

What I do know, is that to solve the problem I had to reboot the computer when doing these changes. Probably, ipconfig /renew might have worked as well, but I do not know for sure.

Anyways, to solve the issue I just had to try several configurations with these variations:
- dynamic ip address or static ip address
- default netbios settings or force enabling netbios
- reboot the computer to try any of the changes

I hope that if anyone has this problem in the future (like myself) might find helpful some of these tips.

In-home technical services for computers to individuals and small companies. Arganda, Madrid, Spain

Report •

January 24, 2010 at 20:38:51
I use Seconfig XP, for Home use, I click on > For home & Apply.

Sounds like you are networking, in which case you would click on > MN & Apply.

Seconfig XP

Report •

Related Solutions

January 24, 2010 at 20:40:52
if above ones not working then u have to make a small office
network on both pears having same network name.
then try.

Report •

January 25, 2010 at 01:42:10
Thanks for the help guys.
The configuration ended up with dynamic ip address like I told you. It is working through a wireless local network though.
In-home technical services for computers to individuals and small companies. Arganda, Madrid, Spain

Report •

Ask Question