Why can't I open files in my control panel

December 28, 2010 at 10:09:58
Specs: Windows XP
I can't open files in my control panel. I can open control panel but when I double click a file (i.e. user accounts, add remove programs etc.) I receive a pop up that reads file or file name not found. All directory names seem to have been changed. I can add programs from a disc (such as games or word, etc.) but I can't access anything in the control panel. Is this a common problem? Is it a virus or is there something wrong inside my computer?

See More: Why cant I open files in my control panel

December 28, 2010 at 10:52:50
It does sound like something malware would do. Most control panel functions are accessible via their .cpl file in \windows\system32 folder (eg, appwiz.cpl is add/remove programs). Have a look to see if there are .cpl files in that folder.

Are you getting other oddities - like pop-ups, apparent security program telling you there's loads of infections on your machine?

You could try using system restore to go back before the problem started - though if it is malware you may find either system restore doesn't work or it makes no difference.

If it is malware it will probably have put an entry in the startup list - run msconfig and look at the startup list (you may not recognise all the entries - but malware often uses a random group of letters both to identify itself & its program. Also, often runs from your profile (either the application data or temp folders are favourites) rather than program files.

Report •

December 29, 2010 at 05:39:56
Thank you for your response. I will try what you suggested with msconfig. In answer to your question about any other oddities, there really have been none. No pop ups etc. Every now and then, my firewall or virus software will tell me someone is trying to access my computer and ask if I want to block them, but other then that, nothing that seems out of the ordinary. The problem has been happening for about a year or so. It never really interfered with what I was doing so I didn't bother with it as I could right click the screen to change wall paper or monitor appearance etc. I now need to change some user accounts and I can't. I installed and ran malware bytes yesterday and it picked up some 376 items and 3 Trojan horses that my programs missed, but I still can't access the folders in CP. I haven't tried system restore, but I suspect too much time has elapsed to catch what ever is the trouble. I will run msconfig tonight after work and see what I might find. Again, thank you for your help.

Report •

December 30, 2010 at 03:44:34
I tried appwiz.cpl and my computer asked me how I wanted to open it. Nothing I tried would work…any suggestions? I also checked the other things you suggested and found a service.exe on the start menu. When I tried to remove it, it wouldn't let me. I read that some malware disguise as service.exe and that the malware would cause the same message I get when I try to open a file. Do you have any more help?

Report •

Related Solutions

December 30, 2010 at 09:14:05
us38, Try the CPL file association fix at the link below. It's a reg file fix and instructions are on the page.

Windows® XP File Association Fixes



Report •

Ask Question