where can I find a command prompt sollution to run Regedit?

December 2, 2014 at 17:56:07
Specs: Linux
I have the excact same issue as well. Regedit.exe won't run in command prompt :(

I'm trying a clean install for windows xp home edition. Needs 'asms' file and apparently CDROM is not responding so I am shift f10 to fix but can't open regedit.exe does not work.

See More: where can I find a command prompt sollution to run Regedit?

Report •

December 2, 2014 at 20:38:09
Boot off the XP disc (watch for the "press any key" prompt), delete all current partitions, create a new one, then proceed with the install.


message edited by riider

Report •

December 2, 2014 at 20:41:17
You're having the same issue as who/what? Please provide a link.

Regedit is a windows program and as far as I know won't ever run in command prompt.

If you're coming up with a 'file missing' message while installing windows it's usually a bad cd, bad cdrom or bad ram.

Report •

December 2, 2014 at 22:46:49
Okay, sorry new to this computing.net forum...

I did a clean install of Windows XP today.

I used these helpful instructions: http://pcsupport.about.com/od/opera...

When I got to the Windows installation process right after the initial setup and preparation I found an error I later found through troubleshooting and online research to be quite common.

My error: Files needed "The file 'asms' on Windows Home Edition Service Pack 2 CD is needed. type the path where the file is located, and then click OK"

I click, "OK" and find that nothing happens for D:\ or D:\1386 for finding the asms file.

I found that the PC is not responding to the CDROM, (and I had been aware of trouble with the CDROM not working so well)

This problem is found all over online from many people and the common fix seems to be directing people here.

I never quite got to this. My attempt at the first step was to hit shift+f10 to open command prompt (that worked) then, Type regedit.exe, and then press ENTER.

This led me to, "the system cannot execute the specified program."

So there was nothing in the Microsoft support page about this happening....

I forget which post I was on or the oldgeek was talking about and I don't completely understand it but...

It was a success! Clean install complete.

What the guy mentioned in the post was,

instead of typing regedit.exe in the command prompt try and old trick,

Try typing, MSCDEX.exe or MSCDEXNT.exe

I did the second one.. had to click OK after...

Then I just clicked cancel because I was still stuck with needing the asms file..

The PC did it's default restart and was brought back to the same setup..


not sure the MSCDEXNT.exe worked or not but a common enough problem I thought I would spread the word.

Report •

Related Solutions

December 3, 2014 at 00:25:32
Mscdex is for cdrom access in dos. I suppose mscdexnt is for command prompt in NT systems--of which XP is one. I've never heard of running that file to kickstart the cdrom during an installation but there's a few things I don't know.

I doubt though that doing that loaded the files. My guess is when you clicked 'cancel' it went on with the installation without the files it was asking about. XP will reboot once or twice during installaiton anyway.

Report •

December 3, 2014 at 01:11:41
I just looked at your MS link about that. (Lately all my links to any 'support.microsoft.com' opened in German. I finally learned how to fix it. You click on the globe icon in the lower left corner of the page and then select region and language. It remembers the change and pages open correctly after that.)

Anyway, note that in method 1 for NTFS drives it says if you continue to get the message you should 'restart your computer and let the Setup program resume' which basically is what you did.

Report •

December 3, 2014 at 09:35:18
To get to regedit I usually hold Windows key + R then type regedit in the Run box and hit Enter key.

However on Win 8.1 which I'm using it also opens fine in a Command Prompt window and I would be surprised if XP is any different. Command Prompt is a windows program (emulator) so I guess that is the reason. Of-course true DOS hasn't been around since the Win 95/98 days.

Always pop back and let us know the outcome - thanks

Report •

December 3, 2014 at 16:34:46
Yeah, when I opened a command prompt box during a windows session and tried to run regedit it opened the regular regedit screen in windows. But I don't think it'll run if you boot to command prompt. Haven't tried it though.

Report •

December 3, 2014 at 16:44:45
"Haven't tried it though" [from boot]
Neither have I but the way I see it you are still using the Windows emulator, the only difference is that you will not have a lot of other Windows stuff running as well. BUT...

Sorry, I'm changing my mind now LOL. Maybe regedit would be part of the "Windows stuff" I mentioned above.

Always pop back and let us know the outcome - thanks

message edited by Derek

Report •

December 3, 2014 at 19:14:43
If you need SP3 for WinXP you can get an ISO of it at the link below.


Report •

December 3, 2014 at 23:46:02
I rebooted to 'safe mode with command prompt' and attempted to run regedit from command prompt. It ran just fine and opened to the normal regedit screen. So I guess I should try these things before I pop off with my opinions.

Report •

Ask Question