VirtualBox Using More Memory For Guest OS . .

September 10, 2010 at 05:18:18
Specs: Windows XP, 2.80 GHz / 1024
Hello I am running VirtualBox . Every Time BEFORE I start my virtual OS i see how much memory is free , usually there is 720 mb free . But when i start my virtual os WITH 256 mb ram for it my free memory goes to 200 mb. I have 1 core for guest , 256 mb ram , 128 video memory. I have 1 gb ram on pc .

CPU : Intel Dual-Core 3.40GHZ
Memory: 2 GB DDRM
Video Card: Nvida 9500 GT
Sound : SoundMAX Onboard
OS: Vista


See More: VirtualBox Using More Memory For Guest OS . .

Report •

#1
September 10, 2010 at 05:44:46
I don't see anything unusual about this.
You must understand that memory management in Windows is extremely complex and many of the principles in use are quite different than how you perceive them.
You have assigned 256 MB of RAM to the client OS but this is by no means the total memory it requires to operate. Don't forget the memory you assigned as video memory for the client. VirtualBox itself requires memory but the biggest user will be the host as it provides services to VirtualBox and it's clients. Memory management in Windows is highly dynamic and memory usage will vary greatly depending on availability and what the application (VirtualBox) is doing.

Also note that what Task Manager shows as "Available" is not necessarily free. In most cases the majority will actually be in use. In Windows memory being both available and in use is not a contradiction.

Edit: I just noticed you have a previous post with this title. Do not double post like this. This causes confusion and could lead to both being deleted.


Report •

#2
September 10, 2010 at 15:26:00
What Double Posted .. .. Thats weird O_o Maybe Because I refreshed twice due to "can not connect error . . ." Any ways i lower the video ram to 32 mb for windows 7 guest . . . And now i can give it 512 MB :D :D :D :D :D :D :D :D Any Higher And I will trash the hell out of my hardrive . *increasing ram* *watching hdd burn* . Yah but now i have this strange problem . At the task bar ( where the start button is ) http://www.megaupload.com/?d=8V3EB9YL

You'll See what i mean AND IT's f---ING HORRIBLE AND ANOYYING ! ! !

EDIT : This happened when i installed a windows 7 theme . . . hmm . . .

CPU : Intel Dual-Core 3.40GHZ
Memory: 2 GB DDRM
Video Card: Nvida 9500 GT
Sound : SoundMAX Onboard
OS: Vista


Report •

#3
September 10, 2010 at 18:25:25
This is the best help page for virtualbox:

http://forums.virtualbox.org/index....


Report •
Related Solutions


Ask Question