USB ports not working after XP Reinstallation

Toshiba / P30
March 11, 2010 at 22:08:46
Specs: MS Win XP 2002 SP3, Intel Celeron 1.70ghz/256MB
I have a generic computer (it has MULTIMEDIA COMPUTER SYSTEM on the front bottom) and after re-installing Win XP from scratch none of the USB ports are working. I am thinking maybe the drivers are not correct. Because the computer is not a brand name how do I know what drivers I need? Is it based on the motherboard (SiS646-P4S533)?

See More: USB ports not working after XP Reinstallation

March 11, 2010 at 22:16:38
download SIW (standalone version) and find out which drivers you need

Some HELP in posting on plus free progs and instructions Cheers

Report •

March 12, 2010 at 18:47:30
I downloaded and ran SIW but not sure what to do when I run it.

Report •

March 12, 2010 at 18:56:10
Did you install the chip-set drivers for the motherboard. It should be the first thing you do after installing the OS. You can get the chip-set drivers from the Motherboard manufactures web site.


Report •

Related Solutions

March 12, 2010 at 22:53:42
Okay I downloaded and ran SIW and found out I have the following Chipset;

Northbridge - SIS 645DX Rev 00
Southbridge - SIS 961 Rev 00

I found the SIS 645DX Rev 00 and installed it but the USB ports still do not work. This could be because the USB ports are controlled by the Southbridge chipset according to a document I read online. I have been unable to find the SIS 961 chipset.

Report •

March 13, 2010 at 06:14:51
It is the motherboard model number you need and the manufactures web site./

Where did you get this chip set driver from? Unless it was from the motherboard manufactures web site it may have been unsuitable. A lot of different motherboards will have the chip-set but the driver is dependant on how each individual manufacture has configured the chip-set in relation to their BIOS which is also individually configure.


Report •

March 13, 2010 at 06:17:03
an easy fix would be to just buy a PCI usb card, they are real cheap anymore. That will work

Report •

March 13, 2010 at 09:41:00
Okay I go them from so maybe that is why they are not working. If the chipset is unique to the motherboard why do these sites offer the chipset. Anyway I will have to try again. ASUS website was not working at all last night. I tried over and over and kept getting a message "due to the vast number of online conenctions the page will not display properly. Please click on one of the links below'. Well the global link just takes me back to and around in circles I go. I will try again today. AnD Xpuser may be right. I may just have to buy a USB card. I looked and I can get one for 34.99. It is just that it is waste to have usb ports in a machine if they don't work.

Report •

March 13, 2010 at 09:52:17
Check these prices on google:

I actually buy cards when things like the onbard ethernet doesn't work or the USB ports. It's a quick inexpensive fix and yes, it is a shame when existing onboard perifials don't work.

It doesn't really matter on the brand name, they all work the same

Report •

March 13, 2010 at 09:58:37
So I tried the Europe link and I was able to conenct there. I entered motherboard for the product, socket478 for the series (got this from SIW), and P4S533 for the model (again from SIW and located on the motherboard). I did a search, it asked me for the OS, I put XP and did a search. It comes back with the following;

BIOS (10) [BIOS History]
BIOS utilities (1)
Audio (2)
VGA (5)
IDE (9)
LAN (4)

Nothing that looks like anything to do with USB or chipset. I did read on a different post on here that there were problems with XP3 and USB. Maybe I wil try uninstall SP3 and see what happens.

Report •

March 13, 2010 at 10:02:02
In addition to problems with SP3 the problem for that guy turned out to be a program that was monitoring USB ports. The person helping with the problem asked the postee if he cared to share what program it was that he uninstalled. Of course he never got back to him. Does anyone have any idea what kind of program would monitor USB ports?

Report •

March 13, 2010 at 10:07:40
Okay I go them from so maybe that is why they are not working. If the chipset is unique to the motherboard why do these sites offer the chipset.

I have no idea when the Motherboard manufacture always supply drivers that are guaranteed to work and they know more than anyone else how they have configured their own hardware.

Although the chips themselves may be standard there are different way it can be configured. Different memory addresses, different port addresses, different facilities either configured or disabled. Only they will know.


Report •

March 14, 2010 at 01:25:45
First, make note to self to not buy anything with a SiS chipset in the future. They're messy and slow.

To install the USB driver or any other troublesome device driver, try the easiest route first:

Click on the yellow question-mark and then on Update Driver. Make sure you're connected to the Internet. The system will go to some mysterious location on the net and attempt to pair your hardware with the appropriate driver. Sometimes it will work, sometimes it won't.

If it doesn't work, look for the VEN_ (vendor) and DEV_ (device) values for your troublesome piece of hardware. They'll look something like:


But the numbers for your particular hardware will differ.

Type the vendor data into your search engine. The above vendor code is for Creative. When you know what vendor has made your hardware, go there. Do not go to all those Driverguide type places, they're a pest.

Search on the vendor's support and download pages for drivers for your particular device. In your case it is SiS.

SiS may or may not provide USB drivers for your hardware. Sometimes the hardware vendors buy drivers from other companies and may be restricted to only provide them on the accompanying CDs that come with the motherboard.

Alternatively, you can go to the motherboard manufacturer's home page, like you've already done, and search for drivers for your particular motherboard.

Now make another note to self to not buy stuff from Asus. They appear to have no trouble taking your money for their products, but they seem to be out of money for buying enough Internet capacity for their support servers? Maybe it is because they've spent their money on making fancy but totally unneccessary Flash and Java tricks just so you can choose what drivers you want? Ever heard of folders, Asus?

Never accept to install idiotic "download managers" like the one on Asus' site, to just download a couple of hardware drivers. You don't know what that download manager does behind your back.

Finally. After having found the right driver and verified that it works properly, save that driver along with some short note telling what it is. Like "USB driver for SiS on XP". Stuff disappear on the net and saving the file will save you the trouble next time the occasion arises.

Good luck.

Report •

March 14, 2010 at 16:10:07

I don't have a yellow explamation mark beside my USB items in device manager. However I have clicked on the item and said update driver but after a search nothing newer could be found.

Tomorrow I will look for the VEN_ name you to refer to and then do a google search.

Report •

Ask Question