USB Flash Drive not working, did everything?

Ocz technology 8gb rally2 usb flash driv...
January 9, 2010 at 17:36:14
Specs: Windows XP
I have Windows XP Home Edition SP3. My laptop is a Compaq V2000. I did all of the steps to fix and make my flash drive work. It never did work before. I just recieved it in the mail and plugged it in and recieved a Code 28 Access is denied when updating the driver for the USB Mass Storage. Steps that already tried:

1. Uninstall all USB port/devices and rebooted and back everything comes. Didn't work.
2. Checked the usbstor.inf and .sys. Seems like they are corrected.
3. I used to have Alcohol 120, tried getting rid of stpd.sys and using uninstall stpd .exe from duplex security. Didn't work.
4. Allowed permissions for users in regedit and cleaned up registry. Didn't work.
5. Tried using other USB ports(only 4 of them). Didn't work.
6. Works with everyone elses computers instead of mine.
7. Updated Windows XP. Didn't work.
8. Checked services and UPNP. They were all good.
9. Downloaded the driver from official site and installed. Didn't work.
10. Tried upgrading BIOS from the manufacturer website(HP). It said I had the wrong type of computer...

Tried other smaller steps as well but been trying since the last two days. I really want this to work and can't consider restoring the computer because of all my stuff I have and important documents.

Anyone have any more ideas I can try to make this work?

Also one thing, my BIOS setup doesn't have the PnP option enable/disable option. I don't know if that will effect it. Also, when I was updating from SP2 to SP3 and with Windows XP updates, it fixed my mouse driver problem so theres no more yellow problem at the device manager. Only problem was my USB flash drive out of every devices.

See More: USB Flash Drive not working, did everything?

January 9, 2010 at 19:04:08
Does the drive work in a different system?


Report •

January 9, 2010 at 20:18:48
Yes, it does. But I figured it out already.

If you have some sort of security or anti-virus software. Its basically whats causing that "Access Denied" and not able to install USB or recognize them. Even if your the Administrator. I basically missed a small step.

All I did was go into Safe Mode, then update the usb flash driver from there. And worked perfect. Then restart back normally.

But its also important if you have a virtual drive before is to remove that virtual drive first to see if its causing the problem.

Report •
Related Solutions

Ask Question