USB Alzheimer: need to reboot for machine to see USB ports

October 28, 2012 at 05:25:09
Specs: Windows XP pro
I have a Dell Precision 390 desktop with XP Pro. Lately I've noticed that in order for it to recognize any USB device like a printer or a flash, the device has to be plugged in when the machine is rebooted. If you connect after a reboot, or even disconnect a device after a reboot and try to reconnect it, the machine will not see it. This has been going on for awhile. I am on the brink of buying a new machine but I do want to give it one last try.

I scanned the machine with malware: nothing found. I rebooted it after keeping the machine unplugged from power for some time. That worked as a fix in the past but not anymore.

Anything else I can do?

By the way, if I decide to uninstall all USB device drivers and reinstall them, will I need to reinstall from scratch the USB printer that is currently connected to my machine?

Thanks much!

See More: USB Alzheimer: need to reboot for machine to see USB ports

Report •

October 28, 2012 at 06:44:13
Normally a good computer, but there have been these usb ports. You can try uninstalling and reinstalling the drivers, but unfortunately this does not seem to work often. The device is recognized when you plug it in?.....makes the noise, but then does NOT load the driver for the device and it doesn't function. If you go to device manager when a USB device is plugged in does it show the yellow exclamation mark for your device? If so, selecting it and upgrading the driver, will usually work. That is however a pain. The bad news is, so far I have not had luck with virus/malware removal fixing the problem, system restore or repair options. The only thing that has worked is to save all your data and reinstall fresh, which is generally the last thing anyone wants to do, but I have not found a quicker way, maybe someone else has a magic bullet for this one, but so far, I have not found any that work. The USB is enabled in the bios or the device would not be seen at all. PS if you do reinstall....these are the drivers you will need.

Report •

October 28, 2012 at 12:36:55
Are you running SP3 plus all the updates since then?

Try installing the chip set drivers. Go to the link below and follow the instructions.

Report •
Related Solutions

Ask Question