There was a problem installing this hardware

February 1, 2010 at 12:27:59
Specs: Windows XP Home Version: 5.1.2600 service pack 3, Intel(R) Pentium(R) 4 CPU 2.80GHz / RAM : 512mb
Hi there,
I hope that I can get some help with an issue I am having trying to connect new components via my usb ports. I've had the problem for some time and have tried various things which I will list below, but have been able to get around it by using another computer, which I now no longer have so I need to try to sort things out.

Problem computer : 2004 Dell Dimension 4600 supplied with XP service pack 1 install CD
O.S. : Windows XP home service pack 3 regularly updated.
Norton AV & Firewall regularly updated and showing no problems.
Additional anti-spyware etc..Malwarebytes, A-squared, Spyware Blaster and IE spypad.

What happens is this.... Where the new device has come with a installation CD I have followed the manufacturers install instructions, the software from the CD loads fine until it tells me to connect the device to the usb port. When I connect I get the new hardware icon in my task bar and the new hardware wizard pops up as normal. Then, when requested, I try to install new hardware such as a webcam, tv tuner, phone,or a new usb flashdrive into my usb port and the wizard starts going through the process of installing. ( The usb flashdrive has no install CD)
However it then stops and brings up the same window every time "There was a problem installing this hardware. An error occurred during the installation of the device. The data is invalid."
I have tried...
1) Putting the device in the usb port first before installing the software and wait for the wizard to tell me to put the install disc for the device in. Also tried a manual search for device and drivers.
2) Putting the device in usb port and restarting the computer with it still attached, both with the software installed and not installed.
3) Tried on all usb ports with same outcome.
4) Updated, rolledbacked, deleted, jumped up and down on :-) and reinstalled usb drivers/controllers.
5) Looked in Device Manager with hidden devices turned on and it shows no conflicts. Under the various usb/controller properties each device shows as operating normally.
6) Where applicable I have downloaded the devices latest software direct from the manufacturers site to get the latest version.
7) Ran scannow/
8) Tried the above tasks in safe mode.
9) Tried numerous google searches before asking here.
10) When problem originally was noticed I tried system restore, over a year ago.
11) Done AV and spyware scans.
12) It is not a usbv1.1 or usbv2.0 problem.

I searched on Microsoft's site and found two articles relating to my problem
h##p:// and h##p://

Being computer illiterate I have not tried these. The first article because I only have a service pack 1 installation CD that came with the computer. Will it still do the required job?The idea of replacing the CAB file in I386 from the installion disk fills me with dread, not the ability to physically do it but that I might make my computer in accessible as a result.
And the second article mentions registry changes which I know can go badly wrong.
It has also been mentioned to do a clean install of windows but that is a bit out of my league I think.

I don't think it is a problem with the usb ports because older installed hardware such as camera ,ipod,usb sticks ( by the way the same model as the one I can't get Windows to aknowledge) all load fine from usb.
There doesn't seem to be a problem with the devices I can't load onto this computer as the loaded straight away on another computer.
It seems like at a certain point in time something related to my New Hardware wizard stopped working.

Any thoughts or suggestions would be great. Thankyou.

See More: There was a problem installing this hardware

February 1, 2010 at 13:24:54
What service pack is installed on the machine? You need at least service pack 2. Let's start here.
Edit, never mind I see you have sp3.

Report •
Related Solutions

Ask Question