Strange http 501/503 behavior....

Dell / XPS 630I
January 30, 2009 at 09:40:30
Specs: Windows XP, Intel Core 2 Duo

My folks' office is connected to the net using DSL and the PCs in there are connected using both LAN/Wi-fi (total of 1 LAN Client and 2 Wi-fi Clients all on Windows XP SP3). They were running on a Belkin Wireless G Router (F5D7230-4). While the connection was not always stable, everything (internet, web applications) worked when it is connected. A few months later, they got a little fed up with the constant connection drops from the Wi-fi signal and had to reset the modem/router a couple of times each day and switched to a D-Link Wireless N (DIR-625 RevC).

Now, the Wi-fi stability problem is solved and they didn't have to to reset 5 times each day and the users have more stable connections to the internet. However, one of the web applications they use now have a problem. When they attempt to log into the web application using IE7, it gave them a http 501 or 503 message. This happened on all clients, the LAN and both Wireless clients.

The DSL service has not changed and the web application was functioning correctly while under that old, albeit Wi-Fi unstable Belkin. So calling the web app's tech support and they claim everything is working fine on their end. Asked me to uncheck the use http 1.1 in advanced setting, nothing. Uncheck show http friendly messages to attempt to run an diagonostics couldn't produce any noticeable results. So finally, the tech asked me to try Firefox 3 with Adobe Reader 9 installed. I went and did that on the LAN Client, and strangely enough, Firefox 3 with Adobe 9 worked just fine.

A few weeks later, I finally had the chance to see if I can follow this up on the Wireless clients. As the users say as long as they can get on the web app it is fine, they don't care which browser they would use. So I installed Firefox 3 and Adobe 9 on one of the Wireless clients, cannot connect and seem to be acting like what IE7 is doing.

Could there be a setting in the D-Link Router that may be causing this? As far as I know, no related settings were changed on any of the clients and no DSL service type was altered prior to the router switch. Logic would have me beliving that it may have been caused by the D-Link router. I e-mailed their support, got one response telling me to do things I already did to set up the router in the first place and nothing else.

So right now, the current status at the office is:

LAN Client -
IE7/Adobe 9 - Http 501/503
FF3/Adobe 9 - No connecion problem

Wireless Client -
IE7/Adobe 9 - Http 501/503
FF3/Adobe 9 - Http 501/503 (may not be the same types of messages, but it just won't connect correctly like the LAN client using FF3)

Any suggestions? Is it the Router? Something with IE7? Strangely enough, we use the same router with the exception being the one at home is a RevA and we use Cable Modem as ISP. But we had no problem connecting to the web application correctly with IE7 using LAN or Wi-Fi. Both Routers (home or office) were set up using same basic paremeters with WPA2 security (it'll take both WPA/WPA2) and no other advanced settings were really messed with.

Thank you for your time.

See More: Strange http 501/503 behavior....

Report •

January 30, 2009 at 10:13:08
Try plugging a computer directly into the DSL modem. Does it work then?

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

February 2, 2009 at 09:25:55
Hi Ryan and thanks for the response.

In trying to figure this out I had forgotten to give that a test to see if it works.

I haven't had time to go there to test it out this past weekend. I will be sure to find some time to check it out sometimes this week.

Will post the result when I do.

Report •

February 5, 2009 at 08:49:01
Ok, need to clarify my original message a bit, it was a http 501/http 505 message on that site that was displayed when attempting to log into the web application using IE7.

That being said, per the suggested, I went and connected the LAN Client directly to the DSL Modem (no other settings changed) and tested the settings out. Everything seems to work fine with the web application, even with IE7 on the LAN Client.

After this test, I had to re-setup the Wireless Network so the clients can use their PCs. Upon completion of the Wireless Network connection, everythings was "back" to where the my original question stands. That is, IE7 doesn't connect to the Web application and display the http 501/505 message on all LAN/Wireless clients, Firefox 3 doesn't connect to the Web Application for the Wireless Clients, but "does" for the LAN Client.

Again, have tried disabling HTTP 1.1 in IE Settings. Disabling friendly HTTP Messages just show a blank page, without telling me which program/application/process is/may be causing the interference.

So logic seems to point to the D-Link DIR-625 Wireless Router being the problem. But at this point I still don't know which setting on there could be causing the problem.

Thanks again for any advice.

Report •

Related Solutions

February 5, 2009 at 10:39:10
If it works when plugged directly into the modem, but doesn't work when connected to the router, then it is the router.

I know some Linksys routers have the ability to filter ActiveX among other things. I would suggest you reset the router to its defaults, update its firmware, then test again (before doing any special configuration). If that works, go through and manually configure the router as needed (wireless passwords, etc.), testing after each change.

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

February 5, 2009 at 10:57:14
Hi Ryan:

Thanks for your response. Well, the funny thing is that after the test I performed, I pretty much did do a Reset of my Router to defaults in the process of getting the other clients back up and running. The Firmware is up to date.

So it could possibly be an ActiveX filtering setting eh? Maybe I will have to look into that.

Thanks again and will post results if I find anything.

Report •

February 5, 2009 at 12:57:51
I doubt it is due to ActiveX filtering, but as I said, there are multiple filtering options on some Linksys routers. I don't know about your router specifically, so I offered that as an example.

On another note, the 50x errors are all server errors. That means something has failed on the server side (as opposed to something like a 404 error which can indicate the client doesn't have a Internet connection or something). I would recommend you look at the web server logs to see the details of the error message. It could be that the website is either getting data it can't process or isn't getting data it is expecting. I've had a few problems where routers, firewalls, and "privacy" software prevent a computer from transmitting the browser string (information which tells the website about your OS and web browser version) and the website in turn doesn't know what to do.

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

Ask Question