Speedtouch 330 and XP Pro

August 4, 2009 at 12:05:47
Specs: Windows 2000
I have just acquired two machines running XP Pro. (I prefer 2000 Pro and am not keen on XP - but won't touch Vista!) I can't get either to connect to my broadband via the Speedtouch 330. My ISP says I need PPPoA but XP only gives me PPPoE. It also won't seem to try USB but keeps trying to open a WAN miniport - even when LAN, WAN and 1394 are disabled. Please don't suggest I get a wireless router - I don't need one as I only connect one machine up at a time, and I don't trust them anyway. Machines are an IBM ThinkPad and an anon 3 GHz tower. On 2000 Pro, I have no connection problems with my Omnibook, but a slight problem with the Dell tower which I suspect to be the USB in the tower. Thanks in advance. Baloo

See More: Speedtouch 330 and XP Pro

Report •

August 4, 2009 at 13:39:48
"My ISP says I need PPPoA but XP only gives me PPPoE."

XP doesn't "care" which of those methods you use to connect to the internet.

USB devices may not work correctly when they're connected to certain USB ports, e.g. ports in a hub or on the front of a desktop case.

See response 3 in this:

You must install software for the Speedtouch 330 on every computer you connect it to.

You install part of the software for the Speedtouch 330 BEFORE you plug it into a USB port, then you install the rest of it. See your manual for it - it's probably on the CD that came with it, or see this manual:

Report •

August 4, 2009 at 14:33:38
Have installed Spoeedtouch (twice)...... Windows may not care, but my ISP reckons PPPoA is required for using their service via Speedtouch. In 2000Pro there's just PPP....

Report •

August 4, 2009 at 14:42:29
I'm a bit rusty on Speedtouch 330 but I just thought I'd confirm that I once used this same USB modem on XP Home and it worked just fine.

I feel sure it is possible on XP Pro provided you install the correct drivers and heed the advice already given in #1, so take heart....

EDIT: I overlapped your previous post - my slow typing LOL.
I am currently using a router with XP Home and using PPPoA, so I don't believe it is an XP issue.

some other bloke...

Report •

Related Solutions

August 4, 2009 at 18:39:20

"Have installed Spoeedtouch (twice)...... "

Did you READ and understand the installation directions?
Do you install it correctly?

"You install part of the software for the Speedtouch 330 BEFORE you plug it into a USB port, then you install the rest of it."

If you didn't do that correctly, you MUST unplug it's USB connection, un-install it's software in Add/Remove Programs, then install it properly.

NOTE what I pointed about to about USB ports. The Speedtouch probably won't install properly unless it is detected properly when you plug in the USB connection during the middle of the software installation.

NOTE that, same as for any software installation, you need to have a minimum of programs running when you install software, in case they interfere with the installation, including you may need to DISABLE the resident part (the part that scans all the time) of any anti-malware software that is loaded.

"...my ISP reckons PPPoA is required for using their service..."

Did you look to see if the ISP has instructions regarding that? If they're the one who supplied you with the Speedtouch 330, they may have specific instructions for that model, or they may have supplied printed instructions, or an ISPsCD that helps you with that, with it. .

According to the manual I found the Speedtouch 330 supports that automatically. Unless your manual says different, so does yours (sometimes the features and the modem manual is different depending on which region you bought it in). If you don't have the proper manual, find it on the web, for the region you bought it in.

If you were using a router, you set up the type of internet connection in the router's configuration, in an internet browser via a URL that accesses that, not in Windows (other informing it than you're using a broadband connection). In most cases the default connection type is Dynamic, and you must change that if you need to connect some other way.

Report •

August 5, 2009 at 10:45:13
I installed Speedtouch from the CD as per the instructions on screen - plugging in when stated. It said the installation was complete (Dr Speedtouch is a separate instal). Exactly as I've done on the Dell and Omnibook (both 2000Pro). My ISP doesn't supply things like CDs or instructions. You decide what to connect with - and I don't want wireless. If you have a problem, you ring or mail in. (I'm not with one of the big ones - I'm probably their only customer on our local exchange. They're not the cheapest, but I like their personal service.)

Won't be doing anything tonight with it as I have to be out at 0330 in the morning.

How did you get PPPoA on XP Home - or did it come with it? My XP Pro only gives PPPoE.

Report •

August 5, 2009 at 11:50:47
"How did you get PPPoA on XP Home - or did it come with it? My XP Pro only gives PPPoE". Assuming you were responding to my #3 :-

Remember I am now using a router, not Speedtouch. I didn't have to do anything, PPPoA just arrived in my router settings. Also note that I am in the UK and this could make a difference. It's just that it casts doubt upon the idea that PPPoA and PPPoE are much to do with XP itself, more likely a server thing. This seems to support that view:

some other bloke...

Report •

August 5, 2009 at 18:47:59
I've set both 2000 and XP - they aren't much if any different when it comes to non-wireless internet connections.
Have you set up XP for your broadband connection??
e.g. in Internet Exlporer - Tools - Internet Options
OR in Control Panel - Internet Options
Connections - etc.

Report •

August 6, 2009 at 10:54:34
Forgot to say I'm in the UK.... Don't use IE - only allow it to stay because I can't seem to get through to MS update pages with it. Otherwise, it would be binned. (I'm trying to get rid of Outlook Express as well, but that's another matter - so is Windows Messenger which I neither want nor use.) Yes, I have been into control panels. (For reference, I've been working with computers since both the 8080 and the original Mac - not counting Atari, Einstein and BBC on the side.) I'm starting to think about getting a LAN connected router - we've plugged into someone's LAN and that worked OK. No, I'm not having a wireless one...

Report •

August 6, 2009 at 12:08:35
"I have no connection problems with my Omnibook...."

Are you using the Speedtouch 330 with that?

"...a slight problem with the Dell tower which I suspect to be the USB in the tower."

Did you check out my USB port info, etc. ? ( it's also possible you have an IRQ sharing problem you need to fix - see the link in response 1) ) Try other USB ports with it?

Whether or not you prefer to use IE or not, you should keep it up to date - at least install the critical and security updates for the version you're using. IE isn't just the internet browser - when you update IE you are also updating a lot of files that other programs use, including other browsers.

You don't necessarily need to use wireless with a router that has wireless capability - they almost always also have regular network ports as well, and the wireless broadcast can always be turned off in it's configuration - in fact it's often turned off by default when you get the router.

I don't have a USB connected high speed modem, so I don't know what you should check to see if it's being detected by Windows properly. The only one I have fiddled with is a Motorola cable modem that has both a USB connection and a network port, and it's connected via the network port via a router to 5 computers, so I didn't set it up to be connected via USB.

If the Speedtouch 330 is being detected properly (are you SURE it should work in the USB port you have it plugged into according to my info?) , and if it's software is installed properly, there's probably some small setting thing that's causing your problem.

By the way, how long have you been presently using this ISP? If you have just gotten signed up, or if you were using it but let you payments lapse and it was disconnected, then you started it up again, there is often a delay, e.g. a week, before the connection is actually enabled.

Report •

August 10, 2009 at 14:58:39
Apologies for irregular attendance - very heavy week last week, and going away this week...
I've been with this ISP since RedHotAnt collapsed - quite a long time (2001). If I have a payment problem (like changing my debit card and forgetting to tell them), they just ring me and leave a message. No disconnection. (That's one reason I stay with them!)
USB sockets - the 'new' laptop only has two anyway. The 'new' tower has 6 - four back, two front. Tried all of them. Yes, the Dell tower and the Omnibook work off the Speedtouch - the Dell needs to be changed socket-wise now and then, which is why I suspect the USB in it. No problems with Omnibook. I've has similar problems on Dell with a different SpeedTouch 330, but the Omnibook worked fine. The non-recognition problem is only on the two XP Pro machines.
Won't be doing much with this for a week (unless the office leaves me alone tomorrow). Might try the laptop on wireless while away - not guaranteeing anything. (Might just watch Ratatouille and Flushed Away instead...) Ta for all the suggestions.

Report •

August 10, 2009 at 20:06:09
See the info in the latter part of the first link I provided in response 1 - you might have an IRQ sharing problem on the Dell - the USB ports directly connected to the mboard (in the main I/O area on the back) should work properly for sure with anything - the front ports might not.

Check the current voltages in the bios - if the +5v reading is too low (more than 10% low) the USB ports are more likely to not work properly. Replace the PS if you see that.

I've been able to get any modem or combo modem/router to connect in 98, 98SE, 2000, and XP on many computers, mostly wired connections, some wireless G, and one installation of Vista, but like I've said, I haven't tried setting up a USB connected one's USB connection.

All the standalone modems have not required a configuration to be set up, but the combo modem/routers and routers do.
The ones I've used default to a dynamic connection - that's what all the major ISP's I've used use here in Canada where I am - but they can all be set up for other types of connections, and I've noticed depending where a person is and where the device was purchased , the default connection can be different. I certainly haven't ever had to set the type of internet connection in Windows itself, other than setting it to a broadband connection, so I don't think the operating system being XP, specifically, has anything to do with your problem. It might be you're missing something you need to set in XP, but not the internet connection type, other than setting it to a broadband connection.

If you're connecting to the internet with the Speedtouch 330 with the Omnibook, take a look for indications of what indicates the modem is being detected. I know if the modem is wired via a network cable I haven't, but you might since it's USB connected.
- under Device Manager - USB controllers
(USB mass storage devices show up there - flash drives, external drive controllers, memory cards - maybe the modem will)
- somewhere else in Device Manager

Or try turning on show uPNP devices in your Network settings - that makes a router or combo modem/router show up there - the Speedtouch 330 might show up there as well.
However, I don't recommend you leave that enabled all the time - malware and hackers can use that.

If you do see something like that, you should see similar in XP. If you do see that in XP but the internet connection still doesn't work, something else is wrong.

Report •

Ask Question