Software fails to reinstall for my hp 3390 laser printer

January 6, 2014 at 12:02:39
Specs: Windows XP
I had to replace the fax card in my HP 3390 all-in-one printer, due to a power surge, compliments of the phone company. After that, the scan software in the computer wasn't recognized, so..I tried to reinstall the factory 3390 software but now it fails part way through the install. The print drivers are ok...the printer prints fine....faxes fine, copies fine..just can't scan. Windows XP Pro, SP3
Error number is Validate # 724288. error code: 24016973


message edited by MCharlie

See More: Software fails to reinstall for my hp 3390 laser printer

Report •

January 6, 2014 at 15:14:54
HP are the people you should be contacting in this regard. Have you rechecked the installation, connections etc.?

Report •

January 6, 2014 at 16:00:22
Oh yes....It is a software issue..error msg: Sorry, could not find required user interface files. Hp will no longer support the 3390 printer.

Report •

January 6, 2014 at 20:59:42
Try using the uninstall tool from HP. Reboot and then try again. Get the tool from the link below. If the driver version you have is not the one this tool was made for then Try the HP site for a different tool.

Your installation is failing because the software is partially installed.

Sometimes you need to disable all programs running in the background. That includes AV software. Read the help files on the install CD from HP for installation help.

message edited by OtheHill

Report •

Related Solutions

January 7, 2014 at 00:01:51
One hill...good suggestion...have already done that..3 times now.

BTW..Here is the error message that pops up when I try to scan something

[Sorry, could not find required user interface files. (Please re-install scanning software.)

...probably because the installation never fully finishes.

Report •

January 7, 2014 at 04:49:16
Then try downloading the latest drivers and application software from the link below. Be sue to follow the installation step fully.

Most times you should NOT connect a USB device until instructed to do so.

Report •

January 7, 2014 at 08:00:29
Already done.....No joy! :(

Report •

January 7, 2014 at 11:21:38
Maybe the printer is damaged.

Did you manually remove the folder for the software? If not, do that and then run the registry module in Ccleaner Slim to remove any orphan files. Get Ccleaner Slim from the link below.

Keep in mind, you must run the removal tool each time you have a failed attempt at installing.

You could also try a custom installation using your original disk. You should be able to de-select one or more of the modules. For instance, if you don't use the FAX function, don't install it. If the scan function is bad, de-selecting it may allow installing the printer function.

Have you tried installing when logged in as the Administrator.

Do you have any other scanner software installed?

Report •

Ask Question