Slow Internet 1-2MB BUT 10MB in Safe Mode!!!

January 31, 2011 at 03:59:39
Specs: Windows XP, 512MB RAM / Intel Celeron
I wonder if someone could help me please?

I have a 10 mb internet connection. Just lately I have been getting 1-2mb connection only.

I have windows xp with avast antivirus and zone alarm fire wall.

My ISP came out and plugged a laptop into my router and got 10mb straight away.

I have booted in windows xp safe mode with networking and I get 10mb straight away, therefore it must be something running that is throttling the speed. It is the same for several accounts on the same computer.

I tried switching off avast and ran the speed test and it was the same still throttled. I tried disabling the firewall and it was the same still throttled.

Avast found no viruses until I did a 'scan at boot time' which found about four, and cleared them, but it is still slow.

I am fairly computer literate and wondered if anyone can help me with this please?

I have a fair few svchosts running, they aren't hogging the processor but probably using some memory, but I'm not sure if this is a red herring?

Many thanks!

See More: Slow Internet 1-2MB BUT 10MB in Safe Mode!!!

Report •

January 31, 2011 at 08:48:43
You have installed an Anti-Virus, Spy-Ware Detection or Firewall like Commodo that is scanning every thing which is slowing your computer down. Think of what you have installed recently that might do this and remove it. You could also send us your task list which might help. To do this run the following command...

tasklist > mytasks.txt

Then open the mytasks.txt that is in your My Documents and paste the contents.

Report •

January 31, 2011 at 09:20:21
Thanks very much for your help.

I am using zone alarm which has not had a recent update. I am using avast antivirus. I have tried disabling avast completely including all real time shields and the speed is exaclty the same. The only thing I installed over the last six months was a firefox 3.6.13 update on the 10/12/2010. If it was this I wonder why it would work in safe mode - :-/

Here is mytask list:-

Image Name PID Session Name Session# Mem Usage
========================= ====== ================ ======== ============
System Idle Process 0 Console 0 16 K
System 4 Console 0 52 K
smss.exe 492 Console 0 48 K
csrss.exe 556 Console 0 1,088 K
winlogon.exe 580 Console 0 1,164 K
services.exe 624 Console 0 716 K
lsass.exe 636 Console 0 1,356 K
svchost.exe 788 Console 0 1,476 K
svchost.exe 836 Console 0 1,132 K
svchost.exe 920 Console 0 9,188 K
svchost.exe 1048 Console 0 652 K
svchost.exe 1104 Console 0 2,564 K
vsmon.exe 1180 Console 0 11,904 K
explorer.exe 1496 Console 0 18,636 K
AvastSvc.exe 1760 Console 0 17,700 K
spoolsv.exe 2040 Console 0 424 K
svchost.exe 784 Console 0 168 K
svchost.exe 1156 Console 0 164 K
svchost.exe 1332 Console 0 320 K
starter.exe 2296 Console 0 132 K
zlclient.exe 2412 Console 0 3,340 K
AvastUI.exe 2424 Console 0 980 K
svchost.exe 2896 Console 0 144 K
firefox.exe 172 Console 0 64,296 K
AppleMobileDeviceService. 2008 Console 0 200 K
plugin-container.exe 3348 Console 0 45,440 K
mbam.exe 3984 Console 0 72,144 K
ntvdm.exe 4040 Console 0 84 K
cmd.exe 1092 Console 0 96 K
tasklist.exe 1224 Console 0 1,996 K
wmiprvse.exe 1380 Console 0 5,824 K

there are alot of svchosts but wonder if this is a red herring,

Many thanks for your help!

Report •

January 31, 2011 at 11:51:15
So you are using Avast and Malwarebytes at the same time. This is your problem. Pick one and remove the other. also, does Avast have a firewall built in? If it does drop Zone Alarm.

Report •

Related Solutions

February 1, 2011 at 02:55:56
Many thanks for the reply. I only installed Malwarebytes yesterday to run a scan - it found nothing. Avast does not include a firewall.

I am stumped.

Thanks alot for you help though,

Report •

February 1, 2011 at 04:48:20
I don't think running software apps will cut your connection speed that radically. I had a similar problem a year ago with verizon dsl. It turned out my router was failing and eventually just fizzed. I got a new Netgear and things are fine now. You could try shutting down the router and resetting it and see if the problem persists.

Report •

February 1, 2011 at 06:17:24
Many thanks for your reply.

My ISP came out to test my connection in response to this problem - they said it is my system. They also gave me a brand new netgear router! The problem is still the same pre and post new router. Also as the internet works fine in safe mode sort of excludes the router hardware (please correct me if I am wrong, I am learning).

Many thanks for your help!

Report •

February 1, 2011 at 06:41:09
I doubt it is the router. It is some program that is not loading in Safe Mode that is loading in normal. We looked at the apps, now it is time to look at the services. Did you do any updates or install any new drivers around the time this problem started happening. If so try uninstalling them.

Also can you do the following command and post the results...

NETSTAT -B > MyOpenPorts.txt


Report •

February 1, 2011 at 07:55:23
Upon reading your post again, I agree with Ace. This is a software application that's bottle necking the system.

Report •

February 1, 2011 at 08:18:08
Many thanks for your replies.

I also confirm that ping test fails on packet loss test everytime even if I switch off my firewall.

Here is the contents of myopenports.txt:-

Active Connections

Proto Local Address Foreign Address State PID
TCP evaluation:1046 localhost:27015 ESTABLISHED 2920

TCP evaluation:1064 localhost:1065 ESTABLISHED 3580

TCP evaluation:1065 localhost:1064 ESTABLISHED 3580

TCP evaluation:1081 localhost:1082 ESTABLISHED 3580

TCP evaluation:1082 localhost:1081 ESTABLISHED 3580

TCP evaluation:2918 localhost:12080 ESTABLISHED 3580

TCP evaluation:12080 localhost:2918 ESTABLISHED 1348

TCP evaluation:27015 localhost:1046 ESTABLISHED 1796

TCP evaluation:5152 localhost:1563 CLOSE_WAIT 1848

TCP evaluation:2919 CLOSE_WAIT 1348

TCP evaluation:2750 LAST_ACK 1348

TCP evaluation:2796 LAST_ACK 1348

TCP evaluation:2807 LAST_ACK 1348

TCP evaluation:2813 LAST_ACK 1348

TCP evaluation:2844 LAST_ACK 1348

TCP evaluation:2848 LAST_ACK 1348

TCP evaluation:2850 LAST_ACK 1348

TCP evaluation:2853 LAST_ACK 1348

TCP evaluation:2855 LAST_ACK 1348

TCP evaluation:2858 LAST_ACK 1348

TCP evaluation:2859 LAST_ACK 1348

TCP evaluation:2861 LAST_ACK 1348

TCP evaluation:2864 LAST_ACK 1348

TCP evaluation:2873 LAST_ACK 1348

TCP evaluation:2916 localhost:12080 TIME_WAIT 0
TCP evaluation:2778 TIME_WAIT 0
TCP evaluation:2868 TIME_WAIT 0

Many thanks!

Report •

February 1, 2011 at 09:38:54
It looks good to me. It looks like all internet activity is going through Avast so my only guess is that the problem is in Avast. Check the settings and see if there is something you can do to improve performance.

Some other things you could try is to run a TRACERT to see where the most speed lose is:


Otherwise I have no idea.

P.S. You have a ton of things open. Is this a fresh boot. Here are the sights you have open at the time you did netstat...

TCP evaluation:2919 CLOSE_WAIT 1348

TCP evaluation:2750 LAST_ACK 1348


Note: has a lot of ports open. I don't know what you are doing with this but it could be eating bandwidth.

Report •

February 1, 2011 at 09:48:37
Yep it is defiantly that is killing you.

Report •

Ask Question