Setup did not find any hard disk drives insta

April 11, 2010 at 10:33:03
Specs: Windows XP
Hello everyone...I have this PC and the current HD has a virus on it, so I am trying to format with a new copy of Windows XP SP1.

The hard drive is an IDE and the jumper is set on master. But when it goes to install Windows, it tells me "Setup did not find any hard disk drives installed"

I thought this was a problem with SATA Hds???? It's a built PC, the motherboard is a ASUS P5GD1-VM

Please help. Thanks so much!!!!

What am i doing wrong?

See More: Setup did not find any hard disk drives insta

April 11, 2010 at 10:55:06
your HD may be dead. If you have another HD, try that and see if it works.
Also maybe take the jumper right off and try.

Some HELP in posting on plus free progs and instructions Cheers

Report •

April 11, 2010 at 11:33:13
Is the HDD showing up in the BIOS?

Report •

April 11, 2010 at 12:20:35
Does the HDD spin up when turning PC on?

Report •

Related Solutions

April 11, 2010 at 15:41:08
thx for the reply everyone. The hard drive will work if i let it load into windows.

Also, the hard drive does not show up in bios...just the cd rom

Primary IDE Master: CR-48X5TE

What am i doing wrong here??


Report •

April 11, 2010 at 15:59:06
If both, CDROM and hard drive are connected to the same cable, set CDROM jumper to slave and check, whether the hard drive has a jumper called slave present. If so, it must also be set.

Report •

April 11, 2010 at 16:05:56
cd rom and HD are on 2 diff. cables. What should the HD jumper be and what should the cd-rom jumper be?

thx so much

Report •

April 11, 2010 at 16:22:19
In that case, both can be set to master.
But you might check the bios setting and check, whether both IDE controller channes are enabled.
If, as you wrote, it's definately an IDE hard drive, it should be shown in the system bios, except, the mainboard supports also SATA hard drives.
In that case, mostly the IDE hard drives are only shown on computer startup at the bios diagnostic screen at the very first beginning.

Report •

April 11, 2010 at 16:25:35
it is deff. an IDE drive.....i will set them both to master and let u know...thx so much

Report •

April 11, 2010 at 16:37:11
still the in the bios...just the cd-rom is showing up as IDE's not showing the HD.....

But in the boot order it is showing the HD....

Plz help

Report •

April 11, 2010 at 19:10:50
Ok, in the system BIOS where IDE devices are shown, is there an option to automatically detect IDE device for each IDE channel?
If so, try to let the BIOS automatically detect the devices.

If this does not solve the problem, you can try to disconnect the CDROM drive just for testing, then switch computer on, enter the BIOS and check the drives.

Report •

April 11, 2010 at 21:41:40
I know I am reaching a bit on this one but I have seen this happen once. What size is the drive gb wise? Is the drive partitioned? I ran into one a year or two ago that a person was having almost the same problem. It was basicaly telling him that he did not have enough space for the OS to be put on his small older drive because he had somehow skipped formatting the drive before trying to load the OS.

You are still able to boot up, the drive has not yet been formatted right?


I want to go like my grandfather did. Peacefully in his sleep. Not screaming at the top of my lungs like the passengers in his car.


Report •

November 16, 2010 at 18:36:47
someone help me please having a problem , i instal a new hd in my pc it dosnt have no OS yet so i put windows 7 cd in and it loads everything when it comes to install in hard drive its says no device found hmm , that hd is new pls anyone help me pls

Report •

November 16, 2010 at 19:46:52

This subject is probably not about your problem - he had an IDE hard drive. .

Your hard drive is probably a SATA II drive.

Your mboard's bios Setup must detect the hard drive.

If it doesn't, load bios defaults, Save settings, and look in the bios Setup again.

If it still doesn't show up as detected.....

If you have a desktop computer.....

Check your SATA data cables. The connector on each end should "latch" into the socket on the drive and on the mboard, or on the drive controller card - it should not move when you merely brush your hand against it near the socket - if it does, mere vibration can cause a poor connection of it - use another SATA data cable that does "latch", or tape the connector in place.
(There is a slight projection or bump on one side of the outside of the connector that "latches" it into the socket - it's easily broken off or damaged)

The same thing applies for the SATA power connection.

If the hard drive shows up in the Bios Setup, but the Windows DVD doesn't detect it, then....

the situation is probably the same as for XP and 2000.

The Windows DVD won't detect SATA or SATA II drives because it doesn't have the SATA drive controller drivers built in, unless.......

- the bios Setup has the SATA controllers in an IDE compatible mode of some sort.
- you provide the drivers for the SATA controllers on the mboard while loading files from the Windows DVD, e.g. via them being on a flash drive, or on the CD or DVD that came with the generic system's desktop mboard or the brand name computer.

Report •

November 17, 2010 at 05:31:32
I also faced the same problm.
and resolve it by going in BIOS setup and diseble the SATA native support.
and this works for me.
if still unable ???
you should delete and re-create all your drives in HDD.

Best of luck.
do this at you own risk.

Report •

Ask Question