Runtime Error, Line : 0, Object Expected

Microsoft Als windows xp professional
July 23, 2009 at 13:21:40
Specs: Windows XP
I have been having this problem lately. One day I logged into my account on this shared computer. Background was blank. When I click on start there is nothing pinned to the quick start menu anymore, instead it showed a flashlight. Nothing is loading up on the bottom right of the task bar. Only the sound options, and that doesnt load.
When I try to run ANY program, whether it be by double clicking, on the program directly from its install location, to using shortcuts, does not work. Instead it gives me an error.

"Windows cannot access the specified device,path or file. You may not have the appropriate permission to access the item"

After trying a lot of things I found that I can start programs by right clicking on file from the program such as a .dll file for a game and "opening with" the .exe file that usually starts it. But this works on only a handful of programs.

I'm basically not able to do anything cept go on the internet microsoft word and a few games. Now, My sister has an account on this computer as well, and when I signed into it, its running almost perfectly fine, except for a few things, I tried to run system restore on her account, it gives me this error:
"A Runtime Error has occurred. Do you wish to Debug?"
"Line: 148 Error: Oject expected"

I've tried clicking no, nothing happens, I tried cliking yes, all it gives me is an option to choose a "New instance of Microsoft Script Editor", which is then followed by another error

"Unable to continue because the system file MSXML3.DLL cannot be found."

"This error can appear if a required system component, MSXML3.DLL is either missing or was not installed. This system component must be installed before this error can be resolved.
To resolve this error, install the MSXML3.DLL system component by clicking one of the links below.
MSXML3 Service Pack 4 Release from MSDN
Internet Explorer 6.0 via Windows Update"

And the same thing happens for anything regarding major system changes, like user settings etc.

I dunno how to fix this, I cannot even System Restore, which is what i usually do and work all the time. I asked my sister if she did anything to it recently, she is very obsessive over low space on the computer, and usually goes and deletes files from the temp folders and unused programs in C:\. She told me she deleted some "nero showtime files that were in the C drive. and I thought "What nero showtime files?". I checked withing the C drive, and I noticed that ntuser files were under the file type "NeroShowTime.Files8.dat" didnt necessarily mean they were Nero files? So I'm putting two and two together she basically deleted a few system files.

Sorry for this long story, but was hoping more information might shed some light on this problem and hopefully fix this? I noticed others have had this error pop up, but they have for completely different reasons like Nvidia firewall? or Java script problem? Surely this cannot be the same.

BTW I did full system scan twice and nothing showed up I use Symantec Antivirus.

See More: Runtime Error, Line : 0, Object Expected

Report •

July 24, 2009 at 03:39:18
Umar1 , suspect you're on the right path and need the file. Sounds like 'tinkeritis' to me. Have a look @:
for explanation/download source.
Ed in Texas.

Report •
Related Solutions

Ask Question