Right click won't open folders in Start Menu

Dell / Inspiron 531s
May 12, 2009 at 05:03:22
Specs: Microsoft Windows XP Professional, 2.812 GHz / 3518 MB

I just had a problem occur after I used TweakUI. Nothing I did in TweakUI should have caused it.

Here's the problem:

When I right-click on a folder in the Start Menu (All Programs), Open and Explore don't work in the context menu anymore. I select Open and absolutely nothing happens. The other 4 items (delete, rename, sort, properties) DO work.

I'd like to know how to fix this. I installed the program ShellExView, but I'm not certain if I should use that, and if so, what I should change.

I'm using Windows XP SP3.

Any help would be appreciated.


See More: Right click wont open folders in Start Menu

Report •

May 12, 2009 at 05:39:56
Try this
Click Start, then RUN, then type
regsvr32 /i shell32
Note the space after the '2', and after the 'i'

Report •

May 12, 2009 at 05:52:32
Thanks, but I just tried it and it didn't work. I copied and pasted the command and it verified that it modified the registry, but no cigar.

Hopefully, I can get this fixed.

Report •

May 12, 2009 at 05:56:18
Did you Restart the computer after running the command.???? I think you have to do that, for changes in the Registry to take effect.

Report •

Related Solutions

May 12, 2009 at 06:24:02
Yes, I did restart it, but Open still doesn't work. That would have been a great quick fix, if it had worked.

Also, now that I think about it, I searched the threads here yesterday before I posted my question today and I believe someone had posted that registry fix. I tried it yesterday and it didn't work. I think it was the same one.

Is there some sort of tool I can use to get info about my system, that I can post here that will help solve my problem?


Report •

May 12, 2009 at 06:38:36
That command I gave fixes a problem where if you double click a folder or drive, then Search Companion opens.

This page has alot of XP fixes
Some require the download of a VBS, or Regedits file.
So, read at the top of that page--
"To use the Regedits" or "To use the VBS files"
You may have to do CTRL + F to help search the list.

Most Virus and Spyware scans are likely to work better in Windows Safe-Mode.

Also, Try System File Checker:
Do Start, then RUN, then type:

sfc /scannow

note space between the c and /
Have XP CD in your drive.
Information about SFC

Report •

May 12, 2009 at 06:43:24
Dom Fontana, Exactly what did you change when you used Tweak UI? Did you try undoing the change or changes? Have you considered doing a System Restore to the closest date prior to the start of this problem?.


Report •

May 12, 2009 at 07:49:41
Chuck 2.

I ran the System File Checker and it copied a bunch of dll files, but the problem is still there.

Then I went to Kelly's Korner, as you suggested, and I searched and found this:

Restore Right Click .inf/Install

That was the closest thing I could find. There was nothing I found that said "Open doesn't work with right-click."

I downloaded the patch, but wanted to ask you first before I used it.

Report •

May 12, 2009 at 08:02:12
Tufenuf (Fabulous Thunderbirds),

In Tweak UI, I unchecked a bunch of programs that are allowed to appear in the Most Frequently Used Programs section of the Start menu. No, I didn't undo the changes.

I also didn't do a Sytem Restore yet because after creating my last System Restore point, I installed a bunch of programs. And believe it or not, I was about to create a new System Restore Point yesterday, when this problem occurred.

I didn't want to do a System Restore right now because then I'll lose all the configuration and registry settings from all the new programs I installed.

I figured getting the Open command to work again was a quick fix, but I guess not.

Report •

May 12, 2009 at 08:36:21
Here's some more information.

The right-click Open command works everywhere else, It opens folders on the desktop and it opens (runs) programs in the Start menu. It just won't open folders in the Start Menu anymore.

Report •

May 12, 2009 at 09:00:30
Dom Fontana, It wouldn't hurt to try undoing those changes you made in Tweak UI, restart your computer and see what happens.


Report •

May 12, 2009 at 09:35:29

I undid all the changes from TweakUI, rebooted, and still have the problem. I also ran a virus check and anti-malware scan, and it turned up nothing.

I can't think of what else to do to fix it.

Report •

May 12, 2009 at 09:40:03
@ fontana

In response to your # 7, I do not know.

At Kelly's Korner, I think what you want is Line 215 in the right hand column. There are TWO seperate Reg files there.

Report •

May 12, 2009 at 09:42:58
Try the "Folder Association Fix" at the link below. The page has instructions for using it.



Report •

May 13, 2009 at 03:35:45
Chuck 2 and Tufenuf,

I tried both of your suggestions and neither of them worked. Downloaded the fixes, applied one, rebooted, then applied the 2nd one, rebooted, and the problem is still there.

Anything else you can think of?

Report •

May 15, 2009 at 05:28:30
I figured out how to fix the problem myself. For the benefit of others, here's how to fix it.

Download the free program ShellExView from here:

It displays and allows you to edit all the entries in the context menu handler, which is the right-click menu.

Usually the problem is with a non-Microsoft entry, so sort the list by company. Then look at all the non-Microsoft entries and disable them one at a time and see if it fixes the problem. When you find the one that fixes the problem, then keep it disabled.

I found it right away. There was an entry for Power Iso and that was the last program I had installed. So, I disabled its entry and Eureka, the right-click Open command now works on the folders in the Start Menu (All Programs) again.

Report •

May 15, 2009 at 06:11:02
Dom Fontana, Glad to see that you fixed the problem and Thanks for posting how you fixed it as it will benefit others who may run into the same problem. I wish I would have thought of that as the link below states this.

"5. When you right-click a folder in the Start Menu and choose Open or Explore, nothing may happen. (Whereas, it works fine in Windows Explorer.) "

Right-click is slow or weird behavior caused by context menu handlers.



Report •

May 15, 2009 at 07:28:54
Hey, Tuf.

Glad I could do a little to try to help. You find something that works, you pass it on.

The PC always seems to have these little niggling things that pop up. I liked my old Atari 800 and Amiga 2500 computers better, but they're gone now, so most of us are using PCs.

This is a great site, so I'll come around again from time to time.

And thanks again for your time and help.

Report •

June 7, 2009 at 07:43:12
Dear Dom Fontana, can't thank you enough for your method.
Worked great =)

I downloaded shellexview program and i got it strait away as

Mine was caused by magic iso, strage, yours was poweriso.

Anyway,thanks for writing up the solution as many would have
said: "thanks, i fixed it, bye"

I registered an account to tell you this.

Yay for right click, explore and Yay for you !!!!

Report •

June 7, 2009 at 08:11:36
Hi, darkplanner.

I'm glad you fixed it. Thank you for the kind words. That was very nice of you to sign up just to tell me that. I apprecate it.

One other thing. I made a slight mistake. It turns out the program that was causing the problem for me was also MagicISO, just like you. I don't know why I put PoweISO. I can't edit my message anymore, but maybe the Sysop can.

Anyway, I'm glad we both got it fixed.

Happy right-clicking.

Report •

June 7, 2009 at 08:18:47

Are you able to edit my message above where I described the fix, to say that the culprit was MagicISO and not PowerISO?

If not, for the benefit of everyone else, please note that it's MagicISO (not PowerISO) that causes the problem with the right-click Open command.

Sorry for any confusion.

Report •

June 7, 2009 at 09:04:09
Dom Fontana, I can't edit your post but you don't need to worry about it as if others read the entire thread they'll see the correction. Thanks again for posting back the fix.


Report •

June 7, 2009 at 09:45:48
Okay, great.

Report •

June 17, 2009 at 11:55:03
I had the same problem and fixed it by going to the start menu properties, choose customize, then advanced... and re-checked off the option for "drag and drop" for the start menu and whalah! it works again

Report •

June 17, 2009 at 18:38:25

I had checked that first, but "drag and drop" was already selected for me. I had heard that fixes it in some instances. I'm glad it worked for you

Report •

Ask Question