Restoring Network Connections error

Hewlett-packard / Elitebook 6930p
March 12, 2009 at 22:37:28
Specs: Windows XP Pro 32-bit SP3, C2D P8600/4GB Ram
Hello, I just recently started getting terrible hangs at the "Loading your personal settings" prompt at logon, making my computer go from ~30 boot to ~5-6 minutes. So I went into a troubleshooting/research frenzy, and I got it down to this:

Enabled verbose status messages for logon/logoff, and the hang occurs on "Restoring Network Connections". The hang is caused by an invisible error message that I can close if I alt+tab and hit enter/spacebar to dismiss, which ends the 'hanging'.

I set up a little Windows Workgroup to share the external hard drive that's plugged into my desktop with this laptop, through mapping it as a network drive. I have been using this setup for a long time with no problems.

I am not really interested in 'reformatting', 'repairing', 'restoring', etc. What I really want to accomplish is to figure out what is causing this error and resolve that cause. I have a clean disk image that I could resore but I would much rather fix this problem.

I scoured the internet looking for solutions or explanations but have only been able to find info pertaining to w2k servers and win95 machines and such.

This MS KB article 816873 explains pretty much exactly what I am experiencing, except my networked hard drive IS acessible and online, and the share ISN'T available offline (I have tried this both enabled and disabled).

A much more detailed account of the steps and research I have done can be found in this thread:

Help me troubleshoot 'Loading settings' hang on startup

If you need any more info, please let me know. I have done everything I know how to do at this point...I really need help on this one! It's over my head.

Thanks in advance!

See More: Restoring Network Connections error

Report •

March 13, 2009 at 00:55:18
Why don't you try removing the share from your notebook and verify that's actually the cause of the error and not something else, like a corrupt DLL that's causing that error message.

If so, then try recreating the share and see if it happens again - maybe that would clear up any errors in the process.

Report •

March 13, 2009 at 01:02:23
Forgot to mention, I already did that :P thanks for the suggestion though. Disabling the share solves the problem...well, it doesn't "solve" anything, but it prevents the problem from coming up. I disconnected the share and reconnected multiple times, from both ends. I think I mentioned it on the other thread.

Report •

March 13, 2009 at 01:56:15
Any difference in using IP addresses instead of Network Names? ie: \\\F instead of \\Joe's Computer\F

Report •

Related Solutions

March 13, 2009 at 03:41:27
I replaced the computer name with \\ip\share but that didn't help =/

I'm thinking in another direction now...try this on for size:

Since the day I got this computer (like 2 weeks ago) it's had strange wireless connectivity issues...sometimes it will say it's connected and I can ping to my hearts delight, but I get no pages up and if I try sending larger packets than ~35 bytes I get time outs. For instance, with trying to find the largest MTU packet for optimization purposes (I am usine PPoE so I already have it set at 1492) with TCP Optimizer I will send 40 bytes, then 750...and the 750 will time out. If I reset my connection i.e. tap my little wireless button off and on, it will reconnect within seconds and the connection will be stable. I am starting to think, more and more, that this has something to do with it. I was going to troubleshoot it over in the DSLreports forum and other such forums at a later date after settling this issue, but when I noticed that my connection had to be reset first thing on one of my boots, I had the thought that maybe it's unable to connect to the share for this reason (whatever is causing this issue). 2 birds with one stone there, or rather, I would only have 1 bird if I had gotten rid of that issue when it first arose.

I am thinking this should have been started over in the network forum :P

Report •

March 13, 2009 at 04:41:34

I disabled the wireless and plugged directly into my gateway/router via ethernet, result: the 'hang' is very short, possibly in the realm of a normal startup speed. This means that I can say definitively that this has something to do with wireless protocol or hardware. Right? lol. When I started up with wireless AND ethernet enabled, the hang still happened and I had to alt+tab-enter to continure login. Only when I had only ethernet did the hang seem to be alleviated.

Just thought I'd throw this new info into the ring. I thought there was nothing left I could do but I was wrong!

Report •

March 13, 2009 at 16:15:14
Great idea, at least you've narrowed it down to wireless. Have you tried changing your channels in your router to see if you get better reception? ie: Try 1, 2, 10, or 11 instead of the default 6.

Report •

March 13, 2009 at 20:28:06
Excellent point, however, I did try that, as well as changing power settings, and that didn't change anything =/ I suppose that this could be a hardware-related issue (my wireless card?) but it certainly seems strange. For instance, I have had this drive mapped for weeks and even taking the laptop to a different network (i.e. a hotel) hasn't caused a problem, except if I try to access the network share (in which case, it tells me the network drive could not be found). This fairly recent problem has me very puzzled, although I am by no means an expert.

I am on the hotel network now, and booting up my computer here also caused the error message.

Report •

March 15, 2009 at 20:16:11
bump...any takers?


Report •

Ask Question