Restore registry to slave OS/HDD

February 14, 2009 at 07:24:18
Specs: Windows XP/SP3, Quad E6600/2GB
Hi all, just joined and hope I could find some remedy here that I have not been able to after wrecking out my brain for the passing day. I’ll try to be as detail and clear as I can, any help would be greatly appreciated so thank you in advance.

I have two machines, for reference I’ll call them Dell (main, everything), IBM (slave, testing software, risky stuff), former running XP/SP3, latter XP/SP2.

Last night I was doing some registry clean up on Dell using jv16 1.1b (registry cleaner, best ever used imo and never had a problem, aside those caused by myself like this time around), I highlighted a group of entries by mistake and proceed to hit delete, it took an awfully long time to process and system stalled and I waited for a long time, afterwards everything was reset back to default status appearance wise as if I just did a fresh install of windows, I tried to restore the delete registry but windows didn’t progress any further from that point on so I forced power off.

Upon restarting after the windows progress bar loaded I was confronted with a blank screen, all attempt to access safe mode failed, same as last working status. I pulled out the HDD and inserted as a slave on IBM and found the backup of the registry file that was removed, the mistake was in fact 9.8mb of registry information, A LOT!

I’m looking at good and bad news here, good news is that I know exactly what needs to be done, if I can restore the registry file that would solve all the problem, there’s no other problems that I need to narrow down to. Bad news however is that I have no idea how to restore backup registry files to a slave HDD.

I have a image of IBM so I can restore that anytime in case something goes wrong. I thought of a few ideas and here’s how they went:

Solution A:
Found some information that allowed me to start regedit on IBM with DELL HDD as slave and “Import Hive”, that allows me to view and edit the registry of the slave HDD, which is what I want to do, yet there’s no option to import backup.reg to the slave drive, I can manually edit each entry yes, but there’s no way I can do that for 9.8mb of text. So that hit a brick wall, does anyone know of any way to import a whole file to slave drive with ‘working’ OS on it?

Solution B or at least the plan was:
1) Copy Dell’s damaged “%system32%\config” to IBM’s 2nd partition Z:\config
2) Copy 9.8mb registry backup to Z:\backup.reg
3) Boot to command prompt on IBM, replace IBM’s with Dell’s, import registry.
4) Once complete before booting into windows copy the new “%system32\config” to Z:\configfix or to Dell’s HDD replacing the damaged files and theoretically that’ll fix the problem, it’s by no mean elegant but it should get the job done.
5) Restore image file for IBM.

The problem with that is I have no idea how to get to true command prompt (like how windows 98’s was not the ones in xp safe mode as that locks system files so I can’t replace them). Found some information with the recovery console when booting with XP CD but it didn’t come up as an option, only thing there was install/exit…

Solution C:
Run Ubuntu Live and find a registry editor which allows one to edit registry of windows partition, but so far I’ve not found anything and also have no experience with Ubuntu/Linux at all.

I’ve exhausted all my options so far and without any luck, an anyone think of anything to help? Reinstallation of windows is not an option due to various reasons, just trying to think of ways to restore this registry file.


See More: Restore registry to slave OS/HDD

Report •

February 14, 2009 at 07:30:24
Did you try to use system restore to a date prior to your deleting?

Silence is golden but duct tape is silver

Report •

February 14, 2009 at 07:46:00
Googling for "using registry restore when WinXP won't boot" yields several hits. This one looks promising.


I think you may need to replace the drive in the original computer to perform that operation. Not sure about that.

BTW, JV Powertools was great in its day. When it went commercial I used the last freeware version for some time after that. I finally came to the realization that cleaners need frequent updating to work right.

Don't get caught up in how much stuff is tagged for removal. All you need to worry about is if your system is working correctly.

Try CCleaner. The cleaner module is excellent and the registry module is safe.

Report •

February 14, 2009 at 07:46:08
@ SysLock
You mean F8 » System Restore? System halted and black screen and had to force power off...

Report •

Related Solutions

February 14, 2009 at 07:49:37
@ OtheHill
Yes tried that as well but the part where I am supposedly to be confronted by this "repair" option I do not, I only get install/exit/format options o_O

I put the Dell's HDD back into Dell and tried with 2 CDs, first the original xp, and second the one with SP3 slip streamed, both yield same results.

Yes I agree, that's why I've always been using v1.1b until now, never ever had any problems tbh, except this one time.

Report •

February 14, 2009 at 11:19:56
I believe if you proceed to install you will get to the point where a screen will say it found a previous installation of WinXP and will then give you three options. One of them will be to repair the existing WinXP installation.

If this IS a Dell or OEM version of WinXP then maybe someone else can verify what I think will happen.

Report •

February 14, 2009 at 19:21:23
My fault, I read that like it was booting up and you could get to the system restore utility from the start>accessories menu. In your case, you can use this procedure to restore the hives and then pull your good hives down from their saved point.

Silence is golden but duct tape is silver

Report •

Ask Question