Repeated problem upgrading RealPlayer SP

February 9, 2011 at 15:14:26
Specs: Windows XP Pro SP3, Pentium M 1.4GHz/1.23Gb
Every time I try to update my RealPlayer from v12.0.0.879 to the latest version, the installation reaches about 83%, then disappears. No error message, but my existing installation of RealPlayer has disappeared from Add and Remove Programs and the shortcut to it (which is in a non-standard position in the Program Menu) is now a dead link. I can restore my system to its previous condition from a Ghost image, then if I try updating it again the same thing happens. Normally, I update my system every month after "patch Tuesday" by running Secunia OSI after doing the Microsoft Update and updating anything it tells me is out of date. Then I delete temporary files, clean up the registry, remove anything unnecessary that has been added to my Startup programs and then create a new Ghost image. But the last 2 months I have had to avoid updating RealPlayer for the reasons outlined above. I've even tried uninstalling RealPlayer, deleting the Real folder from Program Files, removing all trace of Real from the registry, cleaning/fixing the registry using Registry Mechanic and TuneUp Utilities and then installing the new version of RealPlayer from scratch - same result. Any ideas?

See More: Repeated problem upgrading RealPlayer SP

Report •

February 9, 2011 at 19:36:15
See response 3 regarding disabling resident modules of anti-malware software

See response 14 if you have Panda Global Protection

Report •

February 15, 2011 at 03:40:05
Good advice - thank you. As a computer professional, I'm a bit ashamed that I didn't think of that myself.

Report •

February 15, 2011 at 07:13:23
So doing that solved the problem ?
Unfortunately, when a resident module is causing a problem you usually get no indication at all of what the problem is.

Report •

Related Solutions

February 16, 2011 at 06:16:30
Whoops! I just realized that I tried it on the wrong computer. The one giving the problem was my wife's laptop which has virus protection from Microsoft Security Essentials. The one I tried it on (my desktop with AVG) never gave a problem anyway. I just tried it on my wife's laptop, disabled the resident part of MSE and tried the RealPlayer upgrade and it failed as before. So... currently restoring from Ghost image so at least she has a working RealPlayer, even if it's out of date. Any other ideas? Much appreciate your help.

Report •

February 16, 2011 at 12:52:06
Un-install anything left behind after a failed installation BEFORE you disable resident the module(s) and try to install it again. In fact, it's probably best to disable the resident module(s) BEFORE you do both of those things.
E.g. If there is nothing in Add or Remove Programs to remove, you MAY need to use CCleaner or similar to remove Registry entries for the failed installation, and you may need to manually delete left behind files. If the master *.inf file for the installation has been installed examining that for which file names and registry entries it installed can be valuable - e.g. search for *. inf files in C:\Windows\inf that have the name RealPlayer or similar in them, if there is more than one, look at the dates, or look for the *.inf in Program Files/name of program or software maker.

In the previous restore point in which the older version works, it SHOULD work fine if you update RealPlayer AFTER you have disabled the resident module(s).

I usually have AVG 2011 installed on my computers and I usually install it on other computers when I'm working on them. It's Resident Shields does not seem to interfere with the installation of most software when I have forgotten to disable it, but it DOES interfere with the installation of some of them ! E.g. Sound adapter software.
I NEVER have had a problem that I can recall with installing software when I HAVE remembered to disable the Resident Shield.

One of the most frequent reasons SP3 updates fail to install, or fail to install properly, is because the person did not disable the resident module(s) of anti-malware software.

Report •

February 16, 2011 at 14:00:14
There is no residue from a failed installation. Here's the full history: The last fully successful monthly update was immediately after the November 2010 patch Tuesday and when it was complete I created a Ghost image of the boot partition. I didn't get round to doing an update in December, but after January's patch Tuesday I did. I started by restoring November's Ghost image (thereby removing any malware infections my wife might have picked up in the last 2 months), I then did a Microsoft Update, bringing the OS and MSOffice completely up to date. Then I ran Secunia OSI, which told me that various other software on the system was out of date, including Java, Adobe Flash Player and RealPlayer. I updated everything mentioned but when I got to RealPlayer the installation failed as already described. After restoring the November image and retrying the update various times, including uninstalling the working RealPlayer using Add and Remove Programs, getting rid of all residual traces both on the hard drive and in the registry and then trying to re-install it from scratch, I gave up and accepted defeat. I then restored the November Ghost image again, updated everything EXCEPT RealPlayer and created a new Ghost image. After February's patch Tuesday, I tried to restore from January's image but it was corrupt. Once more, I restored from November's image, updated everything EXCEPT RealPlayer and created a new image. Yesterday, on your advice, I de-activated MSE and then tried to update RealPlayer and when that failed I restored the new February image. So you can see that I never attempted an update to a system where an update had already failed. In every case, including the most recent attempt with a de-activated AV program, I was trying to update a clean system, restored from a good Ghost image.

Report •

February 16, 2011 at 16:24:51
Are you sure you disabled the right thing?
Scroll down - it shows where you can enable / disable Real time protection:

Are you SURE you disabled the resident module(s) for ALL anti-malware software ?
If you ARE sure, there are some third party software firewalls that have a resident module that causes the same installation problem - do you have any such program installed ?

Spybot free and paid, AdAware free and paid, Avast! free and paid all have at least one resident module.
Windows Defender has a resident module - installing Microsoft Security Essentials automatically disables that when it's installed if Windows Defender is present, at least it does in Vista and Windows 7.

Windows Defender is built into Vista and Windows 7 and it can't be un-installed, but it can be disabled from running in Windows Defender's own settings.

Malwarebytes free has no resident module (it does but not one that causes this problem) but it's paid version does and that may cause this problem.

If that doesn't help I have no idea what the problem is.You could try searching on RealPlayer's web site, or searching on the web, for possible solutions.

Report •

February 16, 2011 at 19:29:25
Of course, you could back up any personal files in RealPlayer itself that you do not want to lose, Un-install it, install the latest version of RealPlayer, copy your saved files back to RealPlayer

Report •

Ask Question