Repair XP yet breaks installing 3.1 installer

Linksys Wrt54g wireless router
February 26, 2010 at 13:54:27
Specs: XP Pro srv pk 2, 600Mhz
Im fixing someones pc. It wouldnt boot, so I did a repair install. All seems fine until I have to install the first update which is the Microsoft WIndows Installer 3.1 (WindowsInstaller-KB893803-v2-x86). Such things as System restore fails to work, add/remove (appwiz.cpl) fails to load. System restore keeps saying something about drive D not being monitored which doesnt matter as I made a system restore point with it off. I double click add/remove programs and nothing happens.

Ive scanned for malware, adware and viruses using avira, spybot and malwarebytes. It found sum, I removed them and did a new repair. No change, would always break when install the 3.1 Installer. Tried both the automatic updates, and downloading the file from Microsoft.

Running sfc doesnt make a difference.

Any help appreciated.


See More: Repair XP yet breaks installing 3.1 installer

February 26, 2010 at 14:13:10
Backup the data, format and reinstall.


Report •

March 1, 2010 at 14:23:42
Backup the data, format and reinstall.


Was going to be the last resort. But I finally fixed it without wiping the drive.

I did a repair install, then tried installing Service Pack 3. Got an Access is Denied at the end. So I followed the instructions to reset the permissions in the registry here:

After it completed, I tried SP3 again, this time it installed!! Didnt need to install the 3.1 installer as was included with SP3.

System restore and add/remove works now.


Report •
Related Solutions

Ask Question