Remote Desktop is enabled but cannot remote into the system.

Microsoft Microsoft windows remote deskt...
April 16, 2013 at 12:44:02
Specs: Windows XP/SP3, i5 2400 3.1Ghz/4G
The situation is I am attempting to remote desktop into a Windows XP machine after pushing the below registry entry to it via psexec and batch file. All services for RDP to function correctly are enabled and the option: "Allow connections from computers running any version of Remote Desktop (less secure)" is checked. I attempted to remotely connect via both the IP and host name of the machine and cannot do so. After logging into the machine locally and unchecking (applying) then re-checking (applying) the above option, I am now able to successfully remote into the machine. Has anyone encountered this problem before and have a fix?

REG ADD "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server" /v "fDenyTSConnections" /d 0 /t REG_DWORD /f

See More: Remote Desktop is enabled but cannot remote into the system.

Report •

April 16, 2013 at 12:55:44
If I read your post correctly it seems you have already fixed the problem yourself.

It's by no means unusual to have to "toggle" an option or setting in Windows to make it "stick". It's just one of Windows' many foibles which I've encountered myself in some other settings.

Report •

April 16, 2013 at 15:02:50
Have you checked, whether the registry key has been set correctly, when executing psexec and a batch file?

Report •

April 17, 2013 at 05:56:22
Hey guys, actually no I have not fixed the problem myself and am looking for a solution. When I run the command manually it works just fine. And I mean the radial button is getting selected and all looks fine. But for some reason I have to deselect and reselect the listed option before it am able to remotely access the machine. Otherwise I cannot.
I did just realize though that I am applying a bunch of MS updates and patches after I enable the radial button. So perhaps one of the updates is breaking the setting so I have moved the REG command to the end of my script after all of the patches get installed and the system reboots. So I may have solved it, we'll see.

Report •
Related Solutions

Ask Question