Re-installing Java

Dell / XPS 630I
January 27, 2009 at 09:40:23
Specs: Windows XP, Intel Core 2 Duo

My computer at home was running Sun Java 5 Runtime 6. Attempted to update to 6 Runtime 11. Website install from gave me a message saying that there was a problem encountered when installing Java. Some of the solutions provided were:
1. Make sure to activate the ActiveX Control on the Information bar.
2. Download the Offline version and install.

No error codes of any kind was provided. Running the offline update for some reason had the installation shield pop up briefly only to disappear and nothing happened. Running the update from Java applet in Control Panel gave me a Java (TM) installation error message.

Uninstalling the Java 5 Runtime 6 using Add/Remove Program does not seem to help the situation either. System Restore will only make the Java Applet in Control Panel not do anything when clicked on, a residual Java 5 Runtime 6 entry in Add/Remove programs, any web pages that contain Java is automatically closed when clicked on.

Under recommendation of a friend, removed traces of Java using JavaRa. The pages that had Java Applets on do not automatically close any longer when clicked on. Just have red X, as if Java has not been installed. However, I still cannot get Java 6 Runtime 11 to install. Windows Cleanup Utility doesn't want to install (does not run when executed), but the installation program ran when I logged in with another account that also have administrator previleges. But I can only see it (in the list of programs and list of Add/Remove programs) when I log in as that account

The only thing I have not tried.
1. Attempt to find Java 5 Runtime 6 files out there.
2. There are still some residual Java installation in there that were not cleaned out. ActiveX Control perhaps?
3. Have not tried to see if Java will install under the other account. If it will run, could it mean that my default Windows profile may have become corrupt?
4. Should I give MS Java VM a try instead of continuing to deal with Sun Java?

Thank you and any advise is truly appreicated.

See More: Re-installing Java

Report •

January 27, 2009 at 10:35:57
- Go in to Tools > internet options > Advanced Tab > Make sure Sun Java is checked.

-Uninstall Java, go into the registry and delete all instances of Sun Java ( if your comfortable) then re-install Sun Java or try MS Java. Keep in mind that some sites may require you use Sun Java.

-It could indeed be a corrupted profile. Did you verif that the profile your logged in under has admin rights?

Report •

January 27, 2009 at 12:35:21
Thanks for the response.

The profile I am using was the one I started using since day one, and does have admin previleges, since I use it to perform installations and such. I could probably go home and just create another profile with admin rights to see if that would allow me to install.

Report •

January 28, 2009 at 09:07:18
Well, an update on the situation. I have Sun Java back on my home computer again. But it was actually more related to what BLAQ OUT's suggestion.

I went ahead and created another User with Computer Admin rights. Logged in and immediately tried Java installation, same thing. Then I downloaded the Offline installation from that profile and ran, same thing with my default account, the executable just pops up and disappeared. So I then right clicked on executable and chose Run As Administrator. Next thing I know, Sun Java's executable popped up and Java 6 RT 11 is on my computer.

So since this worked, I started wondering, I am not using a server at home (default Workgroup setting) and under User settings in Control Panel and Local Policy, my profile was in the Administrator group. Have my account and the newly created test account suddenly became a "Power User" (Under Domain setting) by a Group Policy that supercedes the Local Policy where only the computer's Administrator can install software? My suspicion was further noted when my Logitech Mouseware application in the Taskbar constantly said there is a new update for the software even after the download is supposedly installed. Downloading the software/driver from the Logitech site and running that under my default account showed that it cannot complete the process, where if I ran it "As Administrator" then it will install. Further more, I ran Scandisk, and I can't even get to Phase 3 before it told me that it cannot complete the operation.

Having said that, I seem to recall a couple of weeks back having came across some XP Update on Microsoft Update, and after confirming with a friend using Vista where whenever he had to install a program, he had to Run as Administrator, I went to look around my update history on Microsoft Update, and the only thing that looks familiar is this: Group Policy Preference Client Side Extensions for Windows XP (KB943729) installed a couple of weeks back (I think it was listed as Optional).

After uninstalling it, I was able to run Scandisk with my own account. Have not tried to see if I am able to install any applications yet though. If this was really the cause, I will be darned. Perhaps my default profile wasn't really corrupted and I didn't need to remove Java in the first place, it was just that I didn't have sufficient rights to install. But having said that, if every time I needed to update a software, run a maintenance function (like Scandisk), uninstall a program, I needed to involve my Admin account, to me it is kind of a hassle. But I suppose that is why it was listed as optional.

According to the friend who uses Vista, that's what it is like in Vista. I understand it's a security measure, but that just kind of took me by surprise. So long story short, I got Java back on my PC, and in the process, stumbled onto something else.

Report •

Related Solutions

Ask Question