Reinstall Windows XP SP2 asms error

Dell / Dimension 4700...
January 4, 2009 at 14:33:25
Specs: Windows XP, Intel Pentium 4 Processor 520 and .99 Gig of RAM
I was having problems consistently with Windows, so I decided to reinstall Windows XP SP2 from the reinstallation CD that Dell sent with my desktop. The install was going fine until I got an asms error which asked me to define the pathway for the file and in the pathway already was the correct path. However, the install will not complete. I have tried the microsoft fix which requires going to regedit.exe and deleting the upper and lower filters and that doesn't work. I tried to reboot in safe mode, and it won't let me. I'm stuck in this install loop of rebooting and getting the asms error. I don't know what to do next.

See More: Reinstall Windows XP SP2 asms error

Report •

January 4, 2009 at 15:01:22
You can't do a regedit of an install so you can't be doing the install correctly.

Normally you boot the cd via the bios and install will start.

Sounds like you are launching install from within your present installed version of xp which is the incorrect way of doing it.

'tis the season to be of good cheer. Wishing one and all happy times with family and friends.

Report •

January 4, 2009 at 16:19:54
You are right, my BIOS got changed to boot from the hard drive. It appears my computer is not recognizing my CD ROM drive. After the Windows CD is inserted, it spins once and then that's it. Is there a way to get Windows to recognize that drive again so I can get it to book from the CD? Thanks so much for the help.

Report •

January 4, 2009 at 22:29:16
If it IS an actual Recovery CD you must boot the computer with it!!

The bios will not recognize a bootable CD in a CD or DVD drive unless it's listed in the boot order before all hard drives.
Go into the bios Setup and change the boot order so the CD drive is listed before all hard drives - the CD drive doesn't have to be listed first - e.g. floppy drive or removable drive can be listed first.

If your computer has two optical (CD or DVD) drives, some bioses will only boot a bootable CD if it's in the first one listed in the bios Setup.
Try the bootable CD in the other drive in that case.

You should see "press any key to boot from the CD" or similar while booting if the bios is recognizing a bootable CD in a CD or DVD drive - when you see that, press any key, or the specific key, to boot from the CD, while the message is still on the screen.
If the computer reboots while installing the software, you will still see "press any key to boot from the CD" or similar while booting each time it boots - DO NOT press any key, or the specific key, when the software installation reboots the computer, otherwise the software installation will start from the begining again.

It's a good idea to make sure the bootable CD is clean, and to use a laser lens cleaning CD in the drive, before you do something important such as re-installing the original software or Windows.

Report •

Related Solutions

January 6, 2009 at 09:16:45
I tried switching out my DVD drive with my CD Rom drive with no luck. Any other suggestions on how to get this problem fixed?

Report •

January 8, 2009 at 14:31:39
You have not provided enough information for us to be able to troubleshoot your problem(s).
Supply the details of the things you tried and what the result was!!!

Did you make sure the boot order in your bios Setup is set correctly to boot from a bootable CD in an optical drive?
See the second and third paragraphs of response 3.

Were you able to boot the CD?

Have you tried other CDs that you know are bootable to see if you get the prompt "Press any key to boot from the CD" or similar while booting??

Are you SURE the CD you are trying to use is a Recovery CD, with which you can reload the orginal contents of C, along with the intact and un-altered original data contents of the second partition on the original hard drive??
Brand name system computers these days usually DO NOT come with a Recovery CD - you're supposed to make that, and/or a Recovery CD set, yourself by using a Dell supplied program, while Windows is working well enough to use the program(s) - but they may come with a brand name CD with drivers, etc. on it.

I searched on eBay for Dimension 4700 recovery CD, and Dimension 4700 CD, and so far all I have found is this, a disk with drivers etc. on it:
Is the CD you are trying to boot with the same or similar to this one?
If it is, you cannot restore your system with it, and it's probably NOT bootable!

Is the bios Setup recognizing the optical drive you have the CD in?

Are you getting any error messages?

According to "hits" on the web, your Dimension 4700 could have originally come with XP Home, XP MCE 2002, or XP Pro.
I assume you're still using the operating system it came with, and you have not loaded Windows from a regular CD (or DVD) - is that correct?

Dell Dimension 4700 Series Service Manual

Amongst other things including onboard video and a PCIE X16 slot, your motherboard has a single IDE header, and two SATA headers.

According to "hits" on the web, a Dimension 4700 often comes with two optical (CD or DVD) drives as well as one hard drive. Therefore - at least one of them must be a SATA drive.

Is your hard drive IDE or SATA?
Do you have two optical drives installed?
Is the optical drive, or are the optical drives, IDE or SATA?
If you don't know, or aren't sure, tell us the model numbers of your hard and optical drives that are listed in Device Manager.

Did the computer come with, or have you installed, a PCI-E video card?

If it didn't come with a PCI-E video card and you installed one, you often have to upgrade the power supply as well - otherwise you are likely to have problems and the power supply may fail because it is being overloaded frequently - brand name systems often come with a minimal capacity power supply that can't handle video cards with recent video chipsets.

Report •

January 8, 2009 at 16:35:40
Thanks for all the help. I really do appreciate all your efforts. I ended up formatting the drive back to the original way it was shipped to me. Based on doing that and running diagnostics, it appears I must have a bad CD Rom drive because it fails the diagnostics and it won't read any media inserted in the drive.


Report •

Ask Question