Click here for important information about

PS/2 Mouse got wet & stopped working

January 2, 2010 at 22:58:00
Specs: Windows XP
Hi, mouse got wet, stopped, no other mouse plugged into the back of the computer will work.
Standard PS2 wired mouse (mice)
HP SR1650 Athlon 3500+, Windows XP, SP III
By getting the mouse itself wet (dunked!), could I have fried the input which the mouse plugs into?

BTW, keep in mind, my "thanx" will be slow in coming....after all, I don't have a usable mouse, and am having trouble navigating with the tab control...


Oh...feel free to respond to: it may be easier for me to retrieve it in the meantime...Thanx all!

edited by moderator: 1. Thread moved from Windows 7 Forum. 2. email addy deleted

See More: PS/2 Mouse got wet & stopped working

January 2, 2010 at 23:41:44
"HP SR1650 Athlon 3500+, Windows XP, SP III"

This is the Windows 7 forum

If you have XP try Start > Run > devmgmt.msc > ok
Expand your USB devices and then right click on them and remove them
Then Restart

Windows will automatically re-install the USB devices again

Or try another USB port

Report •

January 3, 2010 at 01:42:38
Thanx...turns out I just had to reboot (after several hours, and trying 3 additional mice, this is all it was....a windows "glitch, perhaps)

BTW, how was I going to "right click" on my expanded USB devices....when the mouse wasn't working? D'OH!

Nonetheless, I appreciate the input.


Report •

January 3, 2010 at 04:08:12
Well I knew the keyboard commands
Space bar to expand
Alt for menu
Arrows to change fields
Then select remove

Probably should have mentioned that huh?

(still don't know if its XP or 7 yet though)
Oh looks as though Mods moved the thread
Lucky they helped you here

Report •

Related Solutions

January 3, 2010 at 06:21:23
I'm curious as to how the mouse got "dunked." And into what?


Report •

January 3, 2010 at 10:39:12
Thanx, kimsland and Jennifer...

kims..."XP" is mentioned there in the first line of my thread, so no, not Win 7; yup, nice of the Mods to move me (although by then I had solved the problem)...perhaps they're bein' nice because I'm a first-timer here...or maybe they're ALWAYS nice! ;>)
While trying to figure out what had happened and how to fix, I had used the TAB thing a bit trying to send an email, but it wouldn't get me over to the "send" row of selections...quite frustrating.

Jenn, to answer your question - pure frustration: it was late, I had just finished a lengthy financial lesson (stock/options P&F charts, etc) , I took the quiz...and got 1 out of 5 correct....ONE OUT OF FIVE!!! (I'm usually a bit sharper than that...)

So, in a little "hissy" fit (which I never have), I threw my mouse down on the desk...and it bounced right into my big, honkin' cup of tea (organic ginger & green, with cayenne pepper, MSM, Ester-C); didn't make that mouse too happy at all.

Anyhow, dried it up, used some compressed air in a fine now. ;>)

Thanx all!


Report •

January 3, 2010 at 13:30:36
Originally posted by kimsland Date: January 2
Then Restart

Originally posted by FACE Date: January 3
turns out I just had to reboot

Sorry I couldn't help
Glad "you" worked it out

Report •

January 3, 2010 at 13:32:12

"(organic ginger & green, with cayenne pepper, MSM, Ester-C)"

No wonder you lost it; you ever think of booze as an alternative to that stuff?



Report •

Ask Question