printer spooler not running

December 15, 2010 at 19:02:22
Specs: Windows XP
Okay, I'm stumped :( I have Microsoft Windows XP 2002

I've had Kodak All in one for about 3 months now, I had a virus and last week i put McAfee Virus protection on my computer. And ever since then my printer has not been running properly. When I go to my properties, it shows i dont have a printer installed. and when i try to add a printer it says "Operation could not be completed. The print spooler service is not running. Ive tried looking up answers on the web and tried many different things but its still not working.

Does anyone have any suggestions?

See More: printer spooler not running

Report •

December 17, 2010 at 15:00:03
How to clean up printer drivers
If the Print Spooler service fails when printing, when Windows starts or it can not be restarted, the usual reason is that one or more printer drivers is defective. If the Print Spooler service is not running, the Printers and Faxes folder will be empty and you can not use it to remove (or add) printers or printer drivers.

Report •

December 22, 2010 at 18:35:17
Okay, I downloaded that Resource Kit, and I am stuck at part 8, 9 and 10...

8. open a Command Prompt window
9. key the commands
net stop spooler
net start spooler
10. open Windows Explorer

11. navigate to %systemroot%\system32\spool\printers\ and delete any files there. By default, this is where the print spooler stores print files.

12. navigate to %systemroot%\system32\spool\drivers\w32x86 (%systemroot% is usually Windows, but it might be winnt or something else; this is set when the OS is installed).

13. inside w32x86, there will be folders with the names 2 and 3 (one or more of these may be absent - not a problem)
delete all of the files and sub-folders in each of the 2 and 3 folders, but not the folders themselves
inside w32x86, there may be other folders with names starting with "hewlett_packard", "hphp" or something else; delete these folders also

14. restart the print spooler (see steps 8 and 9 above)

I open the command shell but when i type "net stop spooler" it shows this
The Print Spooler service is not started.
More help is available by typing NET HELPMSG 3521.

I was unsure if that is what it was supposed to say so when i typed "net start spooler" it said..

The system cannot find the file specified.

& when step 10 came.. i didnt understand when it said open Windows Exlporer.. and or the rest of the steps.

Thank you for trying to help. and if you still can that would be great

Report •

December 22, 2010 at 18:44:26
Okay i got through steps 10-14 but it still shows the same thing when i key in "net stop spooler" and "net start spooler"

Report •

Related Solutions

December 22, 2010 at 21:54:32
Lets make sure you are infection clean, starting with this one.

Malwarebytes' Anti-Malware
Error codes
Common Issues, Questions, and their Solutions, Frequently Asked Questions.
VIPRE Rescue Program
Try it in Safe mode.
If it won't run, rename the downloaded mbam-setup.exe file to mb.exe to help work around certain malware that will block it from being run.
If it still will not run.
1: Go to Control Panel > Programs and Features and uninstall Malwarebytes.
Next redownload Malwarebytes but rename it before you download it to your desktop. As you are in the process of downloading when you get to the point that the "enter name of file to save to" box appears, in the "filename" slot, rename mbam-setup.exe to something.exe, then click Save.
If it installed but will not run, navigate to this folder:
2: C:\Programs Files\Malwarebytes' AntiMalware
At the top of the page, Tools > Folder Options > View, click > Show hidden files and folders and untick > Hide extensions for known file types.
How to see hidden files in Windows
Rename all the .exe files in the Malwarebytes' Anti-Malware folder and try to run it again.
When it opens, update 1st.
If it won't update after installing, update manually.
Download & install.

Report •

Ask Question