Pretty Involved RAM issue

May 27, 2009 at 11:57:47
Specs: Windows XP SP3 32-Bit, 2.128 GHz / 2047 MB

before I launch into my question, please note
that I've searched the web up and down and
read my head wooly about this. I know about
32-bit WinXP's 4GB virtual memory limit, the
36-bit PAE fix, etc. I also know that it is
common for XP to recognize only 3 to 3.5GB
of 4GB physically installed.

My problem: XP is only recognizing 2GB out of
4GB physically installed. That's at least a full
GB that I'm getting jipped. Doesn't sit well at
all. Is there something I can do, besides
switching to a 64-bit OS, or is this outside of
my control?

The info:
- WinXP SP3 32-Bit (legit, fresh installation)
- Gigabyte GA-E7AUM-DS2H mobo
(Geforce 9400 onboard gpu, 51MB physical
RAM manually allocated)
- 4GB (2x2GB) Patriot Viper PC2-6400 RAM
- Intel Core2Duo 6400
(The mobo and RAM are new, CPU migrated
from old PC, as did HDDs, PSU etc, all
working fine)

Now, the BIOS recognizes the full 4GB
(3582MB, plus the 512MB allocated to the
onboard geforce 9400 gpu, for 4094MB total).
When I check the system properties in
WinXP, however, it only reports 2GB and says
'Physical Address Extension' beneath it (I
assume this means I have PAE enabled?).
Considering that I have 512MB allocated to the
onboard gpu, and allowing for a generous
512mb of other memory needs, I should still
have 3GB reported.

I have checked both DIMMs individually in the
mobo, also checked all the different slots, and
XP reports the expected 1.5GB every time.
So, as far as I can see, DIMMs and slots are
all fine. I also tried inserting both DIMMs but in
different channels, even in this case XP only
recognizes 2GB.

I tried adding the /PAE extension to the
boot.ini file (using Microsoft instructions, no
less), but that made no difference at all after
reboot. System properties reports 'Physical
Address Extension' whether or not I add /PAE
to the boot file... I've deleted it from the boot
file since.

All the memory timings I can see in the BIOS
are set to auto or tied to the CPU, nothing
funky going on there...

Would someone help me out, please? Thank

See More: Pretty Involved RAM issue

Report •

May 27, 2009 at 12:29:05
PAE switch is only used if more than 4gig of ram installed.

What is listed in system properties is just telling you the intel extensions are built in and nothing more.

I assume you have no /MAXMEM switch in your boot.ini?

What does xp report when you only have one memory stick installed?
Same number for both sticks when placed in alone?

Report •

May 27, 2009 at 13:30:06
What is the model and brand of your motherboard? What are the specs on the RAM? What graphics card are you using?

Report •

May 27, 2009 at 14:25:28
Wanderer: as I wrote in the first post, perhaps unclearly, XP
reports the correct RAM with only one stick installed. That is
1.5GB. The other 512MB are allocated to the onboard gpu.
Both sticks work perfectly when used alone.

You are correct about the /MAXMEM switch, I don't have it
enabled. Should I? If so, can I just append it to the end of
the ARC path like the /PAE switch?


Othehill: Read my first post to find out.

Report •

Related Solutions

May 27, 2009 at 19:37:20
Apparently you have a lot of compnents that are being mapped to the 4GB of virtual address space (VAS).

Report •

May 28, 2009 at 21:45:46
I just installed Windows RC 7, 64-bit. It recognizes all my RAM,
4.00GB (3.00GB usable). YAY!

Report •

Ask Question