Phoenix Bios upgrade, HIMEM message

February 7, 2011 at 06:48:57
Specs: Windows XP
I am trying to upgrade the BIOS on a pc using floppy disks, i keep getting this error message in the middle of the process:

Phoenix phlash error
Cannot flash when memory managers ( e.g. HIMEM) are present.
press any key to exit.

I have tried several different ways, i have used WINDOWS ME start up disks then put in a floppy disk with just the PHLASH.exe flash utility program and the platform.bin BIOS file. Any help really appreciated.

See More: Phoenix Bios upgrade, HIMEM message

Report •

February 7, 2011 at 07:30:20
WHY do you want to flash the bios ?

Flashing the bios is not a cure-all !
It's the riskiest thing you can do with a computer !
Even if you do everything right, the flash chip can physically fail while flashing and in that case the mboard will not boot after flashing !

99% of the time, it won't fix whatever problem you're having, unless you have found bios update release notes or other confirmed info that flashing the bios to a newer version will fix your problem !
Usually there is no valid reason for flashing the bios,
unless you need to use a newer bios version in order for it to recognize a cpu type it doesn't presently recognize, and you have found official info upgrading the the bios will support recognizing the cpu you want to use.

Flashing the bios cannot
- make it recognize ram modules larger the the max the main chipset, or on more recent mboards the memory controller in the cpu, presently recognizes.
- make it recognize hard drives larger than 137gb (manufacturer's size = 128gb in the bios and in the operating system) if the main chipset cannot support that.

All the flash floppy needs is the minimal system files it takes to make it bootable, the correct phoenix bios update file for your mboard model and board version or revision, and the correct phlash utility version for that bios update file.
Optionally you can make an Autoexec.bat file on the floppy with a line that starts the flash utilty.

Just use Format (RIGHT click on the A drive to find Format) in ME or 98SE or 98 to FULL Format a floppy and select Copy system files, or similar.

If you use FULL format, any previously undetected bad sectors on the floppy will be found and excluded from use.
You do NOT want to have the files on a flash floppy that has undetected bad sectors.

Or - you could just delete Autoexec.bat and Config.sys, or rename them e.g. to have a useless file extension, on the ME Startup disk.

Report •

February 7, 2011 at 07:42:18
A BIOS update should only be done when it addresses a specific problem you are having. The update must come from the computer or mother board manufacturer and must be an exact match for your system.

A BIOS update is inherently risky. Even if you do everything right a failure could result. This usually means a dead system and an expensive repair bill.

Report •

February 7, 2011 at 08:11:23
Thanks guys but i MUST update the BIOS because i mistakenly flashed a slightly wrong version of it, its for the right board but the board was also used by HP and so the BIOS opens with a HP logo and doesn't fully boot either. I can access the BIOS but first i want to replace it and then work on trying to get it to boot up hard drive. I don't understand why i keep getting the same HIMEM error message. I completely formatted the floppy and then copied the flash utility and BIOS file, i booted up with an ME floopy disk, swapped floppy and entered PHLASH platform.bin after the A:\ prompt and it attempts to flash the BIOS but fails with this error message above every time.

Report •

Related Solutions

February 7, 2011 at 08:17:58
make sure there is no config.sys or autoexec.bat files on the diskette. If they exist rename them to .old so they don't run.

Himem.sys is loaded in the config.sys file.

Biggest threat to a bios flash is a power outage. Highly recommend a ups be connected before flashing.

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's

Report •

February 7, 2011 at 08:23:04
WHY did you flash the bios initially ?

"I don't understand why i keep getting the same HIMEM error message."

An ME (or 98, or 98SE) Startup disk loads HIMEM.SYS in Config.sys - HIMEM.SYS is also on the floppy.

You're taking an unpredictable risk when you use a bios update for a brand name system bios version with a mboard that has a retail mboard bios version, or visa versa. That could also result in the flash failing !
The boot loader portion of the bios data - the fail safe part of it that allows you to recover from a failed flash, if the flash chip is still okay - is usually NOT flashed by default, but the boot loader portion of the data for a mboard manufacturer's retail model may be different from that for a brand name system bios version for the exact same model !
On top of that, I know HP and Compaq use oddball phoenix bios updates that don't use the usual separate bios update and flash utility !
Many mboards used in brand name systems are OEM only models - made only for brand name system builders - the mboard maker has no retail mboard that is exactly the same. If you use a bios bios update for a brand name system bios version with a SIMILAR mboard that has a retail mboard bios version, or visa versa, that can result in disaster - e.g. even if the main chipset is exactly the same, the I/O chip may be different.

Report •

February 7, 2011 at 08:39:05
But i can't find them on the floppy, i can't find config.sys autoexec.bat on the it, are they hidden files? I have set folder options to show hidden files but they don't show up so how can i find them?
Thanks a million for this help guys, i have working on this for nearly a week.

Report •

February 7, 2011 at 08:55:24
You can format a floppy disk from Within indows XP. It will create a pure MS-DOS boot disk without any extra config.sys or autoexec.bat. Use that to boot and flash the BIOS.

I believe the version of MS-DOS that came with Windows ME had HiMem incorporated into the main files and did not require a separate entry in config.sys


Report •

February 7, 2011 at 09:04:01
I used XP to create the first startup disk but got the error message. How can i see if these files are on the disk if they don't show under "Show hidden files"? At the moment the error message seems to be an error in itself because i can't locate autoexec.bat or config.sys or HIMEM on the disk.

Report •

February 7, 2011 at 09:13:41
Just tried with XP startup disk with flash utility and BIOS file onboard and same error: Cannot flash whenmemory Managers (e.g. HIMEM) are present

Report •

February 7, 2011 at 09:23:11
I had replaced the dead motherboard with nearly an identical one and had got it running very well so just to perfect it i decided to update the BIOS which i knew was old but i picked the wrong one from this link: I picked the first one thinking it was the most recent but should have picked the 5th/last one

Report •

February 7, 2011 at 09:24:10
It sounds like you are not actually booting the computer from the floppy disk.

The floppy disk must be inserted in the floppy drive while booting.
The computer must recognize the floppy drive and flash floppy as being bootable.

The floppy drive must be detected in the bios.

The Boot Order or similar settings in the bios should be set to floppy drive first, CD-rom or similar, hard drive.
Most bioses will not recognize a bootable floppy in a floppy drive if floppy drive is not first in the Boot Order or similar.

If that doesn't help....

Did you load bios defaults after you flashed the bios ? If you didn't do that, DO THAT ! Usually flashing the bios does NOT clear the previous Cmos contents, and that can cause problems if the previous cmos contents do not match what they should be for the bios version.

If that doesn't help....

You may have floppy drive data cable problem.

This is about IDE cables but the same thing applies to floppy data cables....

It is common to un-intentionally damage IDE data cables, especially while removing them - the 80 wire ones are more likely to be damaged. What usually happens is the cable is ripped at either edge and the wires there are either damaged or severed, often right at a connector or under it's cable clamp there, where it's hard to see - if a wire is severed but it's ends are touching, the connection is intermittent, rather than being reliable.
Another common thing is for the data cable to be separated from the connector contacts a bit after you have removed a cable - there should be no gap between the data cable and the connector - if there is press the cable against the connector to eliminate the gap.

Try another data cable if in doubt.

If that doesn't help....

You having flashed the bios with the HP version may have made it impossible to boot the computer from a floppy disk.
You could try making a bootable CD flash disk.

Report •

February 7, 2011 at 10:07:43
I am booting from the floppy, without the floppy i only get a black screen with top left flashing cursor, i can see it boot up the floppy ie "Starting,,,,"
then the A:\ prompt

Report •

February 7, 2011 at 10:08:52
I loaded bios defaults too,,,

Report •

February 7, 2011 at 10:17:49
Use the 2-floppy method:

Floppy 1 is a WinME boot floppy. You can download the program to create one at

Foppy 2 contains the flash utility & BIOS file.

Boot off floppy 1 & select "minimal boot". This insures that no unnecessary files will load into memory. When it stops at the A:\> prompt, eject floppy 1 & replace it with floppy 2. Type phlash & press enter, then follow the onscreen instructions.

Report •

February 7, 2011 at 10:20:10
The bootable floppy you make in XP is not a Startup disk - it's just a boot disk - a bootable floppy with ME system files on it . It doesn't have HIMEM.SYS on it.
If that's what you were using I have no idea why you're getting an error message about HIMEM.

A Windows 98, 98SE,. or ME Startup disk is made in Add or Remove Programs, and has many more files on it, for preparing the drive with Fdisk and Format, and for supporting a CD drive in "real" mode./

Report •

February 7, 2011 at 12:32:42
The only thing I can think of is the flash utility is stupidly written and it is assuming .sys files on the floppy are some memory manager.
E.g. when you make the MS-Dos floppy in XP, there are seven *.sys files on it, one of them is normally hidden - config.sys, other than the hidden io.sys which is a system file
OR, it may be detecting the config.sys file, which is not supposed to be on a flash floppy, and is assuming it has a line that loads a memory manager. .
(Win 98, 98SE, and ME Startup disks have a normally visible config.sys file).

If you can't see hidden files in XP....

Go to Control Panel - Folder Options
Click on the View tab.
Click on the circle before Show hidden files and folders to show a dot
It's also useful to
Click on the checkmark before Hide extensions for known type to remove the checkmark
You may also need to
Click on the checkmark before Hide protected operating system files to remove the checkmark

Click on OK at the bottom of the Folder Options window .

All you need on the MS-Dos floppy you made in XP is, IO.sys, and MSDOS.sys

All you need on a floppy that has had system files placed on it in 98, 98se, or ME is, IO.sys, and MSDOS.sys

In Win 98SE - this is probably the same for Win 95 thru ME

To show all files and file name extensions

In My Computer or Windows Explorer, click the folder you want to look at.
On the View menu, click Folder Options.
Click the View tab, and then click Show all files.
If you want to see all file name extensions, click to clear the Hide file extensions for known file types check box.

To select a folder in the left pane of Windows Explorer, click the folder.

Report •

February 8, 2011 at 08:26:12
@Tubesandwires I really appreciate all your help thanks a million, i have been very busy today in work, yesterday i made a little bit of breakthrough in the sense that i realised that if config.sys and autoexec.bat are actually on the floppy i found a way to delete them by just making up new ones in notepad and copying them over to the floppy, when i did that i got a box asking me if i want to replace them and so confirming that they are invisibly on the floppy:-) But they are not causing the eg HIMEM.sys warning. I don't know the name of the file (Memory manager on the floppy that is causing the conflict. Any ideas?

Report •

February 8, 2011 at 09:49:18
See the info in response 16. Delete all files on the floppy, except the three essential system files and the bios update file and the phlash utility. Enable showing hidden files if you need to.
Optionally, you can make a txt file in Notepad with a line that loads the phlash utility and the bios update if you know what that line needs to be, and save it as Autoexec.bat . (If you need to Edit Autoexec.bat, RIGHT click on it, choose Edit, NOT Open, and don't double click on it, otherwise you will run it. If you run it accidently, UNPLUG THE POWER CORD OR SWITCH OFF THE AC POWER TO YOUR SYSTEM BEFORE THE PHLASH UTILITY STARTS TO RUN ! )
The phlash utility MAY be generating the message because it's detecting the config.sys file is on the floppy. Obviously it's not actually detecting himem.sys.

If that doesn't help, there is universal flash utility that you MIGHT be able to use instead of phlash.
Or - there MAY be a different phlash utility version that you could use, however, it's usually hard to determine that other than trying one.

Report •

February 8, 2011 at 11:41:27
Thanks everyone

@Tubesandwires I can't delete all the files because some are invisible and don't show even though i have set "show hidden files". I have formatted these disks too but can't see all the files on them so cant delete all of them. If i knew the names of all the hidden files especially Memory Management ones i might solve the conflict

Report •

February 8, 2011 at 12:24:19
If you have formatted the disk whatever files that were on it before are of no concern. Formatting deletes the partition table info about where the previous files were stored, whether they were hidden from you seeing them in the operating system or not. The phflash program cannot find those files !

Otherwise, you can set 2000 or XP, or previous operating systems, to show all hidden files on the floppy, as I explained in response 16.

See response 16.
If you haven't already done so, in 2000 or XP, in Folder Options - View - "you may also need to
Click on the checkmark before Hide protected operating system files to remove the checkmark "

"If i knew the names of all the hidden files especially Memory Management ones i might solve the conflict"

If you made the floppy with MS-Dos system files on it in XP, then THERE IS NO MEMORY MANAGEMENT FILE ON THE FLOPPY !
The daxx phflash version is FALSELY generating the message for some other reason !

Report •

February 8, 2011 at 16:35:54
Thanks a million, sorry i did not tick "Hide protected operating system files" so that was why i couldn't see them, just used XP floppy with 3 essential files command, IO and MSDOS, and still the same problem. Perhaps a problem with PHLASH.exe or platform.bin I have tried two different versions of PHLASH but i extracted platform.bin from imp_glve_101.exe the Windows BIOS update program for the Motherboard. Half 12, i have to go to bed.

Report •

February 8, 2011 at 20:53:23
You are an example of an amateur should NOT flash a bios with a flash utility unless he/she has FULL flash instructions !!

It just occurred to me that a *.BIN file is NOT a Phoenix bios update file !

A *.ROM file is a Phoenix bios update file !

(OR, a *.ROM file can be an AMI bios update file.)

First of all, are you SURE you got the RIGHT Trigem bios update download?

imp_glve_101.exe is for the Trigem Imperial GLVE motherboard.

Are you SURE you have the GLVE motherboard ?

Look at the pictures here:
Trigem Imperial-G/GV/GL/GLVE Mainboard

If your mboard is NOT GLVE, there's no guarantee the bios update will work !

The only other Trigem bios update there on the e4all site is labelled for GLA .

Is your emachines model this mboard was / is in listed on the left side of that page ? It SHOULD be !

I tried many of the models listed on that page here:
Drivers and Downloads

NONE of the ones I tried have a bios update listed !

The Readme file beside the imp_glve_101.exe download on the e4all site says....

Good luck trying to translate Korean !
It attempts to translate the Korean characters on the right into English on the left.

Trigem is a company in Korea that makes Trigem mboards and all emachines systems. (Most newer emachines systems do not have Trigem mboards - the mboards are made by various major brands.) They ship their systems all over the world and their systems end up with bios versions suitable for the country the brand, in this case an emachines system, is sold in, but in this case, this bios update appears to be meant for upgrading a Korean bios version ! (They also supply some models sold as HP and Compaq desktop models.)
You may flash the bios successfully and then find the text in the bios is in Korean !
It may not be an emachines bios version !

I downloaded imp_glve_101.exe and executed it. I managed to make the boot floppy, but there was NO English text on the message boxes, just lines, except for an Error message, and on the buttons - OK, Cancel, Yes, No, etc.

I got text flashing by on a small message box, then
ERROR in a small message box over that.
Then I clicked on OK.
Then with a floppy in a drive , I clicked on OK again, then Yes.
It showed that it was formatting the floppy and while doing so apparently it extracted files to it.
(By the way, the first floppy I tried had bad sectors on it and it wouldn't let me format it, etc.)

I looked at the contents of the floppy.
It has a -----.txt file that can't be read.
It has the PHLASH.EXE flash utility (NOT PHFLASH) , PLATFORM.BIN, and a D00A.ROM file .
The platform.bin file is TOO SMALL to be a bios update !
The *.ROM file is the right size (512kbit - 1/8th the size of the bios flash chips's 4mbit capacity - the update itself is always compressed).
(If the *.bin file were 512kbit it would be an AWARD bios update !)
It already has IO.SYS, MSDOS.SYS (both are hidden files) and COMMAND.COM (visible) on it.
(When I boot with it the screen displays Starting Windows 98 - I made the floppy in Windows 98SE - it may copy whatever system files the system has, or it may already have those.)

It has an UP.BAT file - inside that file (RIGHT click on a *.bat file, choose Edit to read it ; DO NOT choose Open or double click on it, or it will Run) it has a line

PHLASH D00A.ROM /s /x /c /mfg /mode=3

That's the line that loads PHLASH and the bios update file, and the /things after that are command line switches that perform functions the phlash utility executes automatically.

Apparently what you're supposed to do is insert the floppy, boot the computer with it, and at the prompt, type: UP, press Enter.

When you boot into Dos and type /? after the name of most flash utilities, you get a list of the command line switches. I did that with the flash floppy.
There were so many switches listed only the latter part of the text about them was on the screen.
I typed PHLASH /? > A:/SWITCHES.TXT (press Enter) to make a text file on the floppy - switches.txt - that has the output text of the result of typing PHLASH /? .

I looked at switches.txt in Windows.

"PHLASH D00A.ROM /s /x /c /mfg /mode=3 "

/s - Silent operation (turn off speaker).
/x - not listed
/c - Clear CMOS checksum after programming. (Clear Cmos contents after flashing ?)
/mfg - Manufacturing mode - Automatically reboot without keypress.(after flashing)
/mode=3 - not listed

At the bottom of switches.txt it says:

To FLASH a part you also need the following files:
1) PLATFORM.BIN (manufacturer specific initialization file)
2) BIOS.ROM (BIOS ROM image file)

- so - you need BOTH PLATFORM.BIN and D00A.ROM on the flash floppy

I looked at PLATFORM.BIN in notepad
- most of it is in machine characters except for
Intel NBVV (FWH4 4M-bit ROM) CR board ZQFD2.00 BIOS.ROM

4M-bit ROM - the bios flash chips's capacity is 4mbit

I tried booting with the flash floppy on my 98SE system which has an Award bios version, and typing PHLASH to see what the utility looked like.
I saw the screen but it immediately generated an error message:
(No memory manager error message).
I'm not sure what that message indicates.
I assume it's either because
- the mboard was detected to not have a phoenix bios version
or - it was because I had not specified a *.ROM bios update file on the command line, e.g. PHLASH D00A.ROM, without the command line switches, would start up PHLASH and specify the *.ROM file, then you would choose what you want to do in the flash utility screens..

After you flash the bios, the first time you boot you will get a "Cmos Checksum Error...." or similar message. You will either be prompted to enter the bios Setup or you will automatically go there. Enter the bios Setup, and set the Date an Time, Save bios settings.
(If you used UP.BAT, the previous Cmos contents have probably already been cleared. When you are not sure whether they've been cleared, you also load Bios Defaults after flashing the bios, otherwise, the contents of the Cmos part of the bios and what you see in the bios Setup may not match the bios version, and your settings in the bios Setup may not work properly.)

NOTE that some Trigem mboards are known to have this problem....

Some mboards develop this problem - electrolytic capacitors were installed on them that were not properly made, and they fail eventually - the mboard manufacturer didn't know they were improperly made at the time the mboard was made.

Open up your case and examine the mboard to see if you have bad capacitors, and/or other findable signs of mboard damage .

This was the original bad capacitor problem - has some example pictures.
History of why the exploding capacitors and which mboard makers were affected:

What to look for, mboard symptoms, example pictures:
Home page that site
- what the problem is caused by
- he says there are STILL bad capacitors on more recent mboards.

Pictures of blown capacitors, other components, power supplies, Athlon cpu's, etc.:

Report •

February 9, 2011 at 03:33:41
What can i say? I have to read all this and try it but THANKS A MILLION for all of this, yes the board is an emachine mat#134454 GL VE 20020906 machine so i believe this is the right BIOS for it.

Report •

February 9, 2011 at 04:39:41
WINDOWS XP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :-)
THANKS A ZILLION!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
GOD BLESS YOU!!!!!!!!!!
I did exactly what you said and HEY PRESTO!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Listen man i'll pray for you!!!!!!

Report •

February 9, 2011 at 04:45:18
MACHINE IS RUNNING PERFECTLY!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Report •

February 9, 2011 at 08:09:39
Success ! That's what we like to hear !

I don't get prayed for or blessed often - Thanks for that.

Thanks for the Thanks. We don't hear that often enough.

Could you answer a few questions .....

Why did you flash the bios in the first place ?

Which operating system did you make the boot floppy in ?

Do you see "Starting Windows 98..." when you boot with it ?

Is the text in the bios in English ?

Is it obvious it's for an emachines system ?

Is the specific bios version stated in it ?
E.g. ZQFD2.00

Report •

February 9, 2011 at 09:23:49
Why did you flash the bios in the first place ?

Is the text in the bios in English?

Is it obvious it's for an emachines system?

Is the specific bios version stated in it ?
E.g. ZQFD2.00

1) The original (Mat# 143159 Imperial GV 20030812) motherboard of the 420 emachine died and i just happened to have a (mat#134454 20020906) imperial gl ve in my room which i swapped with it. Had one or two drivers to disable but then it seemed to be working perfectly so updated all drivers etc. But discovered that i had connected the Power Switch, HDD, etc wrong (pc booted when plugged in) so i corrected that and then thought it would be a good idea to update the BIOS, after doing that pc wouldn't boot Windows etc and there began the nightmare for over the last week. The emachine logo changed to a HP logo so that made me double check the BIOS on the update site and i realised i had updated the wrong BIOS.

BIOS text is in English

A Trigem logo came up on the screen first time but not any more perhaps after loading defaults? No emachine logo.

BIOS version
I can't read it because it only flashes for a split second.

Problem! Hard drive led flashes after shutdown?

Report •

February 9, 2011 at 11:26:37
"...then thought it would be a good idea to update the BIOS,..."

It wasn't such a good idea was it?
Many people think flashing the bios is something they should do even if there's no particular reason to do it, and many think doing that will cure a problem they're having Too many places on the web suggest you should update the bios if it has an old specific version.
You are WARNED at many places on the web where you get bios updates, including on the e4all web site, and virtually every mboard manufacturer's web site, that you should NOT flash the bios when there is nothing wrong with the present bios version, and/or if something goes wrong while flashing or if you use the wrong bios update, you can end up with a mboard that will not boot at all after flashing.

"BIOS text is in English"

Okay, that's good.

"A Trigem logo came up on the screen first time but not any more perhaps after loading defaults? No emachine logo."

There may be a setting in the bios enable / disable logo screen.

"BIOS version
I can't read it because it only flashes for a split second."

Anything that displays too fast for you to read while booting - if you press the Pause key at the right time, the POST (Power On Self Test) will usually halt and you can then read what's on the screen easily - press any key but Pause to continue.

Sometimes there is a bios string displayed at the bottom of the first screen while booting - there usually is one for older mboards. .

The video adapter may briefly display a message while booting as well.

What I meant was, in some bioses the specific bios version is stated in the bios Setup screens somewhere.

"Problem! Hard drive led flashes after shutdown? "

Are you sure it's the HD activity led and not the Power led ?

The Power led flashing can indicate a problem with the power supply or with something else.
I don't know of any reason a HD activity led would flash after Windows was Shut Down, unless the computer was in Standby or Hibernate mode, or possibly you have the bios set to wake on something and you did something to activate that - e.g., you moved a mouse, pressed a key.
See the last part of Response 22 - you MAY have failing capacitors on the mboard - the same thing can happen inside the power supply.

If it has a BESTEC power supply, they are WELL KNOWN to cause problems !
For more info, see response 1 in this:

By the way, a bios update and a bios upgrade are two different things.

A bios update updates the specific bios version the mboard already has - usually it just fixes bugs in the code that were in previous versions, and/or adds support for recognizing more cpu types.
The newest available update has all the fixes of previous updates, unless there was a problem with something that was changed.
Usually flashing the bios with an update DOES NOT load the Boot Loader portion of the code - it's the same as it was in the original bios version.

A bios upgrade replaces the whole of the bios code , including the Boot Loader portion of the code - changes the version to that other than what was originally used - with a different version that is compatible with your mboard model's chips (primarily the main chipset chips and the I/O chip) . You can buy those on the web - they're either a special flash file / flash utility configured to flash the whole bios, or if your bios chip is removable, they will supply you with a new flash chip, already flashed, you change the flash chip yourself. They often have every possible setting available for the particular overall bios version the mboard has, there for you to choose in Setup.

Report •

Ask Question