Click here for important information about

no program asociated with all file windows xp

September 12, 2010 at 17:19:59
Specs: Windows XP
major problem
i cant open maybe any file on windows xp except through safe mode with ms-dos
I can open regedit.exe through ms-dos. But most other files i tried to open from ms-dos wont open, either .exe or other

See More: no program asociated with all file windows xp

September 12, 2010 at 19:27:51
You could try item 314 here:

Goin' Fishin' (Some day)

Report •

September 19, 2010 at 15:37:37
i installed it by copying it to a usb key and then opening the file from ms-dos prompt in safe mode. It installed it, but i still have problems

as before, when i start computer in whatever mode in windows it tells me that it cant load the user profile but loaded the default profile and gives me as a reason: access denied

I can now open Task manager by clicking Ctl-alt-del which i dont think I could do that before - but only in safe mode only. However I still cant see anything but a black screen and when I try to run a program from the task manager (through a program called Prio previously installed) (for example regedit) it tells me the same message:

"This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel."

when i try
from dos it tells me i deactivated system restore (oops) and cant reactivate it in safe mode but have to be in normal mode

i installed also
fileassociationsdon'tchange.reg (Disable Changes to File Associations - Undo)
folderoptions.reg (Restore Folder Options Under Tools)

but couldnt load
zip.reg (Restore Compressed Zipped Folders Association )
restoreregitry.reg (Repair the Registry Editor)
exefix.reg (EXE (lnk and regfile) Fix for Windows XP)

i tried from dos prompt:
assoc.exe --> says it cant find the file association for exe extension
assoc.exe=exefile --> says an error occured while dealing with .exe (im translating from french so the wording isnt exactly that)

in regedit
i had played around with the authorisations in regedit, and i dont know what haoppened but since then in HKEY_CLASSES_ROOT there are no subfolders, and only one thing:
ab(name); REG_SZ(type); value not defined (data) and when i double click this (reg_sz) it says i cant modify it because error while reading the content of the value (again, im translating from french)

i had also played with the file associations under folder options

help! thanks!

Report •

September 19, 2010 at 17:50:08
i logged on as administrator and now i have many files under HKEY_CLASSES_ROOT

Report •

Related Solutions

September 20, 2010 at 16:27:40
ok so now I can use most programs but the computer still acts weird sometimes

I logged on as administrator on safe mode and changed permissions in regedit to allow the most control possible, and I loaded I think all the .reg files previously mentionned (except zip.reg) then I loaded in normal mode and I could open programs. I did something I cant remember what and then I had a task bar.

Remaining problems
-in Folder options --> types of files: i cant modify any file association, or add or delete any either. "exe" seems to be absent from the list. "Folder " and "file folder" (the first two) have no application associated with them (I had played around with these two elements around the time my problem started, sorry). Actually, many types of files are not associated with any program

-When I start the computer, I can only log as me (my name) because when i try to log as administrator it tells me that I have limited access or something like that. Then a window opens that says that it "cant load the user profile but loaded the default profile "and also that the reason for this is "access denied"

- In regedit, I changed the permissions to allow as much control as I could on each main folder (HKEY_CLASSES_ROOT, HKEY_CURRENT_USER, HK_LOCAL_MACHINE, HK_USERS, HK_CURRENT_CONFIG) but sometimes it said that the registry editor wasnt able to define the security in the selected key or in part of its subkeys (again, im translating from french, sorry if it makes ur job harder).
Also I have 4 users:

("Everyone" is a user I had added before, also around the time my computer became unusable)

thanks for ur help and time

Report •

Ask Question