No Option To Repair Windows Installation

Microsoft Windows xp home edition with s...
July 18, 2010 at 08:03:46
Specs: Windows XP Home SP3
I ran into a dead computer and am pulling my hair apart trying to figure this thing out.

Today I booted my computer and all I get is a blinking cursor in the top left corner after the post screen. It never loads windows.

Tried F8 - no joy. Never brings up the menu.
Tried disconnecting CD ROM drive - and re-seating memory. no joy.

Tried creating boot floppy with ntldr files and booting from that.
Changed boot order to floppy - rebooted
Machine loads from floppy and then hits the same blinking cursor.

Nothing at all changed on my system, so I can't understand what happened to cause this!

I took my drive out and connected to my other machine. With a drive adapter, the drive reads perfectly fine. I copied off critical files and decided to try everything but the kitchen sink!

Thought I'd run chkdsk /r to see if it fixed some error. It ran for 2 hours and ended saying it fixed one or more issues.

I rebooted with high hopes...

NOTHING. Same blinking cursor of death.

Read hundreds of posts describing bad master boot record. Used Recovery Console from my Retail XP Boot Disk.

Typed fixmbr
said "New Master Boot Record Created"

Rebooted again with hope..


Read more..
Typed fixedboot

Rebooted again and crossed my fingers..


Ran bootcfg /show to see what shows up in my boot.ini.
It only shows one device and one listing.
Looks perfectly normal to me:

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition SP3" /noexecute=optin /fastdetect

So I thought - maybe I can just run a Repair Install on my XP and it will fix whatever corruption might be causing this.

So, I boot from the CD, just like I got to the "R - for Recovery Console" menu... but instead - hit ENTER to continue installing... Pressed F8 to agree to give up my first born...

At this point, the Windows disk (on hundreds of other systems) usually checks the drive for Windows Installation paths... and then results with one that's highlighted... where it gives you the option to press R to repair (windows repair install).

However, in this instance, after pressing F8 - the menu takes you right into showing you the partitions and only gives you the option of deleting partitions or installing again on the same partition.

What can cause the Repair Windows option to NOT work, or not show?

It's treating my machine as if there IS no Windows installed, but there is! And it's only giving me the option to install on my main partition...

So, out of curiosity I choose to install (again) on that partition. Then the next screen warns me of installing Windows again on a partition which already HAS Windows installed!! Well DUH! But why?

I'm so frustrated, I could cry!
Any ideas?
Please? Anybody? Either on the blinking cursor, or WHY the repair option is missing?

I keep reading that people try using non-matching SP releases - can cause this. However, this is NOT the case on my machine. This is the exact same XP Retail Disk I installed from.

Also, some people say OEM disks can cause this. My Disk is a holographic, bonified, out of the Windows retail box - legitimate disk! I've done repair installs before on this exact machine years ago... but now it doesn't work!


See More: No Option To Repair Windows Installation

July 18, 2010 at 08:05:19
For some reason, the product window didn't put in the right version of Windows - so for the record, I'm using WIN XP Home Edition, SP3 as the OS listing in my profile states.

Report •
Related Solutions

Ask Question