Newly installed 3rd internal HDD unreadable

Shuttle / Mv42
January 5, 2011 at 22:34:50
Specs: Windows XP Pro, SP3, AMD Athlon 64x2 Dual Core 4800+ 2.5GHz/2GB RAM
Installed a 3rd drive (WDC WD400BD-75LRA0) on my son's system. I believe the drive had a previous owner. (It was given me by my older son, who runs a business and has a lot of used equipment sitting around.)

MBoard is a Biostar TF560 A2+
CPU is an Athlon 64x2 Dual Core Proc 4800+, 2.5 GHz
RAM is 2GB

the drive is recognized in My Computer, as drive "H", 37 GB. Ran a check, sectors, everything seems to pass, no problem. BUT when I go to Control Panel/Administrative Tools/Computer Management/Disk Management, it shows Disk 0 (IDE), Disk 1 (SATA), as "Basic" and working, but Disk 2 (SATA), the new one, is showing a red X, and "Dynamic" and "unreadable". It does show the size (37.2 GB) and the model no., but again,,"unreadable".

I've tried every kind of troubleshooting I'm aware of in Windows. Right clicking on the "Dynamic", "unreadable" gives a menu that offers "Convert to Basic Disk", but when I select this option, nothing seems to happen, and the situation remains the same. I've done a quick format, a disk check, an uninstall and restart. Nothing seems to work.

I don't know if WD has any kind of troubleshooting software for their products.

Any suggestions?

See More: Newly installed 3rd internal HDD unreadable

Report •

January 6, 2011 at 04:48:04

depending on the model # of the drive, there is a diagnostics tool available. I wouldn't loose much sleep over a 40 gig hard drive.

Report •

January 6, 2011 at 05:10:32
"I wouldn't loose much sleep over a 40 gig hard drive."

Me neither. It's just a back-up that was requested for a specific purpose, and to me, the challenge of making something work, or finding out why is paramount. Plus it was free!

Thanks for the link. This looks like the page I was looking for:

I think I'll try the "Data Lifeguard Diagnostic for DOS".

Report •

January 7, 2011 at 02:56:58
Okay, now I seem to be getting somewhere with the disk, but I'm not certain what to do next:

I ran the Western Digital gamut of diagnostic tools, using "Data Lifeguard Diagnostic for Windows". I did the "Full Test", the "Quick Test", and both passed, so I did the option to "write zeros" to the entire drive (Full Erase), since nothing had failed yet, and I wanted SOMETHING to fail, so that I would have SOME indication of what wasn't working.

Well, at the end of writing zeros to the entire drive, it gave the usual "Pass", but with a caveat: "failed to update disk property".

I didn't know what that meant, but decided, now that the disk was no longer formatted, nor had a file system, that I would now format the disk. I chose to do the full format, in My Computer. After that finished, I received the message, "Windows was unable to complete format"

then I chose "quick format", and received the same message.

at this point, the drive was no longer seen in My Computer, after a restart, so I went back into Control Panel/Administrative Tools/Computer Management/Disk Management, to see if it saw the disk there, and when I did that, a window came up saying that a "disk 2" was present that had not been "converted", or "allocated", or something (I forget the word). I chose to have Windows recognize the disk, which was numbered "disk 2", as before, so I selected "disk 2" (the only option), and clicked "OK".

Now, finally, the disk was seen, in disk management, as "dynamic", like before, but this time without the red "x", and "unreadable" messages, and it showed 37.25GB "unallocated".

I'm not sure what to do now. Right-clicking in either field, I get (in field 1) "new volume", and "convert to basic disk", "properties", and "help". Field 2 (on the right of field 1, where the size of the disk is seen, offers "new volume" and "properties" and "help", when right-clicked.

I don't understand "dynamic" vs. "basic disk", but noticed that when my son was fooling around with this, he kept trying the "basic disk" option, but it wouldn't take. I don't know if I should try that, or not. I did not notice "new volume" as an option when he was messing with it.

So, what should I do? "new volume"? "convert to basic disk"? both, in a particular order?

I'll be seeing him on Saturday the 7th. So if no one feels like responding, I can ask him. But I'd kind of like to show him that I made some progress.

Report •

Related Solutions

January 7, 2011 at 15:25:28
Okay, I figured it out.

First, I switched the drive from "dynamic" to "basic", and then clicked on "new volume", stepped it through the wizard with all the defaults, setting it up as one 38GB primary partition in NTFS. Then I formatted it and it's good to go.

So, the fix, from "unreadable" to "good to go", was to step it through all the Western Digital diagnostics, write zeros on the entire drive, bring it back up in Administrative/Disk Management, let Windows basically guide me from there, with a few hints from my son. (I didn't know whether to set it up as "primary" or "extended").

Thanks for the help in finding the WD drive diagnostics page. :)

Report •

January 7, 2011 at 15:59:23
Glad it worked out for you. Good Luck.

Report •

Ask Question