New memory not being used?

December 29, 2008 at 12:29:01
Specs: Windows XP, Mobile AMD Sempron 1.6ghz

I have just bought 2 x 1GB memory modules to replace the 2 x 256MB sticks pre-installed in my Acer Aspire 3000 Series laptop but I think there may be a problem with one or both of the modules......

Online tests ( + others) say that there are 2 x 512MB modules installed (Should be 2 x 1GB!) and the 'system information' shows 'Total Physical Memory of 1,024MB and yet 'Available Phyical Memory' of 1.41GB?! (Total Virtual Memory of 2.00GB / Availble 1.96GB, Page file size 3.72GB)

However, the 'control panel - system' option says 1.93GB of RAM and the DirectX Diagnostic Tool (Start-Run-DXDIAG)says 1982MB RAM.

Is it just me or should they not all match up?

I was planning to send the new memory modules back as they appeared to be faulty or 512MB modules by accident, but now i'm just confused!

Any help would be greatly appreciated!

Many thanks,

See More: New memory not being used?

Report •

December 29, 2008 at 12:35:20
Sounds like incompatible RAM. The density may be too great for your laptop. Typically if RAM has a higher density than the memory controller can access it will either not work, or be seen as half the capacity.

Laptop RAM is best bought by selecting System specific RAM or using a memory scan/configurator from a vendor that specializes in RAM.

Go to and access their online scanner or memory configurator.

Report •

December 29, 2008 at 13:10:06
Hi, thanks for the response.

I ran the memory scanner at Orca Logic before purchase and I was told the memory type I needed was "200-Pin PC2700 (333Mhz) DDR SODIMM"

I then purchased the recommended (compatible) upgrade - both "1G DDR333 SO-DIMM CL2.5" (A recent scan can be seen here: )

The scan just conducted at can be seen here: - it says that I need "1GB, 200-pin SODIMM, DDR PC2700 memory module" or "1GB, 200-pin SODIMM, DDR PC3200 memory module"

It looks as if the memory suggested by Crucial is the one that I have purchased? Could there be any reason as to why it is detected in some programmes (Direct X etc) but not in others such as Windows System Information?

Could this be faulty memory?

Thanks for help,

Report •

December 29, 2008 at 13:17:13
Best way to find out, go into your BIOS (usually pressing DEL, or F12, as your computer starts). There will be a section devoted to the memory, and it will show you how much is installed. Report back what you find there.

Also, while in there, you may look for something about "on board video memory". This is a portion of your total RAM that is reserved for use with the on board video card.

When you go into the system properties in Windows, the total memory should equal what the BIOS showed as installed minus the shared video memory.

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

Related Solutions

December 29, 2008 at 15:48:59
I managed to get into the 'PhoenixBIOS Setup Utility' as it was loading and the bits relating to memory said:

System memory: 640KB
Extended memory: 1982MB
Video memory: 64MB

So that sounds as if it is there and that the BIOS finds it but Windows is only seeing half of it - what do you think could be causing this? Are there any options I should change something to allow Windows to access it all? Could a programme be blocking half of it?


Report •

December 29, 2008 at 19:18:41
Windows should see between 1984MB (1.94GB) and 1982MB (1.93GB). In your original post, you said the Windows System Properties page showed 1.93GB and Direct-X showed 1982MB. Both of these values are within the expected range.

Windows is detecting the full amount of memory, and you don't have a problem unless I missed something...

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

December 30, 2008 at 05:19:20
What worried me was that the system information (the in depth analysis rather than the tabbed 'system' with general, computer name etc) says that the total physical memory is only 1,024MB and the online memory scans said that there were only 2 x 512MB modules. Shouldn't both say nearer 2,000MB or 2x 1GB? Why would they differ? I was planning to send the modules back and get replacements but will I just see the same issue? Am I right in thinking that the memory is there and being used by Windows, but it's just not being shown for some reason?

Report •

December 30, 2008 at 06:36:24
I get lost with all your numbers.
One thing to consider is that most laptops have shared video memory. Meaning that the installed RAM available is reduced by an amount that used by the Video.

I use a program called Ram Idle, to show available free RAM.
Search the web for a program called "Ram Idle".
Many places to download free.
It displays current free RAM in the System Tray.
Also you can right click the icon to free up any
amount of RAM.
I use a Beta version I got some years ago, and
has a Memory Usage of 2,888k.
Computer Speed and Performance May Decrease

When you open, then close programs,
programs may not free up RAM memory.
That is called "Memory Leak".
Restarting computer will clear out its RAM memory.

Report •

December 30, 2008 at 07:34:57
I don't know what you mean by "the in depth analysis rather than the tabbed 'system' with general, computer name etc", but if the system properties page shows you have 2GB (which it does according to the numbers you provided earlier) then you have 2GB.

Furthermore, since the BIOS definitely sees 2GB, there is no way the memory sticks were mislabeled, mismarked, or anything else.

If a website is telling you you only have 2 512MB modules installed, it is either a scam or a glitch.

The scanner at: has always worked for me. You may try it and see what results you get.

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

December 30, 2008 at 07:54:06
Here is what I think is happening. There are different ways to build a 1GB memory module.

You can use 16 chips with each chip containing 64MB, which equals 1024MB or 1GB.

Or you can use 8 chips with each chip containing 128MB, which also equals 1GB.

The issue is this. The first example is constructed in a 4 rank/bank configuration. The second in a 2 rank/bank configuration.

You memory controller calls for maximum of 2 rank/bank configuration. So your memory controller can only see half the chips.

You need RAM that has the 128MB chips on it.

Look at the Wiki link below for a more detailed explanation.

64M x 8-bit (16M x 8-bit x 4 Bank)

DDR PC2700 • CL=2.5 • Unbuffered • NON-ECC • DDR333 • 2.5V • 128Meg x 64

Report •

December 30, 2008 at 10:17:19
I tried the crucial memory scanner (results link posted previously) but it said I had 2 x 512MB. By in depth analysis I mean the "C:\Program Files\Common Files\Microsoft Shared\MSInfo\msinfo32.exe" file. I have put screenshots here of what I was referring to, hope you can see them!

That makes sense - the 256MB modules I removed from the laptop both have 4 chips on either side whereas the new 1GB modules have 8 smaller chips per side. So it seems that the scanner I ran at has told me the wrong memory to get and I simply need to ask to exchange it for a type with 8 x 128MB chips (the pictures on the site for the memory I ordered show this configuration...)

Does this problem basically mean that the computer knows that 2GB is there but it can't use all of it, hence the 1,024MB total physical memory in the msinfo32.exe file?

Could something like a memory update for the memory controller change anything or is the only option to exchange?

Report •

December 30, 2008 at 14:11:33
Each controller on you computer can only access 2 of the 4 banks.

FYI this is actually the reverse of what the usual problem is. Usually older computers want the less dense RAM.

Report •

December 30, 2008 at 15:34:40
OK so i'll get on to the company who told me this is what I needed and ask for 2 sticks with 8x128's instead of 16x64's.

Thank you so much for all your help, fingers crossed the new memory solves the issue!

Report •

December 31, 2008 at 15:23:51
OtheHill, I'm familiar with the problem you are describing, but wouldn't you agree that since the BIOS sees the full 2GB, it is not a problem with the controller? Furthermore, why would the Windows System Properties and DirectX report 2GB?

-Ryan Adams
Free Computer Tips and more:

Paid Tech Support: Black Diamond

Report •

December 31, 2008 at 16:49:31
To Ross & RT,

I misread the original post and was thinking there was 2-2GB sticks involved. Upon rereading the post I realize there is only 2GB total. There is nothing wrong with the RAM or system.

Guess I need to read better. Sorry for the confusion.

Report •

January 1, 2009 at 11:04:11
It just seems strange to me that within the system properties and online scanners the memory appears to be only half recognised. If I have 2GB in there I want it to all be used!

I sent the modules back yesterday and apparently this is a problem they have come across before and they will hopefully replace them with the different type (8x128mb) of memory.

Report •

Ask Question