missing drivers

Compusys / Tl-m510
August 28, 2009 at 14:27:03
Specs: Windows XP
I have reinstalled xp and like many other messages on this site, all of my 'other devices' now have a yellow ? before them. They are: multimedia audio controller, network controller,PCI modem, USB, and Video controller.
The laptop is Compusys make and has a badge containing TL - M510 as its model.
I have no idea who the manufacturers of the numerous hardware components inside are .
can anyone advise me what to do to reinstate these missing divers. I dont have an original disc. Bill

See More: missing drivers

Report •

August 28, 2009 at 15:33:00
Use the link below and follow the prompts. Google is your friend.


Report •

August 28, 2009 at 19:19:51
you may want to download Everest Home
to see which drivers you need.
If everest doesn't help, try SIW

Some HELP in posting on Computing.net plus free progs and instructions Cheers

Report •

August 29, 2009 at 09:35:22
thank you for both replies.
Reply1: unfortnuately my serial number doesn't match the Stone 'download drivers' format, tried ringing them but they are shut
Reply 2: I have a tremendous report from Everest but it confirms that the 'other devices' still show no details against them and doesn't seem to be a product that will reinstall them.
I have downloaded various software and DRIVER ROBOT appears to have found 4 critical updates for my: Video Controller and PCI Modem and Network Controller and Multimedia Audio Controller - all of which (I think ) would help me in my plight; however they want $30 and I'm not too sure if it is worth trying just in case it still doesn't work!
can you think of a free product which may identify what devices I have and update the 'missing' drivers automatically?
thanks again for your efforts.

Report •

Related Solutions

August 29, 2009 at 10:00:31
You don't need to pay for driver support. Just wait until the first of the week and contact the vendor I linked.

Report •

August 29, 2009 at 10:00:31
Try installing driver max

Its free but you have to register


UK MP's are thieving scumbags.
EU members are worse.

Report •

August 29, 2009 at 10:13:57
It appears your laptop is a Toshiba. Post all and any numbers on the outside and any motherboard numbers or model numbers that SIW or Everest has found.

How did you re-install WinXP. You may not be aware of this but there probably is a hidden restore partition on your hard drive.

When you first boot the laptop there are some text screens that come up. One of those screens should tell you what keystrokes to use to restore to factory specs.

If the screens go by too quickly to read try tapping the Pause key to freeze the screen. Spacebar should start the sscreen again.

Report •

August 29, 2009 at 10:51:24
In Everest Home, look at the devices that are giving you trouble. We're looking for DeviceID and VendorID entries.

Everest Home will also give you a report of what it finds; Report>Quick Report>Plain Text.

Another tool that might help is Unknown Devices...Catfish developed it for his own use and gives it away


Try the Beta 1.4.20 version.

Device and Vendor ID's will lead us to the drivers you need.


Report •

August 29, 2009 at 11:52:28
Restoring from a hidden partition should provide all the necessary drivers plus whatever other software originally came on the computer.

Report •

August 29, 2009 at 13:43:39
skip cox
I can not believe so many folk are there to help - thanks.
below is the file from Unknown Devices (as you suggested from HalfDone)
does it provide what you asked - hope so!
Computer Info
Chipset: Intel i855P
Computer Name: HOME-HDZB054PVC
OS: Microsoft Windows XP (Full or Upgrade Retail)
Product Key...
Device Tree
Other devices
Network Controller
Intel Corporation PRO/Wireless 2200BG Network Connection
PCI Modem
*** Note: AC'97 Detection is unreliable
Intel Corporation 82801DBM AC'97 Modem Controller (ICH4-M B1 step)
Micro-Star International Co Ltd (MSI)
Universal Serial Bus (USB) Controller
Intel Corporation 82801DBM USB 2.0 EHCI Controller (ICH4-M B1 step)
Micro-Star International Co Ltd (MSI)
Video Controller (VGA Compatible)
ATI Technologies Inc Mobility Radeon 9700 (M10 NP) (RV350)
Micro-Star International Co Ltd (MSI)

Report •

August 29, 2009 at 13:46:21
I forgot to clarify that all 4 still have a "?" preceeding each heading in red beginning:
Network Controller
PCI Modem
Video Controller

Report •

August 29, 2009 at 15:40:13
OK, we know more than we did. Maybe. Assuming the info is correct. If it is. Real confidence builder huh?

Intel 855 chipset stuff...


Download #3, Intel Chipset Identification Utility and read the Read Me file. That little piece of software will remove any doubt of exactly which chipset your motherbord uses.

Then download and run #5; again, go through the Read Me and Release Notes.

After you run these on your Compusys, reboot and see if XP detects and install drivers for any of problem devices.


Report •

August 29, 2009 at 17:15:21

First off, go up to # 9 and remove your installation key numbers from that post. Click on the edit icon and you can remove it.

Did you understand what I said in #8?

Report •

August 30, 2009 at 03:03:31
thanks I have removed the numbers as suggested and secondly I am not too sure how to restore from a hidden partition. Is this approach more simple than what Skipfox suggests in #11, because I would favour the easier option!!
thanks again
as an aside I have been tring all manner of downloads (although drivermax comes up with an error to report to Microsoft each time I have tried to install it and it doesn't appear to install completely) but I now have a Intel(R) proset for wireless icon in my tray, but ti doesn't show any components under Network Componenets in the left pane.

Report •

August 30, 2009 at 03:21:12
I have downloaded #3 and the report says:
Intel(r) 855PM chipset
Int Graphics: Not detected or disabled

I will crack on with #5

Report •

August 30, 2009 at 03:28:52
Utility #5 is asking for a 'usbehci.sys' is needed.
tried my XP disc but no joy. can I get it off then ent?

Report •

August 30, 2009 at 06:19:10
I don't know how to perform a restore on your computer but there should be prompts on the screen when you first start the computer to guide you.

Did you get this computer used? If so, it is possible the entire drive has been wiped but that isn't usually the case.

If it can be done, restoring to factory state should be easier than guessing at which drivers you need.

I suppose it is possible to find the Toshiba model by process of elimination but that might take hours of research.

I did find this. Try it and if you are unsure about anything you can always back out.

"Assuming that you have not deleted or corrupted the hidden partitions, you should be able to restore easily...

shut down
hold 0 (zero/NOT TEN KEY)
power on

then the recovery wizard will boot"

Report •

August 30, 2009 at 10:14:12
as per #11 above I have downloaded #3 and #5 (I found a site and downloaded 'usbehci.sys' and it worked) and my previous 4 question marks are down to 3, so success in respect of the USB divers!!
Am I right in thinking I need the drivers for the Network Controller and/or PCI Modem to get the laptop to work in wireless mode?
yes I did get the laptop used and completely restored everything with my XP disc which is why (I assume) I lost some drivers.
Your suggestion of the 'reboot from partition', can I be selective in what I restore (ie the 2 missing drivers) or do I have to restore everything and then possibly loose what I (or should I say we) have achieved?
thanks for your continuing effort

Report •

August 30, 2009 at 10:42:55
If the wizard gets you to restore to factory settings you will have whatever version of Windows originally came on the laptop along with any additional software that was originally bundled with the laptop. Things like Microsoft Works for instance, which is commonly included.

I thought you just re-installed Windows. What is there to lose then?

If you have personal files already on the laptop you would need to back them up first to some external media.

If you want to try and figure out which Toshiba model you have then I can start you in the right direction but I am not going to spend the hours it will take.

The Compusys site has a link to Toshiba for all laptop related issues. That is why I assume the laptop is a Toshiba.

I also assume it is just a re-badged model that was already in production. Compusys probably isn't big enough to customize a model. These are all assumptions and might be wrong.

One thing is probably isn't wrong is that IF there is a restore partition it most assuredly will be the correct drivers. Once that is done you may be able to better determine the Toshiba model, or at the very least determine for sure all the hardware so drivers can be archived for future use.

In addition, if you have a full retail version of WinXP it has worth. You can install it on a different computer or even sell it. If the OEM version of WinXP for the laptop is accessable, why not use IT.

Report •

August 31, 2009 at 21:58:10
Billy, give us an update. You able to contact The link OtH gave or look for a restore partition?


Report •

September 1, 2009 at 13:28:34
I have continued in my quest!
I have not yet restored from a partition as I ihave managed to remove all but 2 yellow '?' i.e. PCI Modem and Video Controller so I think i'm really close.
I managed to download drivers and missing files (by hook and by crook) and the wireless icon appeared in my tray but with a message saying to the effect a regustry setting was wrong. I investigated this thru google and as a result of a simliar question decided to load SP2 which I've just completed.
The icon states speed as 54.0, strenth as excellent BUT status acquiring network address.
I shall continue to try and will let you know how I get on in the mean time, will try google for this message and thanks again for your help!

Report •

September 1, 2009 at 13:33:29
Install SP3. It may have drivers. Certainly more likely.

Report •

September 10, 2009 at 13:34:25
thanks again I finally got everything working, my daughter not giving me the correct password for the router didn't help, but Google told me how to acquire it and now everything works.
thanks again!!

Report •

Ask Question