Microsoft XML Core Services 4.0

January 27, 2009 at 19:08:46
Specs: Windows XP, P4 2.66

I keep getting the update icon on my task bar to install the Security Update for Microsoft XML Core Services 4.0 Service Pack 2 (KB954430). I install it, it says it is installing update 1 of 1) and it shows that it was successful. However, the icon keeps appearing that I need to download it again. Is this Microsoft's way to drive me crazy or is this an update that keeps updating? Will it stop? Please, any help is appreciated.


See More: Microsoft XML Core Services 4.0

Report •

January 29, 2009 at 13:03:22
Hello Veets
I have the same problem, and reinstalled msxl 4.0 sp2 (kb936181), now I'm about to go and reinstall xml core services 4.0 sp2 (kb954430) by entering that in google search as microsoft xml core serv.....etc. the same as I did for the (kb936181) sp2 ?? and see what happens, if it stops the pop up in the taskbar to install (kb954430). I check my add/remove programs and those software files are installed and listed, I guess, and when I check my list of updates from express install(recomendeded) of the micrfst. updates home page etc. (windows updates) it shows that it has been downloaded approx 20 times, but the task bar area keeps telling me to download it. ,what's with this all, have you solved it.. thanks for any help

Report •

January 29, 2009 at 16:30:37
Hi David,

Nope I have not been able to figure it out. I am hoping someone from this form might know what we can do.

Report •

February 28, 2009 at 07:52:48
has anyone found a solution or explination, I tried to make a new post, to gain more exposure but cannot, I am new to this forum


Report •

Related Solutions

March 17, 2009 at 18:00:38

I looked through my archives and I must not have realized that I had posted this question before. How embarrassing! In any event, someone replied and said to read this link from the Microsoft page. Let me know if this works for you. I will try it too!

Report •

March 17, 2009 at 18:21:07

Go to this link:

This is the original message I posted. I tried what one person suggested, what I posted to you, that didn't work. I tried the other suggestion, to remove the update, and then install it again. I restarted the system and within a minute, the update icon appeared again. I ran it, it asked me to restart the system, and so far, the update icon has not appeared. Let me know if this works for you.

Report •

Ask Question