mft errors USB delayed write

Seagate Freeagent go portable external 1...
January 17, 2010 at 18:32:36
Specs: Windows XP
I keep getting $mft errors. When these delayed write errors occur, I noticed my system restore points are all wiped out also. I actually have to re-install sr.sys from my windows cd. It seems when two externals are plugged in simultaneously, I'm practically guaranteed to have a problem. I don't remember that happening in the past, although it's not something I do very often. A brand new Seagate external seems to have started my problems. Once, I was lucky enough to actually have a system restore point to go to, which cleared up my problems for awhile anyway. That points to something in the primary computer, not the externals, do you think? Is using two externals simultaneously a no-no or something? Seems like any given episode of that leaves me with permanent problems. Am I grasping at straws. Thanks in advance. Sue

See More: mft errors USB delayed write

January 18, 2010 at 05:11:24
Coming back to my problem this morning, I tried another suggestion from this forum - and it worked! That is, I plugged one external hd to the back of the computer and one in the front. Will keep my fingers crossed. This is a wonderful forum - thanks. Sue

Report •

January 18, 2010 at 06:35:19
With regard to mft errors, I began getting these when I had some files over 4 GB in size. Per a suggestion from this forum, I got rid of those large files and that eliminated the mft errors for awhile. Or maybe it was just coincidence and the IEEE 1394 thing was the problem all along. Is 4GB a magic number for file size in XP on a 32 bit machine? If so, how would I save an image backup which would be bigger than GB? Thanks, Sue

Report •

January 18, 2010 at 09:43:51
Most external drives come formatted with a FAT32 file system (for compatability with non NT based OS's such as Win98/ME). That being said, FAT32 has a 4 gig file limit size. If you want to write a file larger than 4 gig to your external drive you will need to reformat it with a NTFS file system.

Report •
Related Solutions

Ask Question