Solved Messed up boot loader (XP/Linux dual boot)

January 8, 2013 at 04:57:50
Specs: Windows XP Service Pack 3 and VectorLinux 7, Pentium 4B 2.4GHz + 1GB RAM
Okay, so I'm not sure whether this should go under a Windows or a Linux section, but I figured it's more Windows-related so I'm posting it here.

I was trying to partition a hard drive in Windows XP's disk management, until I realised that XP's built in tool does not let you resize partitions. I have two hard disks, a GB master and 160GB slave, and Windows is installed on the 160GB. I accidentally right clicked the 160GB in disk management and clicked "make active partition" (there was no confirmation when I clicked it, it just did it immediately). I also defragmented the hard drives.

Upon the next boot, I found that it wouldn't start - it said "NTLDR is missing, press CTRL+ALT+DEL to restart). Oddly enough, I inserted the XP installation disk, and when it said "press any key to boot from CD..." I did not press any keys, and I let the "boot from CD" time-out. When it did, it booted into Windows perfectly!

I thought this was just a random error, so I didn't think much of it. I decided to install Linux (VectorLinux 7 SOHO) onto the 40GB partition, and it installed the GRUB boot loader (boot loader that is used by Linux).
However, when I restarted to try the new OS, I still received the "NTLDR is missing" error.
I popped the XP installation disk back into the CD drive, ignored the prompt, and lo and behold, the GRUB boot loader appeared and allowed me to boot into Linux! Except... for some reason, Windows wasn't on the OS list so I could only boot into Linux.

If I have no disk in the drive, I can't boot, because it says "NTLDR is missing"

I really do not know what to do at this point, and I really don't want to have to have the XP disk in the drive just to be able to start my PC.

(TL;DR: "NTLDR is missing" error, even with Linux's GRUB boot loader installed, but works fine with XP disk in the drive during startup.)

See More: Messed up boot loader (XP/Linux dual boot)

Report •

January 8, 2013 at 05:09:06
✔ Best Answer
Check the BIOS to see that it is configured to boot of the drive with Windows installed.

Report •

January 8, 2013 at 05:15:05

Sometimes, it's the simplest solution that you didn't think of that works the best, and when you discover it, you kick yourself :P

Now I just have to find a way to add Windows to the GRUB loader...

(Edit: Misread your answer, it was already set to boot from the drive Windows was on, but the boot loader was on the other drive, whoops. Nevertheless, it worked)

Report •
Related Solutions

Ask Question