KB2251481 won't install

August 26, 2011 at 11:30:19
Specs: Windows XP
I can't get KB2251481 to install via Microsoft or Windows update.

Security Update for Microsoft Visual Studio 2005 Service Pack 1 XML Editor (KB2251481)
Installation Failure
Error Code: 0x66A

I have tried to work with Microsoft technical support for 2 days and they can't figure it out. I have a very, very similar KB getting installed KB2251487. This is the same XML editor problem for 2008 instead of 2005. I have tried to uninstall that to see if it might be an "order" issue. It didn't help, 87 got installed first and then 81 failed again.

I'm not even sure if these are not identical between 2005 and 2008 and so the update is trying to go on top of itself.

Anyone know how to fix this?

See More: KB2251481 wont install

Report •

August 26, 2011 at 18:21:56
error code 0x66a windows update


KB2251481 won't install


Report •

August 31, 2011 at 01:56:58
According to the MS website:

When you try to install this security update (which was re-released August 9, 2011) by using Microsoft Update, you may receive an error code "66a." This error occurs when the following conditions are true:

o You have Microsoft Visual Studio 2005 Service Pack 1 (SP1) and Microsoft Visual Studio 2005 Premier Partner Edition SP1 installed on the computer.

o You have the original security update 2251481 offered by MS11-049 (released in June 2011) successfully installed on the computer.

To resolve this problem, uninstall the original security update 2251481 that was released in June 2011 and then install this security update that was re-released in August 2011. (Updates can be uninstalled by reviewing Installed Updates within Windows Update).

It worked for me!

Report •

September 10, 2011 at 05:13:25

Thanks a lot...

It worked for me..

Report •

Related Solutions

September 21, 2011 at 01:45:47
Hi there,

I have exactly this problem. So I tried to follwo the instructions to delete the original version.

When I iew the "update history", I can see the original patch (installed 07/07) but when I view "Installed Updates" it isn't there.

Is there some manual way to remove the update, or some magical "show me all updates" button I have to push?

Please advise.

Mike McLean

Report •

October 19, 2011 at 14:06:33
Here's a link that shows how to remove this manually:

Report •

Ask Question