Java Crashing Firefox, Update messes up Install

Microsoft Windows xp professional w/serv...
December 26, 2012 at 15:37:31
Specs: Windows XP Pro, 1272 MB RAM
Hey, this is something I noticed just a bit ago. It's kinda gotten tangled, so I'm looking for other help.

I was trying to watch a youtube video, and it kept saying an error had occurred. I checked my java, and it said I had 7 update 9, and that 7 update 10 was available. I tried updating, and I kept getting the message that Java wasn't working.

I had the java platform and toolkit before updating, afterward I only had the toolkit.

I tried reinstalling Java several times. I never got the platform back, no matter how many times I tried. I eventually restored the computer to just before I tried updating, and I have the platform and toolkit both installed again. The add-ons manager says Java Deployment Toolkit and Java (TM) Platform SE 7 U9

Now, when I try and test the current version on Java - I go to the verify page, it says there's a newer version, and I click 'test the current version' - Firefox closes. No crash report, just gone. I also cannot open the Java control center in the control panel.

I did have a virus recently, but I cleaned it up. I have noticed that some things, like Autorun, are working strangely afterward - but I had youtube working a few days ago, so I assume Java was as well.

Youtube is working again, btw. As if nothing ever happened. It's taunting me.

Does anyone have any idea what could be going on?

See More: Java Crashing Firefox, Update messes up Install

Report •

December 26, 2012 at 16:02:14
Try downloading JavaRA removal tool before trying to update. It will remove any old Java's and cleans up leftovers, etc.

Please reply and let us know if our help worked. Your feedback helps others. Maybe you?

Report •

December 27, 2012 at 10:09:43
I will give that a try when I have the time to sit at the computer and try installing Java again. Something I noticed today that seemed odd - well, two things, actually - that I wondered about and thought should be mentioned.

In the event viewer, there was an error message from yesterday's startup (the restore) that Java Quick Starter Service terminated under Services. Under Applications, it said that "The following information is part of the event: Unable to open C:\Program Files\Java\jre7\lib\deploy\jqs\jqs.conf: No such file or directory".

While my antivirus was scanning, I noticed it was scanning Java(2). I looked in C:\Program Files and found Java and Java(2). The Java(2) folder is larger than the Java folder, with more different files in it. (I copied the file that the error in event viewer said couldn't be found - jqs.conf - from Java(2) to the proper Java folder.)

Could the fact that there is a Java and Java(2) folder could have anything to do with all this? Why would there be a Java and Java(2)?

Also, would it work if I just uninstalled it with the Control Panel Add/Remove Programs?

EDIT: I can't edit my ren'py script anymore. I think it needs javascript to run. So...Java is apparently running in my firefox, but the current install doesn't seem to be working on the computer.

Report •

December 27, 2012 at 13:05:55
Firefox was having problems with some flash updates which were causing video to error out on youtube etc.

Report •

Related Solutions

December 28, 2012 at 09:59:53
I did as you said, but I still only have the toolkit in Firefox - no Platform. So Java still isn't installed properly. I downloaded the version I installed from here: In the Program Files, I saw a JRE folder that I moved as well as Java(2) - now there is only a Java folder.

The renpy is working again, but the Verify Java page says "Something went wrong. Java isn't working."

Any suggestions?

EDIT: I uninstalled 7.10 and installed 7.9, and the platform's back and renpy's working again. I guess something on here doesn't like 7.10.

Report •

Ask Question