Installshield Setup error

November 19, 2009 at 11:14:41
Specs: Windows XP Pro
The DVD drive is not working properly, and it APPEARS to be related to an error with Windows Installer. I can read files on a storage disk in the drive, but any install disk brings up "InstallShield Setup Launcher has encountered a problem and needs to close."

Windows XP SP3
CPU 2.93 GHz

I have done the following with no effect:
- Run Windows Install cleanup
- Downloaded and installed Windows Installer 4.5
- Made sure the Installer Service is set to Automatic
- Scanned with AVG, Superantispyware, Spybot, and Advanced System Optimizer
- Unregistered, then registered the Windows Installer Service
- Made sure all Windows updates are updated

This may provide a clue, however, if it's related. When running Windows Update, the Microsoft .NET Framework 2.0 SP2 and 3.5 SP1 and 3.5 Family Update will not install.

See More: Installshield Setup error

Report •

November 19, 2009 at 11:22:50
You need to run the .NET cleanup tool to remove the old .NET frame work. Then run the Windows Autoupdates and it will reinstall all the .NETs.

Report •

November 19, 2009 at 16:10:20
So does it seem that fixing the NET install problem may take care of the Installshield problem as well?

Report •

November 23, 2009 at 16:28:27
I ran the NET framework cleanup tool.

I turned off Teatimer and all antispyware and rebooted.

Using Windows Update, I first tried the Net Framework 1.1 Service Pack, but received this message:

Net Framework 1.1 Service Pack:
Application has generated an exception that could not be handled.
Process id=0x7c8(3192), Thread id=0xc88(3196).
Click OK to terminate, Click Cancel to debug the application.
[pressed cancel]
Registered JIT debugger is not available. An attempt to launch a JIT debugger with the following command resulted in an error code of 0x2(2). Please check computer settings.
cordbg.exe !a 0x7c8

Then I tried the 3.5 Service Pack. It downloaded, installation was initialized, and then I got the "Installing Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86" message.

But the process just hung at that point. After half an hour opf nothing happening, I canceled the program.

I've tried this whole process twice now with the same results.

Report •

Related Solutions

Ask Question