HP m7680n powers on, no picture

Hewlett-packard Hp pavilion media center...
April 25, 2011 at 00:58:12
Specs: Windows XP media center, Intel Core 2 Duo E6400
Powering on, HDD light usually blinks but doesn't. DVD ok, Fan blows. No display.
No diagnostics lights on back of case. Sata drive, Raid 0 ? Thinking power supply to mother board or one of the hard drives gone bad. Please advise.

See More: HP m7680n powers on, no picture

Report •

#1
April 27, 2011 at 04:24:31
You need to isolate the problem.

Start by trying another monitor.


Report •

#2
April 27, 2011 at 21:02:20
Yes, the monitor works fine with another pc hooked up.

Report •

#3
April 27, 2011 at 21:13:39
I also disconnected and reconnected power cords to motherboard, Sata drive, DVD drive. Re-seated all memory cards, Video card, and others except processor.

Report •

Related Solutions

#4
April 27, 2011 at 21:17:48
I'm going to try and find someone who could lend me a PCIE video card to test if mine is bad. But finding it difficult.

Report •

#5
April 27, 2011 at 22:17:26
If you can get your hands on another HD with W95 or W98 or Linux on, you can test your theory about the HD.

Report •

#6
April 27, 2011 at 23:18:40
I have extra Hard drives but not SATA. Maybe I'll try booting with restore disk?

Report •

#7
April 27, 2011 at 23:26:32
"I have extra Hard drives but not SATA. Maybe I'll try booting with restore disk?"

They don't have to be, disconnect the sata drive, use a cable for the IDE drive & plug it into the MB. If you don't have a spare MB IDE socket, use the CD rom socket.


Report •

#8
April 27, 2011 at 23:42:33
You have got the socket for an old HD, no need to bolt it in, just cable & stand on it's end inside the case.

http://h10032.www1.hp.com/ctg/Manua...


Report •

Ask Question