How do I repair my XP installation

Custom / CUSTOM
February 1, 2009 at 08:55:50
Specs: Microsoft Windows XP Professional, 3.001 GHz / 3070 MB
I read and replied in the recent post by vladimir and his troubles. I had something similar and was disappointed that he never shared his findings.

My problem started when I scheduled a boot-time defrag of system files. It blue screened as soon as I saw that the defrag began. I couldn't get it to boot again normally or safe mode. I did get the OS version selection screen. In safe mode, it would get somewhere beyond Mup.sys.

I tried to get a REPAIR option when booting from my retail XP Pro SP2, but I never got that as an option. It did see the hard drive, but it seemed that it didn't recognize the XP installation that needed repairing.

Thinking that I would have to have a SP3 install disk, I made a slipstream SP3 version with nLite.

As a side note, I only have XP Pro installed. I added a switch in the boot.ini to enable some kind of recovery console. When I tried that, just to see what it would do, it prompted me that it couldn't load windows, because HAL.DLL was missing. I never pursued that, because the system worked pretty well, although it would sometimes take a few resets (hard and soft resets) to get it to restart, but not always. I was thinking that the Recovery Console might find something. I gave that up and just continued using it.

Now, back to my problem at hand. I cloned the hard drive with DriveImage XML, so that I would have a setup to 'play' with. Using the clone, I just went through a normal XP install. It booted up and started to look like a normal Clean Install. However, it in fact did see the prior XP install and added a Windows.0 directory. So now when I reboot, I have more choices in the Boot Screen.

On a whim, I tried the previously broken install, and viola it booted normally. There are a few things that seemed odd, but it did boot up. Norton Internet Security was not happy about something. I was not able to get it to reopen once I closed it. I got some pop up that makes me think that a file got reset and I'll have to reinstall Norton. And Windows installed two updates when I was shutting down.

That was all last night. So here I am wondering what to try next. Something makes me think I can still resurrect my original hard drive and use it as normal.

I'm also thinking that I should just use it long enough to properly backup my data and do another clean install. But I would really like to know what's going on.

See More: How do I repair my XP installation

Report •

February 1, 2009 at 09:03:50
I read and replied in the recent post by vladimir and his troubles. I had something similar and was disappointed that he never shared his findings.

Which post?


Report •

February 1, 2009 at 09:45:19
The post I referred to is titled Can't Repair Install Windows XP by Vladimir88

I didn't change hardware as he did, but I seem to have a similar trouble.

Thanks for replying.

Report •

February 1, 2009 at 10:32:50
Copy and paste the URL for the post you refer to.

Report •

Related Solutions

February 1, 2009 at 10:40:07

Report •

February 3, 2009 at 18:51:44
I'm a bit disappointed that the two replies that I got, asking me about the post which I mentioned, were never followed up on. I answered their replies but I guess they forgot about checking back for the answers. And maybe they had no clue how to help me.

Through much trial and error and cloning the Hard drive in between different attempts, I now have it booting just fine.

Here's my solution to not being able to boot, nor get a repair option, after a BSOD during a Boot Time Defrag. I moved the Boot Drive off of the Marvel SATA "orange" connector and placed it in the SATA connectors that I have my RAID plugged into. The Raid works on four connectors and the Boot drive uses one of the open spots.

I was able to boot into Safe Mode and Restore back to before I installed the defrag program. I suppose I would have been able to keep it and just turn off the Boot Time scheduler, but I will simply find a better/safer Defrag program.

Maybe there is something defective, or just flakey, with the orange and white SATA connectors on my MB. I'm happy that my machine is stable again.

My Motherboard is an ASUS P5Q Pro. CPU is Q6600 quad 2.4GHz. XP Pro and 4Gig installed RAM. WD 75 Gig Raptor Boot Drive.

Report •

February 8, 2009 at 20:11:20
Well, now that several days has passed by, I have learned more. I seem to have had several issues with my configuration. It seems that I have been using the wrong memory. I had thought I bought the correct OCZ Reaper memory, but I got 4 pieces of 1 Gig. I was supposed to get the 2 pieces of 2 Gig. That will be fixed shortly.

The other problem still relates to the Marvel Orange and White SATA connectors. I found that I have trouble booting while my SONY DVD is connected to the EIDE connector, which is part of the Marvel setup.

I will try my SATA DVD connected to one of the free Red SATA connectors. And then see what happens when I use the white one.

If I keep having trouble I will have to get a RAID card or a new motherboard. Just not another ASUS. They are very picky about memory.

Report •

February 8, 2009 at 20:32:11
Why don't you read the manual to figure out how to connect your drives.

Report •

February 9, 2009 at 15:42:24
Hi, Thanks for your advise. Not only is it thoughtful, it's also what I did when I set it up months ago and was using for months.

Let me explain, I have an ASUS P5Q Pro motherboard. As per the manual, I can use the Orange and White SATA connectors in one of three configurations. I chose the 'Normal" mode and connected my boot drive to the Orange connector. My Sony DVD drive was connected to the 40-pin EIDE connector.

All was going quite well for a few months, until I installed a Defrag utility and did a Boot-Time defrag.

Then I couldn't boot again as detailed throughout this post. I keep adding feedback here, in the chance that someone might find ideas, or even a solution to their own problem.

As of this moment, I haven't tried the new DVD drive, so I'm just using the machine without any DVD drive. Perhaps my Sony drive is flakey now. I don't know yet.

But, I do believe that my initial problem was due to using 1 Gig sticks and not the 2 Gig sticks as spelled out in the manual. I was thinking 2 Gig Kits.

Bottom line is that I had my drives connected just fine. It's the memory spec that I misread.

Report •

February 9, 2009 at 18:00:40
The 1GB or 2GB RAM sticks shouldn't have anything to do with your problem. You just stated that you ran some third party defrag and after that you had problems.

Try performing a system restore to a date before the defrag.

Go Start> Help and Support> System restore.

If for some reason the restore point you choose doesn't cure the problem UNDO that restore point before trying a different one.

Report •

February 9, 2009 at 18:41:02
If I wasn't familiar with ASUS' common problem about many of their motherboards being picky about memory, I would tend to agree. When I first built this system, I started with two sticks and it wouldn't POST correctly using the rated memory speed. The manual showed that I had to populate all 4 slots with the OCZ Reaper memory. So I got 2 more. Life was good and my memory was running at 1066MHz.

In the past few months, I had not crashed or BSOD. I did have a failure to re-boot once or twice. But it would after I did a cold boot, so I didn't really think much about it.

After the Boot Time Defrag BSOD, I couldn't boot in any mode, so I couldn't Restore. Then, I moved the SATA to the Intel ICH10R controlled connectors, and removed my RAID drives. I found some limited success by something wasn't right.

Through installing XP on spare Hard Drives, I started seeing problems when I tried to use the Marvel controlled SATA connectors.

I read an awful lot in the ASUS forum for my board model. There I saw a something that made me second guess my memory. When I look at the QVL on the website, I saw some changes that weren't in my manual. Then I saw that I actually used the wrong memory.

Saying that, I will say that my system was rather stable with the wrong size memory. But only when I ran it at 667MHz.

So, I put the original Hard Drive back in and used a supported 800MHz memory pair and it booted up fine. multiple times it booted. And I did restore to before I installed that Defrag program.

Now, I plugged everything back together and closed the case. Then it failed to boot. The only thing that was different from when it was lying on it's side and covers off, was the DVD drive. So, I unplugged it and it boots just fine.

The root cause and eventual solution of all this is really frustrating. I don't understand why my system didn't crash before. But it is stable now that the memory is a qualified brand.

At my company, I have a co-worker that has an ASUS Rampage Formula. His machine will BSOD if he tried to use any energy saving feature. It is because they installed memory that is not on the Qualified list for that MB.

I have used ASUS for many years and have been bitten by the memory problems in the past. But, I thought I had used the correct memory so I didn't even consider that as a driving factor at all.

But all the additional troubles as to not being able to do a repair and all the rest. It's crazy.

I just ordered another motherboard for a different system. This time, it's an EVGA!

Report •

February 10, 2009 at 05:08:35
just to add
re: XP install and added a Windows.0 directory. So now when I reboot, I have more choices in the Boot Screen.

simply you have installed a second xp rather than repaired the existing one.

If your now stuck with two folders c:\windows & c:\windows:0 folders

a full format and install sorts that out.
I have yet to find a satisfactory method of removing the prior install.

if you only want to boot from one install
& i would use the working windows:0 version

edit the boot.ini file,

back up a copy first its a hidden file on c:
in win explorer make sure view hidden files is selected, then back up somwhere safe.
start\controlpanl\system\advanced\startup&recovery\settings, press edit
edit out the version you dont want leaving thus:

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS.0="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

save n reboot , you will only have one version booting.
If thats the wrong one replace with your original back up.

if that seems too rash, you can try a second method; start\run msconfig
boot.ini tab , click too high lite relevant under [operating system] you want to boot from set as default.

why xp repair option is somtimes hard to find is a secret of m$ ive seen it and been there my self, some xp disks pcs work fine, & as thats my boot.ini above you can see i couldnt find it either, way back then.
i now just clean reinstall full.

heres a familiar web link for some reading

Report •

February 10, 2009 at 18:19:21
Thanks for the reply, it's full of good advice. What is now lost throughout this thread, is that I made a copy of my orginal hard drive and started working from the copy. I got the Windows.0 when I just plodded on and did an install hoping that I would have gotten a Repair option.

Then, I just started doing clean installs onto a third hard drive. There was always some kind of glitch/problem.

Through trials, errors, and much reading, I finally came up with the fact that I got the wrong memory when I built this system. I just don't understand why it worked so well for a few months and then just became a stubborn mule and refused to boot.

As to the Repair option. I did just learn something new. My Retail Windows disk is with SP1 and that can not work a repair with SP3. Even a slipstreamed SP3 wouldn't work. When I installed a clean fresh setup, I did see the Repair option, but that was before any service packs were applied.

So, once I changed my memory to a pair that's on the ASUS Qualified Vendor List for this motherboard, I put the original Hard drive back in the case. It is boot in just fine. But I can not have my Sony DVD drive connected at the same time. It wasn't a problem before, but I don't want to spend any time trying to figure out why it is now. I will try to connect a SATA DVD and see how that goes.

Report •

Ask Question