How do I reformat the HDD on IBM ThinkPad T41?

July 26, 2015 at 12:06:12
Specs: Windows 7
The OS on my Thinkpad became corrupt after a power surge and I want to erase the HDD and reload the OS. Unfortunately, the simple instructions I found, fail after the computer boots from the windows dvd. It says to boot from disk then press esc to enter the ms-dos command prompt. It refused. Went i boot from the dvd, it goes to partition magic, ghost, floppy startup disk or press q to command prompt. The command prompt option does not accept any commands given and the partition magic I do not know what to do to get it to format the disk. The windows disk is now not being recognized. Can someone give me step by step instructions to clearing the HDD and reinstalling windows xp?

See More: How do I reformat the HDD on IBM ThinkPad T41?

July 26, 2015 at 13:29:29
Before going "any" further... Is there anything on the hard drive that you would like to recover/save?

Report •

July 26, 2015 at 15:16:43
Your specs say Win7 but you're posting in the XP forum. XP was available on a CD, not DVD. The fact that you mentioned DVD & your boot options are "partition magic, ghost" tells me that it's not an original Microsoft disc. Also, if you have a SATA HDD, XP will not recognize the HDD unless the SATA drivers are loaded 1st. Either that or enter the BIOS & change the HDD setting to IDE mode.

Report •

July 26, 2015 at 15:47:04
The 'power surge' may have damaged the drive and not just its contents.

Normally when using a regular installation disk you can delete the existing partition and let a new one be created and formatted as part of the installation process. You don't need a third party disk or format the drive as a separate process.

Report •

Related Solutions

July 26, 2015 at 17:19:09
an error on my part. The computer will not take the win7 because the CPU is not designed for 64x software. The laptop has all its original components. No sata. I did run diagnostics on the hardware and the computer says the hardware is working...

Report •

July 26, 2015 at 17:20:07
There is nothing on the HDD that is to be saved, it was all just anti virus and browser programs, easily replaced.

Report •

July 26, 2015 at 23:42:03
Then you should be able to boot from the XP installation disk and do the install. Basically you just start the installation. It'll ask where to install windows and show the existing partitions and any unallocated space. At that point you can delete the partition containing the previous installation and then tell it to install in a new partition it then recreates in the now unallocated space.

If you need additional help there are approximately an infinite number of tutorials on the internet about how to install windows xp. Here's one:

and another:

The good thing is, if you make a mistake you can always start over since you're not worried about saving any files.

Report •

July 27, 2015 at 04:39:09
yes, but this computer is no responding the way it should. I've done this before on many computers but this one is not doing what the others have. It is giving me the message that it does not recognize the XP set up disk any longer and the only thing I get is the menu for magic partition (which I have no idea what to do with it),ghost and exit to command prompt. When i try command prompt, it does not recognize any of the commands used on other computers to reinstall the OS. It is very frustrating.

Report •

July 27, 2015 at 05:40:15
The mention of Partition Magic... Was that in use previously? That you get a menu listing it and other items would seem to suggest there "is" a boot-manger utility installed (PM for example).

When you install utilities like that they "take over" the boot process; they rewrite/modify the mbr. If you have a dos style boot disk; including win-98 or ME one... boot up with it and type:

fdisk /mbr

- and then press enter. this will disable PM's control of the boot process (if that's what happening).

If you haven't got one... they can be downloaded...

Ensure (in the bios) that you have the boot order as: floppy, CD/DVD, then hard drive.

This link details various approaches to resetting the mbr and enabling XP (and win7, 8x) setup.

Ensure that your boot sequence "is" floppy then CD/DVD (even if "not" using the '98/ME boot floppy to reset mbr).

Report •

July 27, 2015 at 07:55:18
Yes, a menu comes up after the message Click any key to boot from CD/DVD. I explored the disk and it is included along with the WinXP, but I have never had this problem before.
i do not have a dos style boot up disk.
I have confirmed in bios that the cd is the top of the boot order. Floppy first? This laptop does not even have a floppy disk device...

Report •

July 27, 2015 at 08:13:11
I went back in, floppy is listed first on the boot up. I went back in, selected PM and then quit, it sent me to what I presume is dos-command prompt. I typed in fdisk and got an error message- "Error reading system area- can't continue"
Despite the system stating the hardware was operating normally, could this indicate the HDD has in fact been damaged and needs to be replaced or is the system area data so corrupted that the system can't read it? If the data is corrupted, can this be fixed without replacing the HDD?

Report •

July 27, 2015 at 11:54:18
You can't run Fdisk from a hard drive; it's run either from a suitable boot disk, or in the case of earlier windows - 9x/ME (and I think XP as well) you can get to command prompt via the setup CD.

Something to try - as it will in effect test the system out more or less fully; not the least the hard drive.

Boot with Linux CD/DVD. Ubuntu is one of the more common variants and another is puppylinux - free ISO - which download and burn the DVD - not a CD (CD is too small capacity).

Boot up with the DVD; it will load Linux into RAM only - not the nard drive (unless you tell it to - which do NOT).

Once booted to the desktop you ought to be able to locate the hard drive; and thus inspect its contents... If you can' even see the drive... There may be "sumat amiss" with it. I'm not sold yet on the idea that power surge took out the hard drive; usually it's the power supply andor RAM/CPU that go down (in my limited experience).

The OS itself might become cotrupted; but usually one can get into its boot-menu...

The mention of Partition Magic does complicate things; as you don't say how PM arrived or if tt was being used? Al the signs thus far are that it "was" controlling the boot process - which is why you can't get anywhere with a windows installation. One has usually to disable its control of the mbr (via Fdisk /mbr routine),. Also there were known issues with some flavours of PM and XP; the two didn't get along very well - and more than a few XP systems had problems with it.

Another angle to consider - and this may be easier? Use the Ultimate Boot CD:

It allows many operations normally associated with a floppy... It has (scroll down the list) - an mbr tool - which likely will do what Fdisk /mbr does...

I haven't really used this disk other than to explore its contents; and that was age ago - likely about the time that XP arrived... But it is well recognised and safe to use utility.

If the data is corrupted, can this be fixed without replacing the HDD?

Earlier (#5) you stated that there was no data etc. on the drive that needed to be recovered/saved? Is this not so - now? If there is "stuff" on the drive you'd like to recover... then the Ubuntu boot up ought to allow it - providing the drive can be accessed OK (and the data "isn't" corrupted).

Report •

July 27, 2015 at 12:08:57
Still nothing on the drive so I have no problem losing what ever is on it. I don't think the surge knocked out the drive, I think, after receiving that error message, that the surge may have corrupted the software... but still, I can't get the set to engage... do you think making a copy of the disk leaving out the boot PM and boot Ghost options might work? My properly running desktop can make the copies.

Report •

July 27, 2015 at 14:48:37
Where are you getting PM and Ghost from? All you need is an XP setup disk - bog standard OEM or Retail depending on the type of "key" you have from the failed system?

So... since you have a legitimate windows XP "key" - whichever type it is... - you can download an ISO for it; burn to DVD; boot with that DVD? Or you can borrow a disk from a friend who has one that matches the type of "key" you have. Make a copy (it's OK to do so) but use your key when you install XP and set up asks for a "key".

You can download an ISO for XP Home here:

Read the info carefully and get the version you had installed previously; 32 or 64 bit; likely 32bit.

And another:

I can't vouch for he above download links/sites... There used to be a couple of "genuine" M$ approved(?) sites -DigitalRiver being one;but they appear to have disappeared?

But this post (an olde one from CN) has two links that appear to be active (still). Check the first response by riider:

XP disks are also available on the eBay and Amazon(?) and at computer fairs/clearance houses for almost pennies?

The key if OEM can only be used with an OEM disk; Retail only with a Retail disk. OEM keys "usually" have the letters OEM included...

message edited by trvlr

Report •

July 27, 2015 at 16:45:24
Describe the disk(s) you're booting from. Backup disks may have been created with ghost and might include PM. The regular XP installation disk won't have either. If by chance you're booting from a restore partition (and don't realize it) it too may use ghost.

The "Error reading system area" is I think an fdisk message which means it's talking about a problem with the hard drive and it means you're not using an XP installation disk as it doesn't use fdisk.

Report •

July 27, 2015 at 17:22:40
A friend, who is an authorized software seller, traded me the disk with WinXP for some custom artwork. For some reason he placed the other material on the set up disk which as you say, is interfering with the set up of the OS. Again, I never had this problem before loading WINXP on any of my computers. Could the fact that the person who gave me the laptop, had the linux or what ever it is as the laptop's OS?

Report •

July 27, 2015 at 20:55:39
I doubt that linux possibly being on the computer that created the disk you're using (if that's what you're asking) would be a factor. It just matters what software was put on the disk and whether it runs on its own.

My guess is there's a problem with the hard drive because what you've been able to run would seem to indicate that. But it's hard to know for sure because we don't know what you've got on the disk. As Trvlr mentions, you can download a cd image and create a pure XP disk and give that a try. At least that way we might understand any error messages you may get during installation.

Report •

July 28, 2015 at 07:14:26
Now the computer reports there is no OS system on the disk and when I typed in fdisk, it stated the function requires a fixed disk. I think I managed to get the PM out of the way, and now a new problem... like i said, this laptop is not responding the way it should... all software related.

Report •

July 28, 2015 at 08:32:02
Have you tried booting with a linux (DVD - ubuntu etc.)?

Equally via the Ultimate boot disk?

If neither of the above utilities can find the hard drive... double check it's still be recognised at least in the bios; in fact perhaps do that first? Also ensure boot order is still HD last, floppy and CD before it in boot device order.

If you have another windows set up disk - be it win-7 or even win-8... - you ought to be able to boot with that - and reformat the hard drive at least... In effect start an installation and then abort it after it's formatted? Then try the XP "setup" disk (or whatever it is you have) to load XP again? The drive will have been formatted by win-7/8 setup as ntfs by default; the mbr wil have been reset to a windows variant. XP setup will simply overwrite the win-7/8 one.

How did you get PM out of the way?

Report •

July 28, 2015 at 10:18:13
You shouldn't be running fdisk. Specs for a T41 say the hard drive was no larger than 60 gig so fdisk will see it OK but can only describe FAT and FAT32 partitions on the drive. Windows XP usually came on NTFS partitions but can run on FAT32. XP doesn't even support fdisk. It uses diskpart instead:

But since fdisk is running I'm thinking you have a disk meant for earlier versions of windows like 98 or ME that used the fdisk command.

XP uses the format command but you'd need the XP version and not an earlier one in order to format an NTFS partition:

(If you're not familiar, fdisk and diskpart create and manipulate partitions on the hard drive. FORMAT prepares an existing partition so an OS can be installed on it.)

I still think your best bet is to download an XP cd image file and create the disk or procure one in some other way rather than continue using the disk you have.

Report •

July 28, 2015 at 13:49:31
Thank you all for your suggestions, they resulted in the computer actually guiding me to reload the factory defaults. With all that reloaded, the machine then asked me to install the WINXP set up disk. Everything was going well until it reached the INSTALLING WINDOWS stage and the status bar said there was 35 minutes to completion but it stopped. What do I do to get it to continue the set up?

Report •

July 28, 2015 at 17:49:03
That's not unusual. Just let it run. Sometimes it takes awhile...

Report •

July 29, 2015 at 05:26:40
I've never had it stall before, it has been well over 2 and a half hours. I was forced to shut it down when a thunderstorm came through. When i started it back up, it picked up installation. Everything good now.

On a separate note, same machine... I am trying to download anti virus software, but the wireless connect keeps cutting out...Is there anything I can check to stop that from happening.. oh and thank you all for your help.

Report •

July 29, 2015 at 07:01:12
If you have the option - connect via ethernet/cat-5 for downloads...

How strong is the wifi signal where the computer is situated?

Have you tried rebooting the router?

Incidentally I have had occasions when XP setup apparently "stalls" for a long time; and after a reboot/restart etc. it continues and finishes the setup

message edited by trvlr

Report •

July 29, 2015 at 13:23:41
No, I have not tried to reboot the router, do I hit the wireless on/off button or turn it off? The signal strength is excellent, considering the router is next to me on my computer desk. I was going to connect the ethernet connection from my Pc to the lap top to finish downloading.

Report •

July 29, 2015 at 13:35:08
Literally switch/power it off. Wait about a minute or so the power up again.

Often resolves intermittent connections...

Incidentally if the router is nearby - when the wifi "drops" check to see if the incoming dsl service indicator (LED?) is still showing it's there?

Equally if you were to connect via cat-5/ethernet would you experience similar "drop outs" in the connection (to the internet)?

Report •

August 7, 2015 at 11:24:12
Now that I found the router was failing, I came up with a new problem trying to install something I've never had difficulty installing. Yahoo Instant messenger. I down load it and try to install but I get a firewall message. I go to firewall exceptions, browse the downloads and added YIM to the exceptions. Then it says there is a problem downloading the needed files. Any suggestions to what could be causing the problem?

Report •

August 7, 2015 at 13:15:18
Perhaps initially download Yahoo messenger again. I have found in the past that occasionally downloads for it seem to be corrupted...

Yahoo doesn't seem as keen these days in supporting their product line - not the least messenger; and yahoo mail support is now in third-party (private) hands - and thus support pretty well no longer free.

Clear cookies and History too in your browser before downloading yahoo again.

Report •

August 7, 2015 at 15:49:28
I have tried to download it multiple times and delete the ones downloaded. I shall try to erase the cookies and history and see what happens. I 'll let you know.

Report •

Ask Question