Solved HD is Hitachi 500GB. WinXP only shows it at 76.6GB.

Ecs / 945gz/ct-m
June 24, 2012 at 18:20:20
Specs: Windows XP, 1.795 GHz / 2039 MB
My system is not recognizing my correct HD size. How can I correct this? Years ago, I bought a 500GB hd. I transferred ALL info onto it from an older 80GB hd. I just ran out of HD space!!! It seems I did something wrong when I made the 500GB hd my Drive C:\ ... system is not "seeing" the true size of the 500gb hd. How can I fix this so I can use the 400+GB that the system does not now recognize?

Thanks much,

See More: HD is Hitachi 500GB. WinXP only shows it at 76.6GB.

Report •

June 24, 2012 at 18:34:57
✔ Best Answer
The hard drive manufacturer's size is always a bogus decimal size. E.g. 1 gb = 1,000,000,000 bytes.

The mboard's bios and the operating system detect the size of the drive as it's binary size. E.g. 1 gb = 1,073,741,824 bytes

A ~ 82.5 gb manufacturer's size = ~ 76.6 gb binary size.

Your problem is the size of the ~ 500 gb drive is being seen as something much smaller than what the binary size should be.

Go to Disk Management.
E.g. Start - Run - type: diskmgmt.msc , press Enter

If the total size of the drive is seen as ~ 464 gb, you have a large amount of un-allocated space on the hard drive.

You can use a third party program to increase the size of the partition Windows was installed on without losing the data that's already on the partition. (You can't do that with XP itself without losing all the data on the partition.) .
E.g. The freeware Easeus Partition Master Home Edition, however, there must be enough free space on the partition Windows was installed on to install it and run it.

(Actually it's NOT a good idea to have only one partition on the only hard drive connected to the computer.
How to make more than one partition on a hard drive
See Response 3: )

If the total size of the drive is seen as ~ 76.7 gb, it's seen as the same size in the mboard's bios .......

If you cloned the contents of a brand name system drive to the 500mb drive, here's you how fix that problem.

Your problem is caused by the HPA on the original drive.

The destination drive is either re-configured so it's detected as the same manufacturer's / binary size as the original drive, or the same size as the maximum manufacturer's / binary size your brand name model could have come with originally.

See this...

1710: HPA Makes the Cloned Drive Display Wrong Capacity

I have seen this problem problem before in several topics on this web site, most regarding Dell computers, once for an Acer computer

I just fixed a ~120 gb manufacturer's size drive that was being seen as a 34.5 gb binary size drive yesterday. That was my first time I had encountered the problem. The hard drive was in a computer someone had discarded that I had rescued from the trash for it's parts.

To go along with the above article....

Hitachi's Feature Tool is now here:
Support - Downloads- HDST and Simpltech legacy product drivers and downloads -

Feature Tool User's Guide is a PDF - right click on the link to download it.

The article assumes you don't have a computer with a floppy drive.
If it does have a floppy drive, the diskette creator download produces the same result as the bootable CD image.

After you have set the hard drive to it's max manufacturer's size,
- you may not need to do the rest of the procedure at the article above. Try the drive as is. If Windows loads fine, you don't need to do the rest of the prodeure - if it doesn't, you need to do it.
- you will need to use a program to use the now visible in Disk Manager un-allocated space that can do that without losing the data presently on the drive, such as Easeus Partition Master Home Edition. See above.

Report •

June 25, 2012 at 06:57:21

Googling is quicker than waiting for an answer....

Report •

June 25, 2012 at 10:29:10
Sounds like you cloned the 80gig drive to the 500 but never expanded to use the entire disk..

Jolicloud's link will let you use Easus to expand the existing partition.

Make sure you back up your data first!

Answers are only as good as the information you provide.
How to properly post a question:
Sorry no tech support via PM's

Report •

Related Solutions

June 26, 2012 at 17:44:54
All of you had great answers. naturally, I followed the advice of Answer #1...what an easy, easy fix! Thanks to all 3: Tubesandwires, Jolicloud, and wanderer for your time and information. May every good thing meet you on your ways.

Thanks much,

Report •

June 26, 2012 at 18:36:20
We're glad to hear that you solved your problem

Thanks for the thanks.

What was your situation in Disk Management ?

....the total size of the drive is seen as ~ 464 gb
.... the total size of the drive is seen as ~ 76.7 gb

Report •

Ask Question