Freecom Mobile HDD not recognised

August 8, 2009 at 03:31:26
Specs: Win XP, P3/128mb
Hi All,

I have a problem with a Freecom portable HDD. I will start from scratch with what happened.

I have my own Freecom Tough drive 320 GB. I borrowed my friends Freecom portable HDD XXS. I plugged his in to my pc at work and it recognised with no problems at all. I could use it as normal. I then plugged my portable tough drive into the other usb port and my HDD password software conflicted with my friends HDD. Every time I plug my friends HDD in I need to put in MY password. I then did the following.

1) Backed everything up
2) Formatted my friends portable HDD to FAT32 which was what it was on before.

After the whole process had been completed I then plugged it into another laptop (my Personal Laptop with no password software loaded on) and it will NOT show up in MY COMPUTER. It will however show up in safely remove hardware option at the bottom of the screen. I have read a few posts and have had a look at the disc management but nothing shows up.

Can anyone advice me on what I can do get life back into the HDD. Could there still be password software stored on it which is stopping me from running it.

Any help would be great.
Cheers Grant

See More: Freecom Mobile HDD not recognised

Report •

August 9, 2009 at 02:41:03
g.burrows, suspect you're fighting a recognition problem.
Computers are EXTREMELY literal. Things MUST be precisely where they're supposed to be and EXACTLY as anticipated. You've swapped drives around AND reformatted a drive (suspect it's now foreign to your machine).
My guess is that you need to keep it on just one port and reinstall the formatted drive so it'll be recognized.
Ed in Texas.

Report •

August 9, 2009 at 05:22:12
mmm - usb devices aren't usually tied to a given usb port...?

Meanwhile have a look-see at these, as the may help you resolve it...?

Report •

August 9, 2009 at 11:51:52
Hi, thanks for the replies. The USB ports are working fine as i use my 16gb mem stick in all usb ports regular and they are working fine.

I tried using the portable HDD in another laptop and it still doesn't work. The problem defo lies with the portable HDD and is conflicting with the password software that must still be inbedded in the registry.

I am taking a gues at the registry part so do you think that sounds logic?

cheers Grant

Report •

Related Solutions

August 29, 2009 at 15:13:35

Did you get to the bottom of this as I think that problem I am having is the same. I haven't been using any password software though. I received the xxs drive as a gift last year and never really needed to use it untill now. I remember trying it last year on my linux netbook (no longer with us) and it worked fine. Now when i plug it into my work laptop (XP) it recognises the drive in the safely remove icon and device manager but doesnt show up in 'my computer'. Any Ideas would be great as I think I may have a brick.



Report •

August 29, 2009 at 21:06:26
Hi Rob, No I didn't. Due to it being a borrowed drive from my friend I had to replace it with a new one. When I plugged the new one into my pc it worked no problem. The issues that we are having lies within the HDD and not the pc.

I have still got the old HDD so I will have a look at over the next week or so.

Will keep you posted on my progress. If you manage to sort out the issue then please let me know.


Report •

Ask Question